Ethernet doesn't work on fresh install

Hi guys, I decided to dive into Linux and chose to use Manjaro. I'm dual booting it with Windows 10 following [HowTo] Dual-boot Manjaro - Windows 10 - Step by Step
I ran into some issues throughout it, but in the end, it seems to be working fine. The boot times on Manjaro seem incredibly slow for what it is tho (~4x slower than windows 10)

Now I'm trying to get my internet to work. I'm wired in through ethernet and can't seem to connect. I connected once before when I was booting of the live usb, but now I can't seem to connect.

Here is my inxi:

$ lspci | grep Ethernet
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 05)

$ dmesg | grep eth
[ 2.862411] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) e0:3f:49:b6:23:00
[ 2.862415] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
[ 2.862450] e1000e 0000:00:19.0 eth0: MAC: 11, PHY: 12, PBA No: FFFFFF-0FF
[ 2.864580] e1000e 0000:00:19.0 eno1: renamed from eth0

Let me know if there is any more info that would help. I know for sure the ethernet is working - I'm using it right now on the same computer booted in windows.

Thanks

Hey there,
I offer 2 quick things to try if you havent already.

  1. Try a different kernel (4.14 or even 4.9)
  2. Try a different cable (really)
3 Likes

The 200 series of Intel adapters with the e1000e driver has been having a lot of issues lately.

I would suggest trying kernel 4.20.

Test the kernels @cscs suggested, but don't be afraid to go all the way back to k 4.4.

Make sure your speed is set to auto-negotiation in the connections properties in Network Manager.

Run the set of commands below to see if your connection can be properly initiated.

Please do not cut and paste all the commands together at once.

Enter and run each command separately with a few seconds between each command.

Please post all inputs, and all outputs of that sequence of commands once they are finished being run.

Please do not give me a summary, such as "there were no outputs".

It is very important that you post each input and output to troubleshoot this correctly.

nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set eno1 down

sudo modprobe -r e1000e

sudo modprobe e1000e

sudo ip link set eno1 up

sudo systemctl start NetworkManager

nmcli networking on

3 Likes

I just went over your inxi a little more carefully.

A few suggestions:

BIOS update, yours is getting quite old.

Your adapter state is "up" so that is good news. Reboot the router and try a new cable as per @cscs suggestion. Also try a new port on the router. Check that IP address or MAC filtering is not blocking your computer in your routers settings. Try another router if one is available.

Don't say "it worked on Windows", because Linux drivers react differently to hardware or router settings than Windows drivers.

You need to test for connectivity via ping commands:

ping -c5 8.8.8.8                                                                                

ping -c5 google.com 

ping -c5 127.0.0.1

ping -c5 localhost

Please post all inputs and outputs of any commands that are requested. Do not return a summary such as "no packets received".

Thank you.

I checked and it seems like I'm on the latest version of the BIOS firmware.
Here are the outputs of the commands you sent:

[derek@derek-pc ~]$ nmcli networking off
[derek@derek-pc ~]$ sudo systemctl stop NetworkManager
[derek@derek-pc ~]$ sudo ip link set eno1 down
[derek@derek-pc ~]$ sudo modprobe -r e1000e
[derek@derek-pc ~]$ sudo modprobe e1000e
[derek@derek-pc ~]$ sudo ip link set eno1 up
[derek@derek-pc ~]$ sudo systemctl start NetworkManager
[derek@derek-pc ~]$ nmcli networking on
(no output for any of them)

[derek@derek-pc ~]$ ping -c5 8.8.8.8
connect: Network is unreachable
[derek@derek-pc ~]$ ping -c5 google.com
ping: google.com: Name or service not known
[derek@derek-pc ~]$ ping -c5 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.132 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.024 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.030 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.032 ms
64 bytes from 127.0.0.1: icmp_seq=5 ttl=64 time=0.031 ms

--- 127.0.0.1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 64ms
rtt min/avg/max/mdev = 0.024/0.049/0.132/0.042 ms
[derek@derek-pc ~]$ ping -c5 localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.014 ms
64 bytes from localhost (::1): icmp_seq=2 ttl=64 time=0.042 ms
64 bytes from localhost (::1): icmp_seq=3 ttl=64 time=0.040 ms
64 bytes from localhost (::1): icmp_seq=4 ttl=64 time=0.038 ms
64 bytes from localhost (::1): icmp_seq=5 ttl=64 time=0.034 ms

--- localhost ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 45ms
rtt min/avg/max/mdev = 0.014/0.033/0.042/0.012 ms

I've rebooted my router, but haven't tried a new cable yet. (I don't have any long enough to try right now). And I don't have any routers laying around... I'm using a modem+router combo thing Comcast provided.

I'm in the process of trying a new kernel, but I'm having some issues. I've downloaded the tar files of different kernels but I have no idea how to install them. I know that Manjaro has a kernel wizard built in, but I'm not really quite sure how to get it to use the tar files.

You will need to use phone tethering if you have no means of connecting to the internet.

Installing kernels in Manjaro is super simple. You open Manjaro Setting Manager / Kernel.

Simply click on whichever kernel you want and press the install button. Which kernel do you have installed?

I would test at least these kernels 4.14, 4.19, and 4.20. Always keep at least 2 kernels installed. After installing a new kernel reboot. Pres the ESC key while booting to enter the grub menu. Select the kernel you want to boot from in the grub advanced menu.

The adapter is reaching your router, but it is unable to access the internet.

4.19.13-1 (the one installed) is the only one that appears in the kernel manager. I managed to download the tar files of the kernels you listed, but I am not sure how to install them. (I don't see a way to add them to the kernel manager).

Sadly, I don't have phone tethering available either...

So it seems like it magically fixed itself. My bios reset itself when I tried to boot just now, and now the ethernet works.

Thanks a lot for the help guys

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by