Ethernet Realtek PHY RTL8201EL problems

This network adapter. Realtek PHY RTL8201EL is having many miss behaviours and causing problems.

  1. never conects to the internet. now matter how i configure it. manual ip. automatic, etc.
  2. sometimes it does not even show in the tray as it was not even detected.
  3. trying to shut down the pc, or restart, with the ethernet cable connected to the port will cause manjaro to not shut down or restart. it will just hang on a screen. sometimes with things writen on it. sometimes a empty black screen.

also i have some other stuff about this i would like to say.

  1. it used to work on windows 10 and 7
  2. i already unistaled linux and went back to windows 10 and the ethernet works fine. i did this many times going back and fourth from linux to windows, and it only fails in linux.

here is what the terminal says about my hardware.

  Host: otavio-pc Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux 
  Type: Desktop Mobo: ASRock model: N68-S3 FX serial: <root required> 
  BIOS: American Megatrends v: P1.20 date: 06/04/2012 
  Topology: Quad Core model: AMD FX-4300 bits: 64 type: MCP arch: Bulldozer 
  L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 30551 
  Speed: 1406 MHz min/max: 1400/3800 MHz Core speeds (MHz): 1: 1406 2: 1405 
  3: 1478 4: 1410 
  Device-1: NVIDIA C61 [GeForce 7025 / nForce 630a] vendor: ASRock 
  driver: N/A bus ID: 00:0d.0 
  Device-2: NVIDIA GF108 [GeForce GT 420] vendor: Gigabyte driver: nvidia 
  v: 390.87 bus ID: 02:00.0 
  Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 1366x768~60Hz 
  OpenGL: renderer: GeForce GT 420/PCIe/SSE2 v: 4.6.0 NVIDIA 390.87 
  direct render: Yes 
  Device-1: NVIDIA MCP61 High Definition Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus ID: 00:05.0 
  Device-2: NVIDIA GF108 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 02:00.1 
  Sound Server: ALSA v: k4.19.2-1-MANJARO 
  Device-1: NVIDIA MCP61 Ethernet vendor: ASRock 939NF6G-VSTA Board 
  type: network bridge driver: forcedeth v: kernel port: d080 
  bus ID: 00:07.0 
  IF: enp0s7 state: down mac: bc:5f:f4:d8:af:86 
  Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u 
  bus ID: 1-2:2 
  IF: wlp0s2f1u2 state: up mac: 20:e6:17:05:2d:c5 
  Local Storage: total: 298.09 GiB used: 45.38 GiB (15.2%) 
  ID-1: /dev/sda vendor: Samsung model: HD322HJ size: 298.09 GiB 
  ID-1: / size: 284.10 GiB used: 45.35 GiB (16.0%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.44 GiB used: 33.3 MiB (0.4%) fs: swap dev: /dev/sda2 
  System Temperatures: cpu: 23.1 C mobo: N/A gpu: nvidia temp: 37 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40% 
  Processes: 176 Uptime: 2h 59m Memory: 3.80 GiB used: 2.35 GiB (61.7%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.27 

also while i was filing this bug report i found this console has problems that may be related to what is happening with my network. you see. it thinks my mother board is ASRock 939NF6G-VSTA. its not.
my mother board is a n68-s3 fx
this is a link to the official manufacturer of my mother board
and this is for the motherborad manjaro thinks i have
if you check the specification of each motherborad you will see that they are completely diferent.
chipset is diferent. cpu suported is diferent. the network card is not same.
could it be that manjaro is detecting the wrong hardware, and this is the cause of the malfunction of my network card? and if this is true. my whole hardware may be in trouble.

Firstly I would check for a bios update. Second thing is if you are dual booting with Windows then Windows can disable your network card. To check if this is the issue, power down the computer. Unplug all power cords, and remove all backup battery power sources. Give your computer at least a couple of minute to drain all residual power. Then boot directly into Manjaro.

Try disabling then enabling your adapter in bios. Sometimes reseting your bios to factory default helps as well.

See if that helps, if not:

Please post the outputs of:

rfkill list all


lspci | grep Realtek

my bios was already up to date. 1.20 the last update the manufacturer realesed, should i try it again?
i was not running dual boot. i removed windows last time i changed to linux, because i had given up and decided to go on wifi alone, but changed my mind once the wifi problems started anoying me. and so i came here to seek for a solution.
i already did power down the compputer and removed the battery and disconected from the psu.

after doing this i can no longer boot into manjaro, a black screen is all i got, and is stuck there.

This is a far more serious issue than your Ethernet not working. I would suggest creating a new help thread with full background info on what caused this.

Information on how to post hardware specs and logs on the forum:

by the way when i said a black is all i got, i meant that after the bios screen when the login screen for manjaro is suposed to appears it hangs forever in a black screen. i get the bios screen normaly no problem.

what caused this, i installed linux. ethernet did not work. i came here for help. followed your instructions and there that is how it happened. nothing more to say

editing to ask if my clarification on the black screen thing changes anything before i go created a new help thread

It has been 4 hours since my suggestion to start a proper help request on your current problem, and I see you have not done so. Not only do you not follow my suggestion to get proper help, you make a post inferring my diagnostic commands somehow were responsible for your computer being unbootable. The diagnostic commands I gave you only return information, they change absolutely nothing on your system.

Create a proper help request giving full information about your system if you expect to get your issue resolved. I would also suggest you be more responsive and polite to those who offer assistance (if you expect help).

Good luck with getting your issue resolved.

am i missing something ? to me it looks like inxi says you have a N68-S3 FX and you say its a N68-S3 FX .
where did that other model come into play?

1 Like

Try reseating the battery and all the connections that were unplugged.

Does ctrl+alt+f3 get you to a TTY from the black screen?

it later on the network part talks about the other motherboard. just read the whole thing and you will see

here is it

  Device-1: NVIDIA MCP61 Ethernet vendor: ASRock 939NF6G-VSTA Board 
  type: network bridge driver: forcedeth v: kernel port: d080 
  bus ID: 00:07.0 

i did not posted a new help thread because i could not acces my computer due to the problem i was talking about. my last post was from another computer from someone else that i could not have access 100% of the time.
also what i did that caused the black screen was the removing the baterry. that is all i did.
i did not get to do the other commands because i was doing things in order it was sugested

but my missfortune may be of use to solve this problem as i did not had the manjaro liveusb i had to use something else. i used a debian, linux mint. fedora 28 and 29, my ethernet will not work on any of them. i think this proves its not a problem with manjaro, maybe its the nvidia driver.

i tried to look for nvidia site a way to report this issue but i only found areas accepting bug report from graphic cards no place to put a thread about networking.
i think they dont support this network driver anymore

i dont think you can help anymore
unless you want to take nvidia job on supporting this
if that is so i will download the installation for manjaro again and we may continue
edit to fix a missing word

there are 2 models of your motherboard, N68-S3 UCC and N68-S3 . one has the ability to Unlock Cpu Core.
N68-S3 has updates to 1.20 like you already have.
N68-S3 UCC has updates up to 1.60.

im not saying this is your answer but you might want to get your eyes on the board itself and double check, just a suggestion.

there are more than 2 models of this motherboard. mine is not N68-S3 nor N68-S3 UCC, mine is N68-S3 FX

this is the ucc
this is mine
and this is the last one

i just figured out. the reason of the black screen after trying to reset the motherboard may just because by default it boots with USB first. i may had a non bootable usb when the problem happened. black screen is what my pc gives me when i boot with usb boot and not bootable usb

everything is working now?

ethernet still not working.
other than that its ok.

by the way since i need internet i had to make this be a dual boot.
while previously i was not dual booting with windows now i am since this is the only os that the internet works. what was the worries about it?

im looking for drivers for the rtl8201, realtek has not even 1 mention of that card anywhere on its site.
im looking elsewhere, your other option would be just buy a cheap network card or usb dongle for like $5-$15 and use that, at the very least it would be an upgrade to the integrated one on your board.

can you post output for
lspci -nn
mhwd -li
dmesg | tail -n 60

better yet

dmesg | grep -i -E 'eth'

it looks like rtl8201el is just another name for nvidia mcp61 ethernet which both use forcedeth driver.

same problem and a solution:

Please post the outputs @dglt requested if your issue is not resolved.

The result for all the 3 commands

 lspci -nn
00:00.0 RAM memory [0500]: NVIDIA Corporation MCP61 Host Bridge [10de:03e2] (rev a1)
00:01.0 ISA bridge [0601]: NVIDIA Corporation MCP61 LPC Bridge [10de:03e1] (rev a2)
00:01.1 SMBus [0c05]: NVIDIA Corporation MCP61 SMBus [10de:03eb] (rev a2)
00:01.2 RAM memory [0500]: NVIDIA Corporation MCP61 Memory Controller [10de:03f5] (rev a2)
00:02.0 USB controller [0c03]: NVIDIA Corporation MCP61 USB 1.1 Controller [10de:03f1] (rev a3)
00:02.1 USB controller [0c03]: NVIDIA Corporation MCP61 USB 2.0 Controller [10de:03f2] (rev a3)
00:04.0 PCI bridge [0604]: NVIDIA Corporation MCP61 PCI bridge [10de:03f3] (rev a1)
00:05.0 Audio device [0403]: NVIDIA Corporation MCP61 High Definition Audio [10de:03f0] (rev a2)
00:06.0 IDE interface [0101]: NVIDIA Corporation MCP61 IDE [10de:03ec] (rev a2)
00:07.0 Bridge [0680]: NVIDIA Corporation MCP61 Ethernet [10de:03ef] (rev a2)
00:08.0 IDE interface [0101]: NVIDIA Corporation MCP61 SATA Controller [10de:03f6] (rev a2)
00:08.1 IDE interface [0101]: NVIDIA Corporation MCP61 SATA Controller [10de:03f6] (rev a2)
00:09.0 PCI bridge [0604]: NVIDIA Corporation MCP61 PCI Express bridge [10de:03e8] (rev a2)
00:0b.0 PCI bridge [0604]: NVIDIA Corporation MCP61 PCI Express bridge [10de:03e9] (rev a2)
00:0c.0 PCI bridge [0604]: NVIDIA Corporation MCP61 PCI Express bridge [10de:03e9] (rev a2)
00:0d.0 VGA compatible controller [0300]: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] [10de:03d6] (rev a2)
00:18.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0 [1022:1600]
00:18.1 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1 [1022:1601]
00:18.2 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2 [1022:1602]
00:18.3 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3 [1022:1603]
00:18.4 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4 [1022:1604]
00:18.5 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5 [1022:1605]
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 420] [10de:0de2] (rev a1)
02:00.1 Audio device [0403]: NVIDIA Corporation GF108 High Definition Audio Controller [10de:0bea] (rev a1)

 mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
    video-nvidia-390xx            2018.08.09               false            PCI

Warning: No installed USB configs!

 dmesg | grep -i -E 'eth'
[    8.475883] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[    9.023817] forcedeth 0000:00:07.0: ifname eth0, PHY OUI 0x732 @ 1, addr bc:5f:f4:d8:af:86
[    9.023821] forcedeth 0000:00:07.0: highdma pwrctl mgmt lnktim msi desc-v3
[    9.512740] forcedeth 0000:00:07.0 enp0s7: renamed from eth0
[   15.879671] forcedeth 0000:00:07.0 enp0s7: MSI enabled
[   15.879895] forcedeth 0000:00:07.0 enp0s7: no link during initialization
[   16.349122] Modules linked in: arc4 uinput nvidia_drm(POE) nvidia_modeset(POE) drm_kms_helper edac_mce_amd drm agpgart kvm_amd mt7601u ccp mac80211 rng_core kvm k10temp cfg80211 nvidia(POE) input_leds ppdev fam15h_power rfkill joydev mousedev snd_hda_codec_via snd_hda_codec_generic snd_hda_codec_hdmi irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel pcbc aesni_intel aes_x86_64 crypto_simd syscopyarea sysfillrect cryptd sysimgblt fb_sys_fops glue_helper pcspkr pcc_cpufreq acpi_cpufreq evdev parport_pc parport forcedeth snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep snd_pcm snd_timer snd soundcore mac_hid i2c_nforce2 ipmi_devintf ipmi_msghandler crypto_user ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 fscrypto hid_generic usbhid hid sr_mod cdrom sd_mod uas usb_storage ata_generic

edit: my ethernet cable was disconected when i did this so i could shut down and reboot. i think i mentioned before that if i try to shut down of reboot manjaro with the cable connected it will hang on forever and never reboot or shut down. now when i connect the cable it will not detect as if i did not even had a ethernet card


after your booted up and connected and see if it returns anything

@tbg would know more about this but i think your ethernet adapter needs to be set "up"

sudo ip link set enp0s7 up
sudo systemctl restart NetworkManager

Forum kindly sponsored by