Ethernet Realtek PHY RTL8201EL problems

ping 8.8.8.8 says Network is unreachable

when i booted up my pc today it was detecting the wired card again. but then i did the
sudo ip link set enp0s7 up
sudo systemctl restart NetworkManager

and after that i was not detecting anything anymore, it hangs on sometime, the tray icon for the network becomes unclickable, and when i can click again. it does not show a cable connection anymore as if i did not had any

i rebooted and it was detecting again. did the command again and the same happened

i reboot a 3th time and this time the cable connection was not being detected since the boot.
and doing the commands
sudo ip link set enp0s7 up
sudo systemctl restart NetworkManager
made it be detected but still cant connect and ping 8.8.8.8 has the same result

edit: do i need to try the things in the link dglt gave me?

i could be wrong but i think those commands would work better in reverse (my fault, i know) and check
inxi -n
to see if your ethernet state reports up and not down and try to ping again.

can it really hurt? i looked for a while yesterday before i found that thread, while not exactly the same issue, its very similar and there really isnt much documentation/forum posts out there regarding your card. sorry i cant be of more definitive help. @tbg is the networking "whisperer" around these parts AFAIK and for sure knows more than I

i did it in reverse. and the result of inxi -n is this

Network:
  Device-1: NVIDIA MCP61 Ethernet type: network bridge driver: forcedeth 
  IF: enp0s7 state: down mac: bc:5f:f4:d8:af:86 
  Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u 
  IF: wlp0s2f1u1 state: up mac: 20:e6:17:05:2d:c5 

ping still does the same results. unreachable

i was looking for the other posts you gave me. but they point to things that does not even exist on my system, the /etc/netctl/mynet. there is no netctl folder inside the etc folder.
i believe whattever they did it was in a older version of manjaro and that is why i dont have these folder.
they may have changed location or i dont need these at all. so i may need a new solution

i cant do
dig @8.8.8.8 google.com
it says dig. command not found.

my resolvconf looks like this

Generated by NetworkManager

search bloi.com.br
nameserver 192.168.1.1
nameserver fe80::12c2:5aff:fe8d:497%wlp0s2f1u1

edit: i have not tried to disable ipv6 because they said i should not do for no reason, i guess they meant i should try to fix the other ways first

in your case it seems like you cant even get it to enable itself. have you tried going into manjaro settings manager/hardware configuration. check show all devices then find anything related to your ethernet card and uninstall it then re-install.
have you done a full system update since installation? cant hurt to do before re-installing eth

that is if your wifi works to do so. also was your ethernet card working on the live iso before you installed?

there is nothing about ethernet card in there. only video card.

i searched myself, its seems that all people with this same motherboard. as well as some other. have this problem. one of the possible solution is the driver for the network card. i suposed to unistall and black list the one that comes with the kernel then instal the nvidia proprietary driver. but how can i do it?

if you open msm and check the box that says "show all devices" and scroll down you dont see anything listed in the network controller dropdown?

also, the only driver i could find for your ethernet was forcedeth.c , even nvidia says to use it.

you have tried using older kernels? 4.14 4.9 4.4?

1 Like

still only shows video drivers.

by the way the results that i forgot for

rfkill list all

 rfkill list all
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

lsmod

 lsmod
Module                  Size  Used by
sg                     40960  0
st                     65536  0
fuse                  118784  5
ccm                    20480  6
edac_mce_amd           28672  0
arc4                   16384  2
kvm_amd               106496  0
ccp                    98304  1 kvm_amd
rng_core               16384  1 ccp
kvm                   737280  1 kvm_amd
snd_hda_codec_via      24576  1
snd_hda_codec_generic    86016  1 snd_hda_codec_via
mt7601u               122880  0
mac80211              929792  1 mt7601u
irqbypass              16384  1 kvm
snd_hda_codec_hdmi     57344  4
crct10dif_pclmul       16384  0
crc32_pclmul           16384  0
mousedev               24576  0
cfg80211              778240  2 mt7601u,mac80211
input_leds             16384  0
rfkill                 28672  3 cfg80211
joydev                 24576  0
ghash_clmulni_intel    16384  0
pcbc                   16384  0
snd_hda_intel          45056  6
aesni_intel           200704  4
aes_x86_64             20480  1 aesni_intel
ppdev                  20480  0
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_via
crypto_simd            16384  1 aesni_intel
cryptd                 28672  3 crypto_simd,ghash_clmulni_intel,aesni_intel
snd_hda_core           94208  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_via
snd_hwdep              16384  1 snd_hda_codec
fam15h_power           16384  0
snd_pcm               131072  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
glue_helper            16384  1 aesni_intel
forcedeth              73728  0
pcspkr                 16384  0
k10temp                16384  0
parport_pc             49152  0
snd_timer              36864  1 snd_pcm
parport                57344  2 parport_pc,ppdev
snd                    98304  19 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_hda_codec_via,snd_pcm
soundcore              16384  1 snd
i2c_nforce2            16384  0
evdev                  24576  14
mac_hid                16384  0
pcc_cpufreq            16384  0
acpi_cpufreq           24576  0
uinput                 20480  0
nvidia_drm             45056  1
nvidia_modeset       1110016  3 nvidia_drm
drm_kms_helper        208896  1 nvidia_drm
drm                   495616  4 drm_kms_helper,nvidia_drm
agpgart                49152  1 drm
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
nvidia              14401536  83 nvidia_modeset
ipmi_devintf           20480  0
ipmi_msghandler        65536  2 ipmi_devintf,nvidia
crypto_user            16384  0
ip_tables              28672  0
x_tables               45056  1 ip_tables
ext4                  733184  1
crc32c_generic         16384  0
crc16                  16384  1 ext4
mbcache                16384  1 ext4
jbd2                  126976  1 ext4
fscrypto               32768  1 ext4
hid_generic            16384  0
usbhid                 57344  0
hid                   139264  2 usbhid,hid_generic
sr_mod                 28672  0
cdrom                  69632  1 sr_mod
sd_mod                 61440  3
ata_generic            16384  0
pata_acpi              16384  0
sata_nv                36864  2
pata_amd               24576  0
ohci_pci               16384  0
libata                278528  4 pata_amd,pata_acpi,ata_generic,sata_nv
crc32c_intel           24576  2
scsi_mod              253952  5 st,sd_mod,libata,sg,sr_mod
ehci_pci               16384  0
ehci_hcd               94208  1 ehci_pci
ohci_hcd               57344  1 ohci_pci

lspci | grep Realtek does nothing

i think you should try some of the older lts kernels. you could try and disable the wifi card temporarily and see if the ethernet will take over but that is based on nothing factual, just guessing here at this point. some older hardware gets along better with the older kernels

most likely to solve your problem = older kernel

1 Like

how i know what my driver currently is?
and no i have no tried other kernel.

forcedeth is what it is already using.

try the 4.4 or 4.9 kernel.
TBO, i kinda feel dumb for not suggesting it earlier

you said first forcedeth.c i remember the solution i was talking about it was to black list a forcedeth.something so to install a forcedeth.somethingelse

ill take another look, but i think trying other kernels is your easiest/best option at the moment, very quick and automated from settings manager

i did download and installed another kernel. but it seems to not be runing right now. i need to reboot?

reboot and at grub choose advanced options and select new kernel

if whatever kernel you just installed doesnt work, try 3.18 then try the others i suggested.

trial and error, also check if your able to ping on each one, if your able to do that then you have something we can try to work with

a more educated birdie than i provided something for you to try . next time your on try these commands in terminal if changing the kernel alone doesnt work:

sudo systemctl stop NetworkManager
sudo ip link set enp0s7 down 
sudo modprobe -r forcedeth
sudo modprobe forcedeth
sudo ip link set enp0s7 up
sudo systemctl start NetworkManager

one line at a time and see if your ethernet turns on

sudo modprobe -r forcedeth
caused manjaro to freeze. i had to do a hard reboot
ere
speaking of hard reboots. whenever i have the cable connected the os will refuse to shut down or reboot, i always have to do a hard shut down or reboot. and as far as i know this is bad is not it?

also my tray now freezes when i click on it

just tried all the 3 kernel you said. none worked. i could not do the commands you gave me because of the freezing thing

I have added some new driver options, try this.

sudo systemctl stop NetworkManager 
sudo ip link set enp0s7 down 
sudo modprobe forcedeth msi=0 msix=0 
sudo ip link set enp0s7 up 
sudo systemctl start NetworkManager

Also please post:

dmesg | grep -i forcedeth

journalctl -b | grep -i forcedeth

could this be him not having the correct linux headers for those kernels? or is that only in a case where he would be building new drivers?

Forum kindly sponsored by