Ethernet stops working after a system suspend

hi ,
I'm running manjaro , with Deepin DE . here is inxi -Fxz output :

  Host: master-pc Kernel: 4.19.106-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.1 Desktop: Deepin 15.8 Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 33668DG v: ThinkPad Edge E530c 
  serial: <filter> 
  Mobo: LENOVO model: 33668DG serial: <filter> UEFI [Legacy]: LENOVO 
  v: J0ET15WW (1.05 ) date: 08/02/2013 
  ID-1: BAT0 charge: 27.3 Wh condition: 31.1/40.4 Wh (77%) model: LGC 45N1049 
  status: Discharging 
  Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20751 
  Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1197 4: 1197 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA GF119M [GeForce 610M] driver: N/A bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.7 driver: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.3.4 
  direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.19.106-1-MANJARO 
  Device-1: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network Adapter driver: wl v: kernel port: efa0 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.00-NAPI port: 2000 bus ID: 0c:00.0 
  IF: enp12s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 465.76 GiB used: 267.20 GiB (57.4%) 
  ID-1: /dev/sda vendor: Western Digital model: WD5000LPVX-08V0TT2 
  size: 465.76 GiB 
  ID-1: / size: 186.44 GiB used: 174.83 GiB (93.8%) fs: ext4 dev: /dev/sda3 
  ID-2: swap-1 size: 10.74 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
  System Temperatures: cpu: 29.8 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 175 Uptime: 15m Memory: 3.46 GiB used: 1.24 GiB (35.9%) 
  Init: systemd Compilers: gcc: 9.2.1 Shell: zsh v: 5.8 inxi: 3.0.37 

I connect to my modem using an Ethernet cable , and it works perfectly :
here is more information about the Ethernet connection :

after a system suspend the connection is established ,but it says trying to obtain ip address , and so I don't have internet access .
Why is that happening?
I tried log-off and log-in again , also I tried unplugging the Ethernet cable , and plug it again . None of them is working .

Try this first:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by