Ethtool not detecting interface

Hello everyone!

I have a Lenovo Y540. I get the following error when I try to use ethtool on my ethernet interface:

[sam_sepi0l@kushagra-legion ~]$ sudo ethtool enp7s0 
[sudo] password for sam_sepi0l: 
Settings for enp7s0:
Cannot get device settings: No such device
Cannot get wake-on-lan settings: No such device
Cannot get message level: No such device
Cannot get link status: No such device
No data available

It is worth noting that I have Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet as my ethernet controller and the ip a command previously did not show the interface "enp7s0". Previously the driver field for the realtek controller in the inxi command said "drivers:n/a" so I thought that must've been the problem . So I did some digging and found out that the r8168 driver that I had was blacklisted and that another driver r8169 was already available in the kernel. So I uninstalled the r8168 driver from my system and the r8169 driver now shows up in the inxi command. However the issue still persists.

The interface state of enp7s0 is currently down (as seen in inxi) and I have tried multiple commands to get it to go up but to no avail.

image

[sam_sepi0l@kushagra-legion ~]$ inxi -Fxxxz    
System:    Host: kushagra-legion Kernel: 5.5.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.3 
           tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81SY v: Lenovo Legion Y540-15IRH-PG0 serial: <filter> Chassis: type: 10 
           v: Lenovo Legion Y540-15IRH-PG0 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <filter> UEFI: LENOVO v: BHCN36WW date: 02/10/2020 
Battery:   ID-1: BAT0 charge: 10.3 Wh condition: 46.7/52.5 Wh (89%) volts: 10.9/11.3 model: LGC L17L3PG1 type: Li-poly 
           serial: <filter> status: Discharging cycles: 168 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 1100 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 1100 2: 1100 3: 1100 4: 1101 5: 1101 6: 1100 7: 1101 
           8: 1101 9: 1101 10: 1100 11: 1100 12: 1100 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Lenovo driver: N/A bus ID: 01:00.0 
           chip ID: 10de:1f91 
           Display: x11 server: X.Org 1.20.7 driver: modesetting compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.5 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10fa 
           Sound Server: ALSA v: k5.5.11-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus ID: 07:00.0 chip ID: 10ec:8168 
           IF: enp7s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 92.58 GiB (7.9%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFS256GD9TNG-L3A0B size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 80040C10 scheme: GPT 
           ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-24Z10 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 1A05 scheme: GPT 
Partition: ID-1: / size: 95.47 GiB used: 26.17 GiB (27.4%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-2: /home size: 294.28 GiB used: 66.41 GiB (22.6%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 292 Uptime: 7m Memory: 7.66 GiB used: 1.27 GiB (16.6%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           clang: 9.0.1 Shell: bash v: 5.0.16 running in: yakuake inxi: 3.0.37

The output of ip a is as follows:

[sam_sepi0l@kushagra-legion ~]$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 98:fa:9b:86:84:ef brd ff:ff:ff:ff:ff:ff
3: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 40:74:e0:0d:80:b3 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.38/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20f3
       valid_lft 43176sec preferred_lft 43176sec
    inet6 fe80::b0:979d:eaab:6410/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

Please help and thank you for your time.

Why complicating it and using that? KDE by default is using networkmanager that has the cli and ui already.

Hello!

Actually we had an assignment that required us to use ethtool to figure out the speed of the NIC and other various details. In doing the assignment, I encountered this issue and noticed the drivers for the Realtek controller were missing and decided to fix that as well. In any case, ethtool should ideally be able to detect the interface but it is not doing so.

Is network manager able to show the details of network interfaces as well?

nmcli should provide information, yes, and you will also have the possibility to consult nmcli(1) and nmcli-examples(7) manual pages for complete usage details.

ok I will look into it. Thank you!

Do you know of a way of achieving this as well? I have tried many commands from multiple forums but have yet to find one that works.

I appreciate the honesty on that, but just so you know
https://wiki.manjaro.org/index.php?title=Forum_Rules#Homework
Since i do not use that tool and never had the need to do it on any of my installs, i have no idea why is not doing what is suppose to do. My guess is that having two network managers trying to manage the interfaces each on their own, are getting in conflict, same as would conflict connman with nmc ... even tho as packages do not conflict one to each other, but as services.

My intention was not to get help with my assignment. I only stated that so as to explain why I was adamant on using ethtool for this task. My reason for asking the question was because ethtool was giving me unexpected errors due to my network card drivers and interface which I had trouble dealing with in the first place as I am a newbie to Manjaro. Sorry if I caused some misunderstanding or wasn't clear on that.:sweat_smile:

No worries :slight_smile:
You say that

Is the nmcli giving you errors too? If not, then might be something else, and my only guess is

:slight_smile:

I also get this error on startup regarding the interface.

IMG_20200401_211818

It does show up on typing nmcli device show but its apparently off.

image

So you practically enabled the dhcpcd service, you have NetworkManager and ethool and you don't know why that network interface is acting strange? Is because now it has to listen to 3 sources of commands ...
:slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by