Evey boot .xinitrc is copied to bash_history

Since a few weeks, the entire text of .xinitrc is copied on my bash_history file every time I boot the system.
There are a few closed thread on the forum:
.bash_history is having .xinitrc appended to its end with each boot
.xinitrc content fill my .bash_history
but no solutions are specified.

I basically tried to rename the .xinitrc file, delete and recreate it, but nothing is changed after the reboot. And the same for bash_history file.
This issue is only on my desktop pc, while it's not happening on my laptop, where the system is almost a copy of the other, xfce DE, installed aprox. 3 years ago

It's annoying, cause every time I recall a command from the terminal I get the text from .xinitrc.

Any idea? Thanks in advance

I think the solution is listed there.

Thanks for the reply, I have already tried that workaround, but it sadly did not work for me

The only workaround that's working is completly deleting .xinitrc, it stops with the problem!
But is this a good solution?

Good question... I have been running that way since Dec 6

https://archived.forum.manjaro.org/t/bash-history-is-having-xinitrc-appended-to-its-end-with-each-boot/13937/4?u=kmartin

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by