executables (gminer/bfgminer) wont run on manjaro

I just downloaded gminer. Its a simple cryptominer, which has a simple one line setup. Then you simply click the executable and it should open up in terminal and run, although nothing happens.
I also tried bfgminer which is available in the software repository for manjaro with the same result.

Anybody have any experience with these mining programs?

  1. You may need to make both of the files executable: chmod +x .
  2. You should run both of the file via terminal: ./.

Thanks ive used the right click method and checked them, and it says they are executable. There is something not working correctly, or should i do as you suggest and go to the directory using terminal where they are and try there with chmod+x ?Screenshot_2020-08-05_00-37-43

maybe the exclamation mark has something to do with it???? That Manjaro has blocked programs like this from running??

There is nothing blocked.

Just run it in the terminal and look for errors.

/home/les/gminer/miner

Also bfgminer is in the repository. Downloading any program form a website is always a very bad idea.

1 Like

One does not simply click an executable. :wink:

Executable binaries are meant to run from the terminal, not a GUI. Some file managers allow it, but it's not default on most. If you install a program that doesn't have a application menu shortcut, check the documentation to see what binaries it contains and what they do.

ok thanks for that. How do i set a mining program up to run from a terminal?

Forum kindly sponsored by