External monitor not consistently detected

Hi everyone,

I'm currently having a bit of an issue with getting my computer to detect an external monitor. I've never had a problem before having monitors automatically detected, and using xrandr and arandr, but I recently reinstalled Manjaro and I'm running into a couple of problems.

My external monitor will be detected on HDMI1 when I boot my computer but if I decided to turn off the monitor using xrandr or arandr and then try to turn the display back on, the display won't be detected. Additionally, if my laptop is already on and then I plug in external monitor it won't be detected at all.

Is there something I'm missing here?

I've currently got a fresh install of Manjaro and I'm using i3wm.

:+1:Welcome to Manjaro!:+1:

  1. "You've never had any problems with this specific hardware set-up before and this issue cropped up suddenly" OR "You've never had any problems using xrandr on other HW setups before."?

  2. Please read this:
    How to provide good information in your posts
    and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:wink: :+1: :innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

Thanks for your reply;

  1. Both statements are true really;
  • I haven't had any set up issues with this specific hardware and it has only occurred on this install of Manjaro.
  • Also, I've never had problems with xrandr using this hardware setup before, and using this hardware setup with my previous Manjaro installation before.
  1. I've updated my profile now, but let me know if there is any specific information I should be posting that I've missed

Post what you've tried already and the results (Please be specific) and post your system configuration as described in the post I referred to earlier.

Please help us help you!



There hasn't really been much to try, but here are the few straightforward things I've done:

  • If I plug in the monitor and it doesn't come up in arandr, I'll run xrandr to check but usually see the same result.
  • Turning the monitor on and off while it is still plugged into the computer doesn't change anything
  • Rebooting the computer with the monitor plugged in and on, will fix it.

Below is the output of inxi -Fxxxza --no-host

  Kernel: 5.4.18-1-MANJARO x86_64 bits: 64 compiler: gcc
  v: 9.2.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
  root=UUID=6b95a48d-2c93-4f36-9f88-818678af1e38 rw quiet
  apparmor=1 security=apparmor udev.log_priority=3
  Desktop: i3 4.17.1 info: i3bar dm: LightDM 1.30.0
  Distro: Manjaro Linux
  Type: Laptop System: LENOVO product: 20KHCTO1WW
  v: ThinkPad X1 Carbon 6th serial: <filter> Chassis:
  type: 10 serial: <filter>
  Mobo: LENOVO model: 20KHCTO1WW v: SDK0J40697 WIN
  serial: <filter> UEFI: LENOVO v: N23ET59W (1.34 )
  date: 11/08/2018
  ID-1: BAT0 charge: 14.7 Wh
  condition: 45.9/57.0 Wh (80%) volts: 11.1/11.5
  model: SMP 01AV431 type: Li-poly serial: <filter>
  status: Discharging cycles: 315
  Topology: Quad Core model: Intel Core i5-8250U bits: 64
  type: MT MCP arch: Kaby Lake family: 6
  model-id: 8E (142) stepping: A (10) microcode: CA
  L2 cache: 6144 KiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2
  ssse3 vmx
  bogomips: 28808
  Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz):
  1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
  Vulnerabilities: Type: itlb_multihit
  status: KVM: Split huge pages
  Type: l1tf mitigation: PTE Inversion; VMX: conditional
  cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass mitigation: Speculative Store
  Bypass disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers
  and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline,
  IBPB: conditional, IBRS_FW, STIBP: conditional, RSB
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Lenovo
  driver: i915 v: kernel bus ID: 00:02.0
  chip ID: 8086:5917
  Display: x11 server: X.Org 1.20.7 driver: intel
  unloaded: modesetting alternate: fbdev,vesa
  compositor: compton resolution: 1920x1080~60Hz
  renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
  v: 4.6 Mesa 19.3.4 compat-v: 3.0 direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio
  vendor: Lenovo driver: snd_hda_intel v: kernel
  bus ID: 00:1f.3 chip ID: 8086:9d71
  Sound Server: ALSA v: k5.4.18-1-MANJARO
  Device-1: Intel Ethernet I219-V vendor: Lenovo

Please be more specific:

  • What is the exact xrandr command you typed and its output?
  • What is the output of xrandr --verbose when the monitor is working and the same output when it's not.
  • What are the hardware capabilities of your monitor on top of what's listed by xrandr? (last one only if applicable)

Please help us help you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by