External monitor not detected

Hi

I’m complete newbie, trying to wrap my head around all this ... external monitor not being detected ... originally Manjaro at least detected my external monitor, but now it’s not even detected under settings/display, only shows laptop display, no external hdmi display ... even although I tried all the available drivers again (except vesa).
Update: I ran ... optimus-manager and selected Nvidia GPU only ... then the external was temporally detected and on, but no menu/panels showed, so I restarted, but it seemed to default back to just the laptop monitor, in settings NO external showing again.

Is there anyway to “factory” restore the system back to what it was when it was first installed from flash drive files, without effecting the newly installed apps and user files?
I posted another query about the drivers here ... but I’m thinking seeing I tried all drivers, maybe it’s some other setting that’s stopping the external monitor from being detected and used ...

rob@rob-dellxpsl502x ~]$ inxi -Fxxxza --no-host
System: Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64
root=UUID=17e7c708-1792-49fe-9df2-448b23ff19b5 rw
quiet apparmor=1 security=apparmor
resume=UUID=0a20dec3-73a0-4338-aed6-83e8e3d40cca
udev.log_priority=3
Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 wm: kwin_x11 dm:
SDDM Distro: Manjaro Linux
Machine: Type: Portable System: Dell product: Dell System XPS L502X v:
N/A serial: Chassis: type: 8
v: 0.1 serial: 
Mobo: Dell model: 0714WC serial: UEFI [Legacy]:
Dell v: A12 date: 09/07/2012
CPU: Topology: Quad Core model: Intel Core i7-2630QM bits: 64
type: MT MCP arch: Sandy Bridge family: 6
model-id: 2A (42) stepping: 7 microcode: 2F L2 cache: 6144 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 31941
Speed: 798 MHz min/max: 800/2900 MHz Core speeds (MHz): 1:
798 2: 798 3: 798 4: 798 5: 798 6: 798
7: 798 8: 798
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge
pages
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache
flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass
disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and
__user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel 2nd Generation Core Processor Family
Integrated Graphics vendor: Dell driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:0116
Device-2: NVIDIA GF108M [GeForce GT 540M] driver: N/A bus
ID: 01:00.0 chip ID: 10de:0df4
Display: x11 server: [X.Org](http://X.Org) 1.20.8 driver: modesetting
compositor: kwin_x11
resolution: 1920x1080~60Hz
OpenGL: renderer: N/A v: N/A direct render: N/A
Audio: Device-1: Intel 6 Series/C200 Series Family High Definition
Audio vendor: Dell
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID:
8086:1c20
Device-2: NVIDIA GF108 High Definition Audio driver:
snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:0bea
Sound Server: ALSA v: k5.6.19-2-MANJARO
Network: Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak]
driver: iwlwifi v: kernel port: efa0
bus ID: 03:00.0 chip ID: 8086:008a
IF: wlp3s0 state: up mac: 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit
Ethernet driver: r8169 v: kernel port: 2000
bus ID: 06:00.0 chip ID: 10ec:8168
IF: enp6s0 state: down mac: 
Device-3: Dell F3607gw v2 Mobile Broadband Module type: USB
driver: cdc_acm,cdc_ether,cdc_wdm
bus ID: 2-1.6:4 chip ID: 413c:8184 serial: 
IF: wwp0s29u1u6i6 state: down mac: 
Drives: Local Storage: total: 698.64 GiB used: 65.52 GiB (9.4%)
ID-1: /dev/sda vendor: Seagate model: ST9750420AS size:
698.64 GiB block size: physical: 4096 B
logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial:
rev: DEM1 scheme: MBR
Partition: ID-1: / raw size: 689.83 GiB size: 678.01 GiB (98.29%) used:
65.52 GiB (9.7%) fs: ext4
dev: /dev/sda1
ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap
swappiness: 60 (default)
cache pressure: 100 (default) dev: /dev/sda2
Sensors: System Temperatures: cpu: 49.0 C mobo: 49.0 C
Fan Speeds (RPM): N/A
Info: Processes: 215 Uptime: 1h 25m Memory: 7.67 GiB used: 1.06 GiB
(13.8%) Init: systemd v: 245
Compilers: gcc: 10.1.0 alt: 8 Shell: bash v: 5.0.18 running
in: konsole inxi: 3.0.37

[rob@rob-dellxpsl502x ~]$ mhwd -li

Hi!
You need to config your dual graphics, search in the forum about optimus manager

Update: I did and I ran ... optimus-manager and selected Nvidia GPU only ... then the external was temporally detected and on, but no menu/panels showed, so I restarted, but it seemed to default back to just the laptop monitor, in settings NO external showing again.

Hi!
That happens because you have the monitor mode on extended, don't show any panels, you should have some fn keys to change it, also from the monitor icon on systray.
If you want to use the dual graphics like on pc, for now you just can't
The nvidia driver 450, it would be the next, it should be able to do that. We just have to wait and see.
I have an amd/nvidia and like you only can use the hdmi output if use nvidia only

I just used optimus manager with Nvidia driver for Nvidia gpu and Linux driver for intel GPU ... with intel GPU it runs Only the laptop monitor, so I switch to Nvidia GPU and get both monitors “working” or at least on, BUT it’s all messed up, everything is distorted, eventually lags and then freezes, also when using Nvidia GPU with Nvidia driver, both displays are on, BUT the mouse curser is restricted only to the external monitor and everything I try open, opens up on the laptop monitor and is out of reach to try and use.
Should I uninstall optimus manager rather, does prime work better without optimus manager, is there conflict .., is the away to get it back to its original settings which at least worked far better than it is now ... ?
I wish someone in this forum would start giving some real assistance, rthis is my third post and hardly any help, it’s off putting first experience on Linux. I’ve done lots of reading but I’m no techie so most I read very confusing.

Ps ... I’m not sure how much it matters or not, but I tried opening the “x server” a number of times and it keeps giving error message that Nvidia driver/card that support “x” can’t be found

Hi!
You can use prime or optimus manager, using both doesn't gonna work

Must both be installed though, or must I uninstall prime if I use optimus and visa versa?

Hi
It's better if you uninstall one of them

I have a new problem, Chose latest Nvidia driver, in optimus manager, chose start with Nvidia , but when I rebooted, it doesn’t work, just blank ... I’m assuming chosen to run on Nvidia, but driver not compatible. What to do now ... complete reinstall or any other way?

Hi!
Follow this guide

1 Like

The simple answer is, that by default on hybrid GPU laptops Manjaro installs hybrid Intel-Nvidia setup. Alas, the current Nvidia drivers don't support outputting to secondary monitor on hybrid mode. Only Intel and Nvidia mode work with secondary monitors. This is fixed in 450xx driver series where hybrid mode has ability to support multimonitors, but it's not available on Manjaro yet. Luckily it shouldn't be too long to have them on Manjaro as well.

For more details about other driver setups on hybrid GPUs, see my tutorial - link in the post above :slight_smile: .

2 Likes

Hi there , thanks for info ... my laptop is not in great condition, laptop monitor still working but damaged, I’m artist/illustrator so rely on external monitor. Also battery no longer exists so works completely off mains, so conserving power is not my main objective, although it’s still always good, don’t want over heating etc,

I’m new to Linux, tired of windows struggles, so far found Manjaro to be the best Linux for me ... but need external to work at its best.
If I install “free Linux drivers” , external seems to work, but seems to lag on graphics work, so ideally need Nvidia I think.
When,I chose an option to install “non free”, it chose Bumblebee, but I could find a way for it to recognize my external monitor (maybe I missed something or doing something wrong. Ps ... when I chose Nvidia and bumble be 390xx version, my supystem just seemed to crash, so have to stick with 340xx ... saw posts where others also had trouble with 390xx)

What would be my best option so far for using external monitor?
Also, should I still be using the optimus-manager feature and bbs switch if I’m more focused on external monitor use and working off mains only?
PS .. follow up... it’s weird, originally with “Linux video install” the system automatically detected and displayed external monitor. This morning I switched on and now external not detectable. I tried different drivers, nothing detects it now. Getting pretty frustrating.

Sorry my knowledge very limited for now on Linux, I’m not all that technical and programming minded (arty brain lol), I’m kinda shooting in the dark, trying to find my target.

Specs: ( old laptop, legacy GPU) Dell System XPS L502X
Graphics: Device-1: Intel 2nd Generation Core Processor Family
Integrated Graphics vendor: Dell driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:0116
Device-2: NVIDIA GF108M [GeForce GT 540M] driver: N/A bus
ID: 01:00.0 chip ID: 10de:0df4

image

Darn ... Things just got worse again, I suck at this ...
I was trying t o uninstall the Bumblebee driver but it wouldn’t let me as it said it was depended on CUDA , so I uninstalled Nvidia utilities along with a few other files and I messed up, got this empty space under hardware where the drivers are supposed to show .l. Any ideas, any help to get me set and external monitor working? Please ...

image

In that case there is no need to use switchable graphic, set Nvidia only mode. Use MHWD to change configuration.

See Manjaro Wiki:

https://wiki.manjaro.org/index.php/Configure_Graphics_Cards

So, uninstall CUDA if you have it. I'm not sure why people install it so often - it's only for developers, for regular users it's a useless package.
Then uninstall current bumblebee setup:

sudo mhwd -r video-hybrid-intel-nvidia-340xx-bumblebee

If it's already uninstalled, it will return error.
Try installing Nvidia only in terminal (forced setup) by:

sudo mhwd -f -i pci video-nvidia-340xx

Then start with this tutorial's point 3 (fix mhwd configuration):

Since you messed up royally ;), you may have some unexpected responses, so in case any troubles, copy the terminal output and post it here.

If you want to know what you did, I try to explain it briefly:

MHWD configuration setups are not drivers per se, but a full package and drivers configuration. You shouldn't manually mess with drivers but use MHWD.
So Manjaro automatically installed for you Intel drivers, Nvidia drivers, Bumblebee and configured everything so it would work. You manually uninstalled Nvidia drivers (nvidia-utility packages ARE THE DRIVERS, or at least the part outside kernel modules, I know the naming is confusing and misleading). What you should have done was simply uninstall CUDA.

Now without Nvidia drivers, your configuration is no longer intel-nvidia-bumblebee, so it is missing from your list.

Hopefully the commands above uninstall the rest of the drivers and install Nvidia ones.

Remember to make a backup before! If something be wrong, you won't have access to graphical session after reboot, only to tty. Use the info on Manjaro wiki to fix it and install video-hybrid-intel-nvidia-340xx-bumblebee setup and then try to setup again manually Nvidia according to the guide above.

Hey ... thanks for the in-depth response ... I managed to get the settings list back by reinstalling something Nvidia to do with “library” driver list ... then I uninstalled Bumblebee after removing Nvidia utility, I did system and app search for CUDA but found nothing ... so when in doubt, sadly google it. That told me it was part of utilities, thus I uninstalled that.

So I managed to first reset default “free Linux” drivers, and boom I had my external monitor back again. BUT ... seems always a but in my world ... but, not long before system freeze. Then I rebooted and managed to install Nvidia only driver, removed optimus manager and installed prime, that seemed to work ...
but , then again a freeze!
Not sure if it’s driver issues or now something missing from system after my playing around. Or if my old laptop is just not happy with Linux :frowning:

I’ve seen that Prime instructional post before, but honestly it’s overwhelming for a newbie like me, will try to wrap head around it, but expect many more crashes, which is unfortunately off putting to new Linux experience. Was hoping for smoother sailing since Windows 7, I need pc and external to work, I’m illustrator.

Just wish there was a simple fix so I can focus on work and not technical pc issues.

Manjaro is a distro for advanced users or newbies who are not afraid to get technical and break their setup many times till they get it right.

For newbies the best distro would be Mint or Ubuntu Mate as far I know.

You basically did the first steps required in this manual if I understood it correctly:

Step 1: remove bumblebee - done

Step 2: install the NVIDIA driver - done

Step 3: break fix mhwd 's configuration - still missing

Step 4: enable nvidia-drm.modeset - still missing

Step 5: Set the output source for your DM. - still missing

and then reboot.

It's very possible that it isn't working for you smoothly because your setup is not complete. Hopefully, when you do all those points, it will start working correctly.
Also, don't be afraid to break your system if you're on early stage. This is how you learn and most of us broke Manjaro few times before we became long time, happy Manjaro users :slight_smile: .

If you managed to fix things so far on your own, you should be able to follow this tutorial. In case any doubts, we're here to help.

Good luck!

P.S. Linux is "do it yourself" kind of system, so it requires some knowledge on your part. If you don't have it, expect you will need some time till you start using it as you hoped. The first stage is hard, confusing and frustrating, but when you overcome obstacles, learn how it works, you will be happy user. It's just takes some time.

Yeah I heard that recently about Manjaro lol ...
I originally chose POP because reviews said it was simple to setup NVIDIA drivers etc, so I chose Nvidia option when downloaded, but once installed it didn’t seem to be able to pick up my external monitor.
Then I tried Mint, it installed, looked ok, but honestly wasn’t very happy with performance and overall.
When I first installed Manjaro I was pretty impressed ... first impressions everything seemed to work and I also loved the UI and features , plus surprisingly I found it used even less resources than both pop and mint.

But now just the external display and freezing issue is killing me.
Problem is I’m freelance illustrator and need to focus on work so extra frustrated I guess ... I’d be up to “breaking” the system if I wasn’t under so much pressure. Been tempted to install Win7 simply cause I know it picks up monitor and works display ... but then the system sucks and uses too much resources.

So I’m going to try a little more with Manjaro... I’m just not sure what I’m doing most the time.

Ps ... I’m trying “step 3” ... already stuck lol

Step 3.1: set up a new Xorg configuration

Firstly, remove /etc/X11/xorg.conf.d/90-mhwd.conf and replace it with:

/etc/X11/xorg.conf.d/optimus.conf

How do I do that, remove that and replace that?
I tried just going it in the terminal but I got “no such file or directory”
I’m guessing I was supposed to do it another way ...

Ps ... silly question, but isn’t there away JUST to install the default system setup settings to get default drivers and files back without doing a clean install?

Ps ... should this Prime method allow both monitor to work? Currently with Nvidia installed only the external “works” ... however I keep getting the system freezing and have to do hard off and reboot.

Forum kindly sponsored by