Extremely low FPS on Thinkpad P1

Hi! More than year ago I bought Thinkpad P1 with 4k display and all this time I am looking for solution. And I almost lost my hope to find it.

The problem:

UI is very slow and feels like 15fps. Animations lags (e.g. apps overview in Gnome). Scrolling is a pain (especially in browsers: Firefox, Chrome). Any activity in UI makes fan loud. All of this is about 4k resolution. On FullHD all works relatively fine, but sometimes feels worse than my old laptop with Intel i7-4510U (with Intel HD Graphics 4400).

I tried:

  • Ubuntu, Pop!_OS, Fedora, Clear Linux, Manjaro.
  • KDE and Gnome on each of this OS.
  • X11 and Wayland on Gnome on each OS.
  • i915 and modesetting drivers
  • different acceleration methods: UXA, SNA
  • dri2 and dri3
  • different kernel versions
  • FBC (frame buffer compression)
  • GuC and HuC
  • periodically update BIOS
  • to undervolt CPU and GPU
  • all workarounds from ArchWiki page about Thinkpad P1 and Thinkpad X1 Extreme

But recently I found only one case when my laptop works relatively good: on SwayWM.

Here is screenshots of glxgears output on SwayWM (left) and on Gnome on Wayland (right):
merge_from_ofoct
Window with spinning gears was maximized on 4k resolution. If I just run glxgears and will NOT maximize window than I will get 9000 FPS on Gnome.

I tried Sysprof to capture stack traces for both installations (Gnome and SwayWM):
https://drive.google.com/file/d/1bcpqVlBW1tkQcGzL-jbshqw8hyS8eyZV/view (Gnome)
https://drive.google.com/file/d/1ItsYJ3hoJ-M9QMxitFab0zn4jUs2H6vG/view (SwayWM)

But this captures doesn't mean to me anything, I don't know Linux very well to find a root of problem.

My assumptions:

  1. Probably it is impossible to get desirable performance on Intel UHD on 4k resolution. But I don't believe in that. There is Thinkpad P1 version officially distributed with Ubuntu Linux. It have to handle 4k resolution. Moreover, laptop works relatively good on SwayWM.
  2. Maybe there is some hardware problem in my laptop.
  3. Maybe display can be root of problem. Say Linux can't handle 10 bit color or 60hz. (But I think this sounds like complete nonsense)

Do anybody have an ideas? Maybe anybody can sit with me and investigate this issue by audio/text chat?

Is your graphics unit provided with enough ram? Your unit uses your working memory (main system) and it is not certain whether, for example, your bios/uefi is set so that it has enough ram for your gnome in 4k mode. Sometimes a setting in the BIOS limits the ram that is required for the graphics unit (in 4k in your case).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by