Ezbook 3 Pro touchpad problem

I`m a new manjaro user from Ubuntu.
I just installed manjaro 17.1-rc4, alongside preinstalled Windows 10 home, on my brand new jumper ezbook 3 pro and everything works fine out of the box, but my touchpad isn't working at all and never working in liveusb too, altought it work flawlessy in my dualboot windows os.
Can someone help me to fix it? I wold like to erase windodw but I do not touch it until I fix touchpad problem on manjaro.
Thank for your help


Have you tried to type touchpad in the right top corner magnifying glass ?
Full of answers, already... :wink:

thank you fassil, doing a reserch I found my touchpad model is idetified as
SYNA3602:00 0911:5288 but I did not found a solution on the forum.
Is touchpad problem fixable? How?

tried to install xf86-input-synaptics ?

yes i did but it still isn't working

What is the content of the Section "InputClass" of /etc/X11/xorg.conf.d/*-synaptics.conf ?

There isn't such file in /etc/X11/xorg.conf.d/

Why did you go for a pre-release instead of the full (with fixes) 17.1.1 release?

Which edition did you install?

Can you post the output of inxi -Fxxxz so we can see more about your hardware?

I tried stable release and touchpad did not work, so I install the RC because I suppose to find a fix in the more recent kernel of the 17.1-rc

here is output of

inxi -Fxxxz

Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: ezb3p Kernel: 4.14.12-1-MANJARO x86_64 bits: 64 gcc: 7.2.1
           Desktop: N/A info: xfce4-panel dm: lightdm Distro: Manjaro Linux
Machine:   Device: laptop System: Jumper product: EZbook serial: N/A
           Mobo: Jumper model: P313P serial: N/A
           UEFI: American Megatrends v: JUMPER10x.P8.WP313P.NhNAUHL02 date: 11/06/2017
Battery    BAT0: charge: 41.3 Wh 86.0% condition: 48.0/48.0 Wh (100%)
           volts: 7.6
           model: Intel SR 1 SR Real serial: <filter>status: Discharging cycles: 0
CPU:       Quad core Intel Celeron N3450 (-MCP-) arch: N/A cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8756
           clock speeds: min/max: 800/2200 MHz 1: 1094 MHz 2: 1094 MHz
           3: 1094 MHz 4: 1094 MHz
Graphics:  Card: Intel Device 5a85 bus-ID: 00:02.0 chip-ID: 8086:5a85
           Display Server: N/A drivers: intel (unloaded: modesetting)
           tty size: 80x24
Audio:     Card Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
           driver: snd_hda_intel bus-ID: 00:0e.0 chip-ID: 8086:5a98
           Sound: Advanced Linux Sound Architecture v: k4.14.12-1-MANJARO
Network:   Card: Intel Wireless 3165
           driver: iwlwifi bus-ID: 01:00.0 chip-ID: 8086:3165
           IF: wlp1s0 state: up mac: <filter>
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/mmcblk0 model: N/A size: 62.5GB serial: N/A
Partition: ID-1: / size: 5.7G used: 4.8G (91%) fs: ext4 dev: /dev/mmcblk0p5
           ID-2: /home size: 24G used: 142M (1%) fs: ext4 dev: /dev/mmcblk0p6
Sensors:   System Temperatures: cpu: 39.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 180 Uptime: 2 min Memory: 790.1/5813.6MB
           Init: systemd v: 236 Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121 running in xfce4-terminal) inxi: 2.3.53

thank you jonathon, your help is much appreciaed!

Hi any ideas to fix this touchpad problem?

Do I need to install the manjaro 17.1.1 release?

If you have updated your system then there's no need to reinstall.

Unfortunately, if you have a piece of hardware that few other people have it's difficult to find someone who has had and solved the same issue. Without knowing more about the underlying hardware it's going to be very difficult to find a solution other than making wild guesses as to what could be the cause.

Essentially, you need to find out the manufacturer of the touchpad itself, and then find out how to enable support for that manufacturer's hardware. If it doesn't have a Linux driver module, or the kernel doesn't support the hardware natively, then it's not going to work.

This is one reason why buying "cheap" hardware is often a false economy.

The touchpad identified with SYNA3602 does not work with any Linux distribution or kernel not even on 4.16.

I have researched on the matter and there is some kernel patches but nothing final that makes this specific touchpad work.

The touchpad works as expected but only under Windows OS.


1 Like

Update: still not working in kernel 4.17...

Older thread: Touchpad SYNA3602 (0911:5288) not working at all

Forum kindly sponsored by