Fail to boot after latest updates, ethernet fail too

Hi, everyone

Two days ago, after the latest update, my PC never booted again. I am a total newbie with minimum knowledge of linux that has managed to keep Manjaro for 8 months now. And I am super-happy with Manjaro. But now what do I do?
Second problem: after running in grub this command sudo pacman-mirrors -f3, to update the mirrors, and it says internet connection is down. So I guess sth to do with Ethernet controllers?

My tip, read, read, read
search in forum (black screen, grub)
and post

inxi -Fxxxz

What does that mean? Did you see errors? We need more Informations:

You can try to boot from USB stick and chroot in your system, than try to update again with sudo pacman -mirrors -f3 and sudo pacman -Syyuu

1 Like

Thank you for the tips. I have been reading for 2 days, and just yesterday managed to get admin privileges in grub. I mean totally newbie, with only a mobile phone at hand. The pc doesn't boot at all, stuck in black screen. Did I mention no internet connection?
Below you can see the inxi command.

From the same TTY, as your user, try this command:
sudo systemctl start dhcpcd
Make sure you have the cable connected to your LAN
Then try again to update with
sudo pacman -Syyu

Also, let's see the status of lightdm and if it failed and where.
systemctl status lightdm

1 Like

Done everything. Thank you for being kind.
"Failed to synchronize all databases"

systemctl status lightdm
lightdm.service - Light display manager
Loaded:(/usr/lib/systemd/system/lightdm.service;enabled; vendor preset: disabled
Active: inactive (dead)
Docs: man: lightdm(1)

Ok, try to run this:
sudo systemctl start lightdm
if it starts and you can log in, then open the terminal and run:
sudo systemctl enable lightdm

Did you try to also refresh the mirrors as you tried previously ?
sudo pacman-mirrors -f5
then again
sudo pacman -Syyu


None of the above works. Still no internet connection, light display manager dead.

Did we talk about your backup strategy?

If nothing work, save your data, reinstall, backup ... bogdan knows a way out :slight_smile:

1 Like

If you rebooted then you have to do again

That command should give you internet connection if your router is set to work as DHCP server.

That is why i asked to start it manually and if ti works then you enable it permanently ...


I don't know if it works as DHCP server (I don't even know what that means-Plz don't bother to explain). Using all previous commands I get the exact same output.
Used these after reboot in TTY:

  1. sudo systemctl start dhcpcd
  2. sudo pacman-mirrors -f5
  3. sudo pacman -Syyu
  4. systemctl status lightdm lightdm.service - Light display manager Loaded:(/usr/lib/systemd/system/lightdm.service;enabled; vendor preset: disabled Active: inactive (dead) Docs: man: lightdm(1)

And after

black screen. Now I reboot.

Fortunately everything is already secure. BUT
man, I really want to keep using Manjaro, but these ■■■■ make it so difficult to keep the faith.

Well, i was trying to get you trough this

so you don't feel overwhelmed ... :slight_smile:
Not sure how can be more helpful, but maybe someone comes along and provides a new approach to fix your issue.

1 Like

This is the third time you have tried to help me. I REALLY appreciate it. I will try with the link. Thank you very much!


I am gonna try reading here: WARNING: after latest update [23/01/2019] my computer won't start anymore!

As I suspected (from what I could make out in the pic you posted) you have a realtek r8168 NIC adapter. You most likely lost your connectivity because of a driver or kernel update. There have been many issues recently with the proprietary r8168 drivers. You can probably fix this if you have access to the terminal.

You basically have 3 choices.

Downgrading your kernel to 4.14 may fix this.

The other method would be to uninstall the r8168 driver. You will probably also have to delete the blacklist on the r6169 driver in /etc/modprobe.d.

Your other alternative is to not worry about fixing your LAN connection ATM and simply use phone tethering to get a temporary internet connection for now.

Good luck.


Let's do this one. How can I uninstall it from TTY?

cd /etc/modprobe.d
ls -la
# if  r6169_blacklist.conf is listed
sudo rm r6169_blacklist.conf

or for the brave

sudo rm /etc/modprobe.d/r6169_blacklist.conf

Good luck.

1 Like

I believe this would be the command.

(edit) sorry I was thinking you were on broadcom I corrected the command,

I'm pretty sure this is the right one.

sudo mhwd -r pci network-r8168

If you uninstall the driver via MSM it removes the associated blacklist for the r8169. When you uninstall via the terminal I don't think it is automatically deleted.

You will have to search /etc/modprobe.d for the blacklist file, and either comment out r8169, or delete the blacklist file that contains any reference to r8169.

1 Like

You are correct on the procedure to remove the blacklist @sgs , but he must uninstall the r8168 driver first. :+1:

1 Like

Forum kindly sponsored by