[FAILED] Failed to start Load Kernel Modules

Just did the updates, rebooted and was presented with a command prompt after a error message. I could not type anything into the prompt so hard rebooted, presented with same error and unusable prompt, hard rebooted, selected advance and the 5.7 kernel, was presented with the same error and a useless prompt again., another hard reboot, advanced, kernel 5.6, and booted into my desktop. Just received another 500+ megs of updates, once done will reboot and try the 5.8 kernel again. If I get the same message will edit this post and add it here.


OK with attempting the 5.8rc7 I get "[FAILED] Failed to start Load Kernel Modules.", attempting with the 5.7.11 I get that and a list of my drives / partitions that timed out attempting to load / mount.

[agentx@Secret-Computer ~]$ pacman -Q | grep linux
archlinux-appstream-data 20200612-1.1
archlinux-keyring 20200622-1
lib32-util-linux 2.35.2-1
libutil-linux 2.36-1
linux-api-headers 5.6.11-1
linux-firmware 20200721.r1678.2b823fc-1
linux-latest 5.7-1
linux-latest-headers 5.7-1
linux-latest-nvidia-440xx 5.7-1
linux-lts-headers 1:5.4-3
linux54 5.4.54-1
linux54-headers 5.4.54-1
linux56 5.6.19-2
linux56-headers 5.6.19-2
linux56-nvidia-440xx 440.100-1
linux57 5.7.11-1
linux57-headers 5.7.11-1
linux57-nvidia-440xx 440.100-8
linux58 5.8rc7.d0726.g92ed301-1
linux58-headers 5.8rc7.d0726.g92ed301-1
linux58-nvidia-440xx 440.100-0.7
playonlinux 4.3.4-2
util-linux 2.36-1

@openminded I'm about at wits end here. I attempted to chroot into the OS and no luck. I tried to run Timeshift and no luck. I did the updates that were pushed this morning and the system removed the 5.6 kernel I was booting with. Tried to drop down to the 5.4 kernel and just sits there at a black screen. As of right now I've exited the live key and booted into the second install on my main disk using it's 5.6 kernel. If you have any other suggestions for repairing my main OS I'd really appreciate the help. Thanks

To me it looks like Nvidia related issue. You're getting dropped to black screen right, not grub prompt?

As stated in the first post I was getting that one error when I press enter to boot Manjaro from the 5.7 or 5.8 kernels. Now with the last round of updates it removed the 5.6 kernel and the 5.4 kernel just boots to a black screen. Went on my roommates machine to check something and had to have it boot to the 5.7 kernel cause the 5.8 kernel wouldn't boot and looks like the updates on his also removed the 5.6 kernel.

In this second copy of Manjaro that I'm in now I've avoided the updates cause I'm afraid the same thing with the kernels in the main OS will happen here.

That's due to linux-latest being installed and "rolling" foward. If you want to manage kernels yourself, you could safely remove it.
It might also be possible to reinstall linux56 via mhwd-kernel but it's EOL now and shouldn't be used anymore.
Are there any errors visible in journal from the failed boot(s) (when chrooted) so as to determine which modules failed to load?

I'd just as soon fix the 5.7 and 5.8 kernels.

Thanks guys for the input. I decided that after Manjaro 20.1 drops which I suspect will be relatively soon I'm just going to do a reinstall. I think it will be a lot easier and faster than trying to figure out what's going on with the kernels. I know what I have installed, and I know My KDE settings so I should be in good shape for a fresh install.

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by