failed to load kernel modules and unable to boot

Hello Everyone,
Last night I updated my manjaro system to the latest Manjaro Stable branch and everything seemed to go well, nothing was interupted and I didnt see any errors, I even rebooted my system to make sure that everything was alright and it worked. However when I tried to run the system in the morning, I started getting the boot error Failed to load kernel modules and I am no longer able to boot.

I tried the solutions posted here



but it didnt solve anything. I am not able to open a tty but am able to chroot into the system.
Any help would be appreciated

  1. Boot from the Manjaro USB stick.
  2. chroot into the system.
  3. mkinitcpio -P.
  4. exit chroot.

I already tried that but it didnt fix the issue.

What operating system do you have on your computer?

Manjaro Gnome with 3 kernels available, 4.19, 5.3 and 5.4

Only this OS?
Then post grub.cfg.
When does this error occur? With kernel 4..19, 5.3, 5.4?

I have only this OS installed on that system.
it occurs with all three kernels.
here is the grub.cfg from /boot/grub/

The grub.cfg is OK.
Then, can you post the error message?

I can try to click a picture but i doubt i can it comes for a second then goes away in the boot screen. After the boot sequence fails the screen is blank with a single _.

Can you chroot into the system and check dmesg for errors?

Here is dmesg


There werent any errors as far as i could see

The system must be updated (kernel 4.19.28).
Have you tried to update the system with chroot?

Yeah it shows me theres nothing to do.
the dmesg from chroot is of the OS of the usb and not the actual system as my os is 4.19.91

Dmesg shows a kernel version 4.19.28-1.

dmesg is showing the kernel version of the boot drive. If you look into in the grub.cfg the kernel version is 4.19.91.
How do I access the dmesg with chroot?

In post #9, you show dmesg.
The first lines of dmesg shows the kernel version:
[ 0.000000] Linux version 4.19.28-1-MANJARO (builduser@development) (gcc version 8.2.1 20181127 (GCC)) #1 SMP PREEMPT Sun Mar 10 08:32:42 UTC 2019

Possible solutions:

  1. Update the system with chroot
  2. Reinstall the system
    :upside_down_face:

yeah that is the kernel version of the live usb. Chroot can only access the kernel that is running and not of the failed kernel.
https://bbs.archlinux.org/viewtopic.php?id=204809

  1. I already did that and it shows me there's nothing to do.
  2. Im really looking for an alternative to this.

Try to reinstall your kernels after manjaro-chrooting into your system using
mhwd-kernel command. Read the wiki carefully:
https://wiki.manjaro.org/index.php/Manjaro_Kernels

Which version of the Manjaro USB stick are you using?

it shows Illyria 18.04 in manjaro Hello.

Forum kindly sponsored by