"Failed to load kernel modules" message on startup after system update

Hi all. I've been far from home some time now, today i came back and power on my Manjaro computer, all fine but, it said i had 2.0 GB of updates pending, so i decided to update it, but it said couldn't update because there were some conflicts that i resolved uninstalling ffmpeg and x264, 'cause they were the programs that caused conflicts. With all conflicts resolved the system seemed to updated fine, but as it was a big update, i thought that was a good idea to restart the system, and then the system show "Failed to load kernel modules" message on load and it hangs on "Started TLP system startup/shutdown" , and after another restart it hangs on "Started Network Time Service", and it stays here and can't boot it. Why this problem?, Its my fault?, What can i do?
Thanks in advance.

Enter a TTY by editing the Grub menu as describe in this post and adding the number 3.

When you reach the TTY login as your own user and try running the update again with
sudo pacman -Syu reboot and see what happens.

1 Like

First, thanks for your reply mate. Now, I've done what you said but, it says everything is already updated, and after restart, the system hangs again. What can i do now?. Thanks

Today, i powered on my system and opened the TTY2 and loged in, then with systemctl i could see the details of the Fail, it says that "lightdm.service" and "systemd-modules-load.service" are loaded but failed in the ACTIVE an SUB column. Im in Manjaro Linux 4.14.85-1, but i had the 4.9 kernel installed too so in the advanced options of the start menu i tried to load with it but hangs in the same way but it shows a "Unknown option "nsdelegate"" message. Any idea of how to resolve this problem???

1 Like

if your not able to get to a desktop environment, you can use a live usb and use manjaro-chroot so you can provide info needed to be able to help you as @anika200 suggested

Looks like you made good progress, the easiest thing to try right now is to log into TTY like you did before and re-install the kernel and then lightdm and see if that gets things going. I guess you are on XFCE correct?

I am not on my manjaro box but the commands to search for package are sudo pacman -Ss packagename and to install sudo pacman -S packagename.
The kernel packages are linux418 or in your case linux414 I believe.

Actually for the kernels you should try the Manjaro tools sudo mhwd-kernel -i linux414

1 Like

No, i have an old machine but i'm on Cinnamon 'cause i though that it was based on Xfce when i installed it, now i know its based on Gnome, my mistake.

Now i tried to reinstall kernel 414, but it said that i can't reinstall the current kernel, only update it through pacman, so i restarted the system loading the 4.9, and then reinstalled it and lightdm with commands:
sudo mhwd-kernel -i linux414
sudo pacman -Ss lightdm
sudo pacman -S lightdm

All seemed to reinstall properly but when i reinstalled the kernel it showed a message "In order to use the new version reload all virtualbox modules manually." I don't know if i need to do something here...
With all reinstalled i restarted the system but everything remains the same :frowning:

What now? You think if i update the kernel to 4.18 this could solve the issue?

It is possible.

However I seem to remember some issues with Cinnamon and lightdm please have a search on the forums to see if there are similar issues.
You may have to downgrade lightdm or install a different DM like sddm.

Have you tried booting a new live usb, that would let you know if the new kernel would work.

The warnings for Virtualbox are normal and nothing to worry about unless you are running a guest OS on Manjaro.

1 Like

I have made a live usb with the latest version of Manjaro (18.0), and tried to boot with it without success, it hangs too. I can see that "lightdm" has failed to load in the same way but the "systemd_modules-load.service" is active, not failed. So it seems that lightdm can be the guilty. Now, how can i downgrade lightdm or uninstall it to install that sddm you named before? can you guide me?

Im thinkin' that a good choice can be install a new Manjaro 18.0 with KDE that seems to need less resources than Cinnamon (and supose that it will solve the issue with lightdm, im right?), but my HD is in one partition so i can't format it 'cause i don't want to lose my personal files. Is there a chance to partitioning my HD with livecd or something without lose everything? (like partition magic used to do in a windows machine).

1 Like

yes, in kde livecd i think it comes with KDE partition manager.
with gnome livecd comes with gparted.
im not sure what come on the others but yes, its pretty straightforward either way. if your entire drive is being used you can resize an existing partition, then create a new one in the space you just freed up and then backup whatever files your concerned about losing and go about installing kde or whatever you decide

1 Like

Ok dglt, i booted my machine with a live manjaro 17.01 (the version which i installed for first time) and i have partitioned my HD with Gparted, now i have two partitions to save some data in the case i can't solve my issue, but from now im gonna try to solve it with the help of anika200

1 Like

From bad to worse. I though the partitioning worked fine, but seems i was wrong.
I resized the HD and made a new partition at the end of the HD of about 250 GB, and supposedly i left about 16 GB of free space in the first and main partition (the old one). All seemed to be fine but when i tried to install sddm package in the tty2 to replace lightdm it said there is no free space in the old main partition (0 blocks free it said). So i booted again with the live usb, to see what happened, and Gparted still says there are about 15 GB of free space, but if i mount the partition, the explorer says there is 0 bytes of free space. Tryin to solve quickly the issue i deleted a video file of 1,5 GB, but it still says that there are 0 bytes of free space, despite Gparted says ther is about 18 GB of free space. So i unmounted the partition and checked its structure with Gparted to search for errors, but after that, the explorer still says there are 0 bytes of free space. I'm lost right now... :frowning:

Just one more thing... i tried to uninstall lightdm in tty2 but it says i can't because something about dependencies. I tried it with commands: "sudo pacman -Rs lightdm", and also with "sudo pacman -R lightdm" with the same results. Any idea of what can i do?

this is a tutorial to switch from gdm to lightdm but you can read through it and get the general idea for what your trying to accomplish.

also, check your drive/partition layout and compare to fstab and make sure uuid's,mounts and drive designation (sdaX) match the way they should. you can check with the following commands:

cat /etc/fstab

1 Like

im gonna try it, thank you, i cross my fingers.

Please post the output here from lsblk if possible. If it is something like mine you will have a seperate home partition.

In this case you can install the brand new kde BUT do not overwrite or format the home partition. This gives you a brand new install but your personal files are not affected if they are in your normal area like pictures, documents etc....

At this point though your empty partition is kinda messed up so not sure about that without some output from the machine.

lee@linux-6y72:~/bin> sudo lsblk
[sudo] password for root: 
sda      8:0    0 223.6G  0 disk 
├─sda1   8:1    0  68.5G  0 part /mnt/0ac51365-1ffa-47a4-95b1-5b34ffaacecc
└─sda2   8:2    0 155.1G  0 part /home
sdb      8:16   0 111.8G  0 disk 
├─sdb1   8:17   0     8M  0 part 
├─sdb2   8:18   0    40G  0 part /
├─sdb3   8:19   0  15.6G  0 part [SWAP]
└─sdb4   8:20   0  56.2G  0 part /mnt/b05d6476-23ed-4535-988b-6845422cca7f
1 Like

Ok, thanks anika200, im gonna do it right now, im a little worry about that. I supossedly have 2 primary partitions in my HD, and i bet that are a little messed up. I will post the output of lsblk command in some minutes (as soon as i can).

Writing lsblk in tty2 i get this output:

sda      8:0    0 931,5G  0 disk 
├─sda1   8:1    0 650.2G  0 part /
└─sda2   8:2    0 245.3G  0 part
sr0     11:0    1 1024M   0 rom

Please post

df -h
inxi -SMGpuoxxxz

You do not have a separate /home partition so what I suggested is out, but you can probably move your personal files to another partition /sda2 and then re-install on sda1. Right now you do not have sda2 mounted but sda1 is mounted as /.
Lets see your output from petsam suggestions.

1 Like

Forum kindly sponsored by