Failed to start Light Display Manager. Pc not launching

(My PC is dead so I'm typing from my phone. I hope I'll be able to address the issue good enough.) Anyways, as the title suggests, I'm unable to launch Manjaro on my PC, and whenever I try I get a failed message.
IMG_20200720_012041
I'm a real noob when it comes to Manjaro, and linux in general so I'm not sure what I did wrong and what I should have done instead.
It all started when I tried to launch Blender via pacman, it for some reason didn't launch and so I tried to launch it in Terminal, and it seemed that my drivers and grapbic card didn't support OpenGL3.3 needed to open the software. I tried to install/update my drivers using many guides, but non of them managed to solve the problem, so i tried to reboot my computer and this message showed up. Help?

Graphics: Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: intel resolution: 1366x768~60Hz
OpenGL: renderer: N/A v: N/A

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by