Failed to start Load Kernel Modules.

Could anyone help me with fixing this issue, i have a low understanding of how to fix this problem so i would appreciate if i could get detailed help.

Please do what the error message says.
systemctl status systemd-modules-load.service

On a general note, always read error messages carefully, they often contain information on what to do next. In the above case, it literally gives you the exact command to run in order to get more info.

I did that and i got this:

is it safe to assume you were messing around with video drivers before this happened? it's looking for nvidia modules and cant find them.

since you cant get youself to a graphical desktop, please do the following commands and provide the links after the last 2 commands.
(if your not connected, use nmtui to activate a wifi connection first.)

sudo pacman -S pastebinit
inxi -Fxxxz > paste.log
mhwd -li >> paste.log
systemctl --failed >> paste.log
ls -laR /etc/X11 >> paste.log
cat /etc/X11/xorg.conf.d/*.conf >> paste.log

cat paste.log | pastebinit
cat /var/log/Xorg.0.log | grep -E "(EE)|(WW)|error|failed|Time" | pastebinit

post the links that the last 2 commands output.

not pictures please.

1 Like

Umm yeah i was trying to get my games to launch using my deticated graphics... heh

first question, do you actually need the rt kernel or your using it just because you can?

ok, you have an optimus laptop, so you cant just install video-nvidia and expect it to work. thats why there is bumblebee but if you want actual performance gaming, bumble bee is no good.

use prime or optimus-switch.

heres a comparison of the different optimus options

decide which fits you best.

also, you have the wrong version of video-nvidia installed anyway. your GPU uses the latest 418 drivers. so for starters.

boot a different kernel and get rid of the RT kernel unless you need it for some specific purpose.
sudo mhwd-kernel -r linux50-rt

get rid of the installed drivers
sudo mhwd -r pci video-linux
sudo pacman -R nvidia-390xx-utils
sudo mhwd -r pci video-nvidia-390xx

if you want to use nouveau install free drivers, if you want bumblebee install nonfree drivers like this.
sudo mhwd -a pci nonfree 0300

if you want video-nvidia you need to set it up a certain way, hence the link i posted.

edit: do make not that optimus-manager and optimus-switch are not the same (poor thinking on my part naming it optimus-switch) :man_facepalming: .

Oh boy, hybrid GPU. So it means either using default Bublebee with nvidia-xrun or try setting Primus or use optimus-manager.

So basically:

  1. switch to main kernel (if you don't need rt) as @dglt already noticed

  2. install non-free drivers:

sudo mhwd -a pci nonfree 0300

Read more:

This will give you default Bumblebee. Check Arch wiki about Bumblebee and see if it works correctly. For using Vulkan you may want to set nvidia-xrun:

  1. Do backup (with timeshift) so you could restore system setup if you mess things doing next steps.

  2. Install and setup correctly optimus-manager, read:

Be aware, it will mess us Bumblebee. In theory, uninstalling optimus-manager should restore Bumblebee, but in case it is not, restore system from backup.
Why would you want uninstall optimus-manager? It's in beta and don't work for all, but if it does, IT IS THE MOST OPTIMAL SOLUTION FOR GPU CARDS. This is what I use, although I'm sitting on old version, because newer ones don't agree with my computer from whatever reason. 0.6 version works perfectly for me.

  1. If nothing works and you really want to play a lot of games and you are ready to give up on using laptop remotly (short battery life), use Prime setup. There is a tutorial how to do on Manjaro forum. Search for it.

So when i try to enter sudo mhwd-kernel -r linux50-rt
It gives me this

linux-rt-manjaro-bbswitch: removing linux50-rt-bbswitch breaks dependency ’linux50-rt-bbswitch’

pacman -Qs bbswitch

uninstall any package that gets listed from that command.

not to mention it shouldnt be there anyway unless you have bumblebee or optimus-manager installed

When i try to remove nvidia-390xx-utils it says

linux419-nvidia-390xx: removing nvidia-390xx-utils breaks dependency ’nvidia-390xx-utils=390.166’

what about
sudo mhwd -r pci video-nvidia-390xx

Nope, it says

optimus-manager: removing linux419-nvidia-390xx breaks dependency ’nvidia’

when did you install optimus-manager?
i see you tried many different things, and left behind some stragglers along the way.

before anything else, do this

sudo systemctl stop optimus-manager.service
sudo systemctl disable optimus-manager.service
sudo optimus-manager --cleanup 
sudo pacman -R optimus-manager

then go back and continue removing the other video drivers and utils

So now i should install the non free drivers and after that install one of the other programs the right way?

what does mhwd -li show?

if it shows no video drivers then yes,
sudo mhwd -i pci video-nvidia

and decide which option fits you best. i recommend either full time PRIME or optimus-switch which has nvidia prime mode setup exactly like PRIME and intel-only mode where only the iGPU is used and the nvidia is powered down.

i know those 2 methods work, so thats what i recommend to people.

PRIME tutorial

optimus-switch for SDDM

Well when i tried to run the command sudo mhwd -i pci video-nvidia
It said that it failed retrieving files, failed to update cores etc
It was too long to type

you need to connect to network. use nmtui and activate a connection.

also, lets be sure to avoid any other unforseen issues, start with:

sudo pacman-mirrors -f8
sudo pacman -Syyuu

if kernels get updated, reboot before you try and install video drivers

What should i do if it says that its not authorized to controll networking

are you trying to run nmtui as root?

sudo systemctl restart NetworkManager

you shouldnt need sudo with nmtui

Nope doesnt work, it still says that it doesn’t have authorization

Forum kindly sponsored by