Failed to unmount run/misco/bootmnt

So i'm completly new to Manjaro and linux in general although I previously installed ubuntu 18.10 which worked fine.

When I try to install the latest Manjaro 18 kde 64x on my old toshiba c660 laptop, the installation is smooth until I reboot the compter.

There is one line marked:
Failed unmounting run/misco/bootmnt

And then it fails to boot to the installed Manjaro os saying there is a PXE problem.

I hope you can help me figure this out !

You have two issues here. Let’s tackle the easy one first.

  1. /run/miso/bootmnt unmount failure is common, and it is something that can be ignored, as it really doesn’t mean anything.

  2. You have a boot problem. PXE messages usually mean that there was no bootable medium found. Go into your bios, and make sure you have the built in HDD set to boot first. If that still fails, comment below.

Yes it is set to boot on HDD first.
I can reinstall ubuntu 18 and make sure if the problem is manjaro related if necessary.

So for the record, ubuntu 18.10 worked just fine when i reinstalled it. So its definetly something i messed up while installing Manjaro

I installed Manjaro Gnome edition and got the exact result. Apparently, the bootloader doesn't detect any OS, but when I boot using the USB disk I used to install Manjaro and select 'detect EFI bootloader' from that menu, the installed OS does in fact boot. Any clarification on this matter is much appreciated.

Boot into Manjaro, your method is fine, and refer to this,, at terminal, do

sudo grub-install /dev/sda
sudo update-grub

and also the 2 [UEFI - additional commands]

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Refer to link on second command. Get the $esp partition right.

So the instructions above didn't work for me. After using echo $grub_platform, I surmised that I was trying to boot using efi firmware on Legacy BIOS mode, while booting on UEFI mode simply didn't work ( as booting from HDD was blocked) because of secure boot being turned on.

So, in the end, I am taking the easiest path (for me) of simply downloading a Windows ISO and burning the media using rufus to install Windows and using its recovery mode to disable secure boot and then installing Manjaro.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by