Fails to boot with kernel 4.14.15-1.1

Hi!

I'm a Linux newbie and after installing today's updates I can no longer boot my PC. Boot hangs on TLP startup/shutdown. While I read threads regarding this issue, I'm not sure if the information provided by them are applicable to my situation.

Here are some photos of the boot screen. Any help is appreciated. Thanks.

IMG_20180131_110218
IMG_20180131_105946

Switch to a text console with CTRL-ALT-F2, log in as normal, then run

sudo pacman-mirrors -f 3
sudo pacman -Syyuu

Attempting to use crtl-alt-f2 causes my screen to flicker rapidly between the boot screen and the text console. There is also severe input delay once that happens. I also have to spam the key combination in order for it to even attempt to switch over to the text console.

OK, reboot, press e at the GRUB menu, tag a 3 to the end of the boot line (it normally has "quiet" and "resume" in it) then press F10 to boot. Once booted, log in as normal, and etc. as above.

Thank you!

I successfully logged in and used the aforementioned commands. Here is the result:

IMG_20180131_135552

I think this is because I have no network connection, and I have been looking up how to start it via console. I've gotten to the nmcli commands, but have now run into another issue: Trying to start my VPN produces a "could not find source connection" error, while trying to start my connection produces a "secondary connection of the base connection failed" error, which I assume is my VPN.

Sorry. :worried:

OK, so you'll have to use a live installer to log in to your system via a chroot, then perform the above steps.

Some hints on using a chroot are here: https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader and you can also search the forum for more.

An easy way is to run the command nmtui.

1 Like

Hey,

I've got the same problem relating "Started TLP system startup/shutdown".
I managed to run your commands after updating the package signing keys.
However, after rebooting the system, the problem still persists.
Is there something else I could try in order to fix it?

Are you running an i686 system?

If you can log into a text console then your DM isn't starting. If you're running x86_64 you might need to install libbsd as per the other (correct) update thread.

I'm running an x86_64 system in a virtual machine using Oracle VirtualBox.
I can indeed use the text console and you're probably right about the display manager. I just noticed the error "Failed to start Light Display Manager" during boot.
Unfortunately, installing libbsd didn't fix the problem for me.
Any other ideas?

If it was the same problem as above then the steps above should have fixed it.

You'll need to check your error logs, for example /var/log/Xorg.log.0 and journalctl -b.


(thread split from [Stable Update x32] 2018-01-31 - Kernels, Firefox, Thunderbird)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by