Failure to boot from USB stick in UEFI mode

what the hack are you running at your usb-device while booting up ?is your usb- stick a fat-formatted device ?

Only the EFI boot part is fat32. The rest I guess is ext4, as it is not visible under Windows.

Anyway, I managed to boot from the stick after another try to unplug/replug the stick while booting just before the mounting part. This last USB image was made with Rufus, but I've tried many different ways, including the instructions in the Manjaro wiki page.

I've find this "solution" while searching for my problem. It seems this is very common issue with Manjaro. I believe I had the same problem long long time ago when I tried again to install from USB stick.

Makes me wonder why the same problem persists through the years....

Please, do us a favor and do not call this

a solution... :face_with_raised_eyebrow:

2 Likes

What do you mean?
Can you share links of similar cases, please?

Because you haven't helped tracking it down :man_shrugging:
Will you now? :wink:

1 Like

I set it to unsolved!

2b2cfc27211d460aecbd711587d137a50a022c3a

3 Likes

Sure, I am more than willing to try and find a proper fix. I myself am not that skilled with Linux stuff but if anyone has ideas, I will try test them.

What I've found so far for the problem is mainly on Arch forums.

Here are some threads with similar issues:
https://bbs.archlinux.org/viewtopic.php?id=247656
https://bbs.archlinux.org/viewtopic.php?id=241437

Where are the Manjaro issues?

My guess is your hardware has difficulty.
Have you searched for issues related to your hardware?

Manjaro LiveISOs have a special format.
I suggest you try other Manjaro editions/versions, including Architect.

Possibly a regression in linux 5.4?
Try some older iso.

Do you mean that technically the issue I have is not Manjaro specific but Arch related or that the issues are completely unrelated? If it is the former, you are correct, if it is the latter that would be some very interesting reasoning. It might be true but I very much doubt it.

I've downloaded the oldest Manjaro iso I could find. Apart from that I downloaded some other distros as well as the latest Arch version. I also have a second laptop so will test with it as well. Unfortunately I am away for the holidays and have forgotten my USB stick at home.

In the meantime I have a microSD card with me and I was able to boot from it without a glitch!

Cool, now bisect :slight_smile:

And friendly reminder that network boot is also a (comfy) thing.

I don't think there is a special meaning to what I try to express. Maybe I used wrong language, not a native English speaker... :man_shrugging:

Manjaro is not Archlinux, especially when it is about installers and LiveISO images.
If this seems this is very common issue with Manjaro, I understand you have read some reports or complaints from other users that tried Manjaro installation and had the same issue with yours (LiveISO on MSDOS boot works while LiveISO on UEFI boot does not work). Because I don't remember such issues in the forum, being one of the boot issues expert here :slightly_smiling_face:, I asked for links to such reports. I hope this is fair and not provoking... :man_shrugging:.

IMO you are not correct. Arch has nothing to do with this.

I don't know what you mean, but it doesn't matter.

Let's review...

You have internal USB hub(s).

These indicate the ISO Live system is functioning well (hardware and software). Also it seems the ISO image is properly written to the USB drive.

You forgot to explain when and where did you edit/add this. It's a manual grub editing procedure, looks like from the famous @gohlip instructions and countless issues he/she assisted.


And still some questions remain

Have you finally installed Manjaro or was there another issue (I couldn't figure out, sorry...)?

My best guess is still

It is not uncommon. Each laptop/motherboard vendor uses their own UEFI implementation, resulting to unique problems regarding hardware recognition/discovery, that many times can be worked-around with a UEFI/BIOS setting, which is not widely the same to UEFI/BIOS of all vendors. Thus you might have to look for some relevant (obvious or some times not so...) setting in UEFI/BIOS menu.

It is not uncommon .

But maybe mhwd service on LiveISO interferes and makes things worse (or not). You might want to disable it with a grub parameter.

systemd.mask=mhwd-live.service
1 Like

Yes, I am aware of that. My point is, I don't have any external hubs, nor any other devices using the USB ports while doing all this.

I've got the idea from this topic. Basically when I was using the legacy BIOS setting this helped me boot from the stick, without it I've got the same error as described here.

Yes, I've already installed Manjaro using the unplug/plug suggestion. That's why I've even marked that as solution although I agree it is not. However, it was at least something that could help circumvent the issue.

I won't argue with that. It is a possibility. My experience though is that both times I've tried to install Manjaro from USB stick using UEFI I've had similar problems. The laptop I am having this problem now is pretty new one so it is possible. I've another one though, an old one from 2013 so when I get back home I will try with it as well.

1 Like

It's good to keep them in our watch list! :stuck_out_tongue_winking_eye:.
Info?

inxi -SCMGaxxxz
1 Like

This does not require you to boot from a USB. And you can try a usb2 port instead of a usb3 port, there are reports about problems with grub uefi boots from usb3 ( not too sure).

And as AgentS asked, what is computer make and model, some are Microsoft tied in or must have secure boot ( Microsoft certified) or needs a lot of tweeking in bios to set uefi. Since you have no problem with bios-legacy, that is most likely the issue.

1 Like

Here you are :slight_smile:

It's not about requirement. I don't have many ways to boot live OS-es from. I also don't have USB 2 ports.

Secure boot is not enabled. I do have problems with BIOS legacy, but I managed to bypass this by setting the usage of uuid instead of label.

1 Like

Try this then.

2 Likes

Thanks. Will check it out once I am back from the holidays.

1 Like

OK, I had some time to test a little. I wasn't able to fix this as per the latest instructions, but probably I am doing something wrong.

Anyway, I tested with my old laptop and with some other iso images (old manjaro and other distros). Everything is fine on my old laptop and fails the same way on my new one so it seems it is something hardware related.

Regardless, I did install what I wanted so it doesn't matter anymore.

Thanks everyone for the help.

What I did was I made a Live CD and booted from the CD drive. That worked.

This is how I would install Manjaro from a USB stick.
When I downloaded the ISO file and Image writer to the USB stick I had I did not understand that some systems will not boot from the USB like that.

You would have to take the files off of the USB stick you downloaded and open the image writer program/app.

Through the writer program, Locate the iso file on your PC in the downloaded Manjaro file and burn it to the USB stick.

This will open up everything you need to boot from the USB stick.

Reboot into your UEFI BIOS. Tab over to System Configuration, Select Boot order, Then Change the boot order of your Laptop or PC to boot only from the USB stick. Reboot.

When you see the make icon screen, press the necessary key or keys to get into the UEFI BIOS again, this time you will choose boot devices or something like that.

Select USB boot, In USB boot Choose EFI.

Keep choosing EFI.file until it asks you if you want to exit and save. At that point choose exit and save. Reboot again.

Your Laptop or PC should pickup the boot file on the stick and install Manjaro on your system.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by