Fan at maximum speed

Why not try an LTS kernel?

Is there any big disadvantage to that? It is long term release but it is older.

LTS is a stable kernel. It won't hurt to try regardless. You can have multiple kernels and boot to whichever you want. BTW I googled your issue and it could be tied to your graphics card too.

I tried kernel 4.14 LTS and the same issue. Yes it may be the graphic card because it didn't even boot in the beginning and nowI have to add a code when rebooting to grub: acpi_osi=! acpi_osi=“Windows 2009” in order to boot up.

So you had an issue even with the live iso?

No. The live iso works perfectly. Only after I install Manjaro or any other Linux distro (tried Ubuntu, Solus, Mint) it doesn't boot. But that issue I reported here Manjaro stuck after Grub where I also mentioned the fan speed and I was told to make a different post about the fan speed. But they might be connected?

Could be BIoS bug,have you updated to the latest?

You cold look inside the mhwd if you installed some proprietary driver for gpu ?

Why did you read that part? Did you tinker with fancontrol or is it still the default setting the OS came with? That could explain why the fan is at maximum speed.

Could be BIoS bug,have you updated to the latest?

You cold look inside the mhwd if you installed some proprietary driver for gpu ?

Yes it is the latest kernel and I changed the kernel to LTS and it is still the same.

I only installed this https://aur.archlinux.org/packages/asus-fan-dkms-git/ to try and fix it then uninstalled. Had no effect. I didn't do anything to the fan speed. Basically the minute I installed a fresh manjaro the fan started to go crazy. As I remember booting into manjaro live with proprietary drivers had the same effect. Could I try install only Nvidia proprietary without bumblebee? I know from the past that my laptop worked well with Nvidia 390xx, but then I switched to Manjaro and in installed other Nvidia drivers. Maybe that's the issue? Also is it bad to keep my laptop like so until we solve it? i don't want to ruin it but the fan is at max speed.

An update: I think it is the nvidia driver. I am using the above drivers, from Manjaro auto install. I removed them and install nvidia 390xx. Unfortunately I got a black screen but this time the fan stayed at normal speeds. Before, with the auto install nvidia, even when I got a black screen the fan went at maximum speed. So I am quite sure it is the Nvidia driver. Not sure though what part of it (because Manjaro installs several things that work with Nvidia), nor do I know what is the solution. I am sure running the fan at max speed is alright, my computer won't blow up, but it is super loud and I really want to fix this.

I am sure this issue has probably been brought up a hundred times in the past. Your best bet is to start sifting through old posts on the forum till you find a solution that works for you. Sorry I can't be more helpful, but as I'm not using your hardware it's impossible to speculate on what might work for you.

A bit more info because I would really like to fix this since it makes it difficult to have voice conversations over the laptop or record stuff.

[tio@tio-pc ~]$ sensors
asus-isa-0000
Adapter: ISA adapter
cpu_fan: 0 RPM

coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +50.0°C (high = +100.0°C, crit = +100.0°C)
Core 0: +50.0°C (high = +100.0°C, crit = +100.0°C)
Core 1: +48.0°C (high = +100.0°C, crit = +100.0°C)
Core 2: +46.0°C (high = +100.0°C, crit = +100.0°C)
Core 3: +47.0°C (high = +100.0°C, crit = +100.0°C)

acpitz-virtual-0
Adapter: Virtual device
temp1: +52.0°C (crit = +98.0°C)

iwlwifi-virtual-0
Adapter: Virtual device
temp1: +52.0°C

pch_skylake-virtual-0
Adapter: Virtual device
temp1: +53.5°C

Also I get an error when I boot the computer something about the CPU being too hot, thought it is not. The fan works normally with a live Manjaro USB.

I also have to mention that it doesn't work to open Nvidia Settings. My suspicion is that the Nvidia driver wrongly assumes that the cpu is super hot so it throttles the fan. But how to check this. How to fix?

I also noticed that my cpu fan RPM is 0. Which is weird. I've read here that you can change that value https://wiki.archlinux.org/index.php/Fan_speed_control#lm-sensors - should I try that? I don't want to break my computer now that Manjaro finally works and I love it, so please advice if you can. Thanks!

The max. temp. parameters for your chipset show 98/100 degs. Why would the fan need to be running at 50 deg.?

Because it is probably a bug. As you can see the fan RPM show 0. When I boot my laptop I see a quick error saying something about cpu being overheated, but it is not overheated. So somewhere I believe Nvidia thinks maybe its gpu is overheated and not cpu? I dont know, but I really want to fix this issue.

Your sensors output is almost identical (before I found the proper drivers) for my Asus Prime Z370-A mobo

You're going to have to do some deep research on your motherboard, and try to find what "Super-IO" chip it uses. It took me almost a month to find what chip my uses (lm-sensors detected the chip, but reported it as 'unknown'), then determine what kernel module is the sensor driver for it. Even after that, you may have to do some testing to correlate the chip outputs to be meaningful.

I've almost got my sensors down now:

[merell@Jammin1 ~]$ sensors -f
amdgpu-pci-0100
Adapter: PCI adapter
vddgfx:       +0.96 V  
fan1:        1278 RPM
temp1:        +93.2°F  (crit = +201.2°F, hyst = -459.7°F)
power1:       11.02 W  (cap =  70.00 W)

nct6793-isa-0290
Adapter: ISA adapter
Vcore:                     +0.33 V  (min =  +0.00 V, max =  +1.74 V)
12V:                      +12.19 V  (min = +11.42 V, max = +12.58 V)
AVCC:                      +3.41 V  (min =  +3.23 V, max =  +3.57 V)
3.3V:                      +3.38 V  (min =  +3.14 V, max =  +3.47 V)
5V:                        +5.08 V  (min =  +4.76 V, max =  +5.24 V)
3VSB:                      +3.41 V  (min =  +3.14 V, max =  +3.47 V)
VBAT:                      +3.12 V  (min =  +2.85 V, max =  +3.15 V)
CPU STBY:                  +1.02 V  (min =  +0.95 V, max =  +1.05 V)
CPU System Agent:          +1.24 V  (min =  +1.14 V, max =  +1.26 V)
PCH Core:                  +1.03 V  (min =  +0.95 V, max =  +1.05 V)
CPUVCCIO:                  +1.22 V  (min =  +1.14 V, max =  +1.26 V)
CHA-Fan1:                    0 RPM  (min =    0 RPM)
CPU Fan:                  1875 RPM  (min =    0 RPM)
M.2 Fan:                     0 RPM  (min =    0 RPM)
EXT_FAN hdr:                 0 RPM  (min =    0 RPM)
AIO Pump:                 1430 RPM  (min =    0 RPM)
CHA-Fan2:                    0 RPM  (min =    0 RPM)
Motherboard:               +84.2°F  (high = +208.4°F, hyst = +203.0°F)  sensor = thermistor
CPUTIN:                    +83.3°F  (high = +176.0°F, hyst = +167.0°F)  sensor = thermistor
Power Supply:             +102.2°F    sensor = thermistor
PECI Agent 0:              +57.2°F  (high = +208.4°F, hyst = +203.0°F)
                                    (crit = +212.0°F)
PECI Agent 0 Calibration:  +83.3°F  

asus-isa-0000
Adapter: ISA adapter
cpu_fan:        0 RPM

coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +107.6°F  (high = +179.6°F, crit = +212.0°F)
Core 0:       +107.6°F  (high = +179.6°F, crit = +212.0°F)
Core 1:       +104.0°F  (high = +179.6°F, crit = +212.0°F)
Core 2:       +102.2°F  (high = +179.6°F, crit = +212.0°F)
Core 3:       +104.0°F  (high = +179.6°F, crit = +212.0°F)
Core 4:       +104.0°F  (high = +179.6°F, crit = +212.0°F)
Core 5:       +104.0°F  (high = +179.6°F, crit = +212.0°F)

I'm not worried about the asus-isa-0000 sensor, because it is incorrect.

Oh, and my case fans are controlled by an on-case controller that suits my needs w/o using mobo headers.

So....what exactly should I do? Can you please be more specific? Cheers

Google your mobo model. Look @ Asus website.

“gl753vd linux” brings up a lot of pages on google.

Forum kindly sponsored by