Few issues on fresh XFCE install

Hi all,

Have just reinstalled Manjaro after using it for quite a while, and instead of just dealing with the issues I have previously come across, I'd like to actually go about fixing them. If anybody is able to help on any of these issues, that would be much appreciated.

Internal 'storage' hard-disk not showing in Devices after auto-mounting in fstab
I have an internal hard drive that I want to automatically mount at boot. Directly after installing, it was showing in File Manager under Devices, but after mounting with the below line, it no longer shows. It is there, since I can navigate to /mnt/Storage, but I want it to show undert Devices for ease of access.
/dev/sdc1 /mnt/Storage ntfs-3g defaults,windows_names 0 0

Unable to boot into Windows after installing Manjaro on a different disk
I have 2 SSDs, with Windows on SDB and Manjaro on SDA. I installed Windows first then Manjaro. I assume the EFI boot files for Windows will have installed on SDB, and now Manjaro has taken preference with its own EFI boot files on SDA. How do I get the GRUB menu to appear at boot with an option to select Windows?

Monitors are switched around at login screen
I have 2 monitors. By default, the are the wrong orientation, in that they 'extend' the wrong way. I have changed this in the Display settings, which works fine, but every time I boot up they are the wrong way around at the login screen, and only fix after logging in. It's a very small issue but gets my OCD going. Is there a way for the system settings to apply to the login screen also?

Thanks in advance for any help given!

create a new profile for the monitors

to automount you want to add it to /etc/fstab

have you run sudo update-grub from manjaro?

if it's not seen, try mounting the EFI partition on the sda drive first. in the future so you know, only 1 EFI partition is needed. the manjaro installer usually default to using an existing one but im guessing you chose manual partitioning?

Have done that - still the same

The code I put IS from my fstab file

Yes, nothing happens. There are 2 separate disk, so 2 different EFI partitions. I didn't do this on purpose, just how it's gone. Didn't do any manual partitioning either... For a dual-boot system people tell you to install Windows first, then Linux, which is what I did. How would I mount the EFI partition from SDB to SDA?

Mount to /media/Storage instead.


That did the job! Thank you kindly.

I can just deal with the monitor arrangement at login, so now to fix the Windows install. Last time I was in this position I had to install Windows again, which I would rather not, but it then allows me to at least enter BIOS and choose which disk to boot from manually. If I do that at the moment Windows doesn't boot when select. I get a cursor flash for a few seconds then get booted back to BIOS.

1 Like

for your grub issue, focus on searching @gohlip 's posts, he's a wizard when it comes to grub issues and i know he's answered the "grub doesnt detect windows" issue many times over. do some forum searching and then if nothing works, create a thread about it.

as for your monitor layout situation, there seems to be something with the latest xfce not remembering layouts and the solution for others in the last day was creating a new profile.

1 Like

@BarbraStreisand Re: grub

  1. Are you positive both windows and Manjaro are in uefi?
  2. Are the 2 drives internal drives or is one of them an external drive?
    You have another internal drive "Storage". All 3 are internal?
  3. At manjaro terminal, please print out output of
sudo parted -l
test -d /sys/firmware/efi && echo UEFI || echo BIOS

sudo parted -l --> small 'L', not 'one'. And output of all drives. Do not omit or truncate.
Explain partitions if not clear, like sdb2 is manjaro /home.. etc

If unsure windows is uefi/bios-legacy, it's okay, but tell us if unsure.


Not 100% sure, installed using a USB that was booted via UEFI.

All are internal. As I say, SDA is Manjaro and SDB is Windows, then we have SDC and SDD which are 2 x 1TB mechanical drives (one for general storage NTFS and another for Steam games installs in EXT4). Guides online seem to want you to install it the other way around, but since Manjaro is my main OS I wanted SDA to be that and then SDB Windows. Not sure if this is my mistake...

Model: ATA SanDisk SSD PLUS (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      2097kB  317MB  315MB  fat32              boot, esp
 2      317MB   240GB  240GB  ext4

Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  17.8MB  16.8MB               Microsoft reserved partition  msftres
 2      17.8MB  240GB   240GB   ntfs         Basic data partition          msftdata

Model: ATA WDC WD10EZEX-00W (scsi)
Disk /dev/sdc: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  1000GB  1000GB  ntfs         Basic data partition  msftdata

Model: ATA WDC WD10EZEX-00B (scsi)
Disk /dev/sdd: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  1000GB  1000GB  ext4


You do not appear to have a windows $esp.
Unless it is the same $esp for Manjaro sda1 (sandisk).
To confirm, at manjaro terminal,

ls /boot/efi/
ls /boot/efi/efi/
ls /boot/efi/efi/Microsoft/
ls /boot/efi/efi/Microsoft/boot/
ls /boot/efi/efi/Microsoft/boot/bootmgfw.efi

If none, you may have inadvertently formatted windows $esp while installing manjaro or windows is bios-legacy in the first place.

I assume you cannot boot windows now but at computer start up, try (don't think so, but please try) at boot key (usually F8~F12) if there is a drive you can select "Kingston" (without UEFI prefix) - (you can try later (if you like) with UEFI prefix, try but most likely won;t work).

If you do not have windows boot file, it doesn't look good and you will have to reinstall windows boot.
And I cannot (don't know how) help you on reinstalling windows boot.
But after reinstalling windows boot, we can help you get back manjaro grub.

1 Like

Yeah there's no Microsoft folder anywhere to be seen.

As you say, it must be that Manjaro wiped the Windows EFI which is annoying. I did look at my BIOS/UEFI and saw only a single entry for the disk with Windows installed on it, which then shows a blinking cursor as I've said above and doesn't load.

There are a good few guides online about how to go about doing this exact setup, but all of them seem to suggest that you need to install Windows on the first disk, which I'm assuming is SDA, instead of on the second like I have.

Instead of re-installing Windows and hacking together the EFI, I'd rather start again and this time put Windows on SDA and Manjaro on SDB to see if that 'just works'. If it doesn't then I can go ahead and hack the EFI to get it all working. I'm looking to create a setup with minimal hacking so if I can get it working out the box just by swapping around the disks each OS is installed on, I'd see this as a worthwhile effort.

I'll give that a try and report back. Thank you very much for the help you've given already. I really wish I could ditch Windows completely but of course there is proprietary software that I need to work with now and again, with no alternative on Linux (Rekordbox). Have tried the VM route, but there always seems to be audio issues.

EDIT: On looking at other guides, some say to completely remove the Windows disk after installing to make sure that the UNIX install doesn't interfere. Maybe this is a more worthwhile tasks, since that would retain both EFI partitions.

o I don't know much about windows, but I think (not sure) you can install in 'sdb'. It's boot just needs to be in a primary partition (gpt is all primary partitions).
o Manjaro can be installed in 'sdb'.
o You don't need to reinstall the whole windows. Just its boot. But as said, I don't know much about windows.
o It is not necessary to remove windows disk when installing Manjaro. Just safer. Safer that you do not wipe out windows $esp, safer when you choose 'sda',sdb',sdc'.... Notice I put in ' ' when saying sda, sdb,sdc...that's because it is never always sda,sdb,sdc...., You must always verify whenever you do commands with /dev/sdax. The problem is not with dual-boot, the problem is with (pointing to) multiple drives when dual-booting.
o Do not format any existing $esp with windows at installation.

Good luck, see you around.... and welcome.


you can download a windows repair utility to reinstall the bootloader, it's somewhere on the ms site im sure you can find with a search

1 Like

Thanks for the suggestion @dglt. In general I wasn't wanting to start messing around with the EFI partition, since I thought this may waste time and would just break things further, but I'm glad to say that I have been able to fix everything with very little effort after a bit of looking around.

I plugged in my Win10 install USB and booted from it so that I could access the Command Prompt. Once here, all I had to do was type the following command:

bcdboot c:\Windows

This seemed to re-create the 'Microsoft' folder that was missing in the EFI partition. After rebooting, I found that I was then booting directly into Windows. On looking at the UEFI settings, I saw that the Windows Boot Manager had been changed to boot first. I changed to back to the Manjaro disk, which booted me back into Manjaro by default.

Once booted up, all I had to do next was to update GRUB with sudo update-grub. After rebooting again, I'm presented with my GRUB menu, which now has a Windows entry (that works).

Thank you all for your help with resolving my issues. Things like this make me a more confident Linux user and helps with getting comfortable with the system, even when things break. Glad I reached out to ask the community for help. There will be other issues I'm sure, but I can cross that bridge when I get there.

EDIT: Grammer


Didn't see this reply until now - apologies.

This isn't what's happening with my system. The settings DO stick after reboot, but the screens are in the wrong arrangement ONLY when at the login screen. After creating a profile, the correct arrangement applies instantly after logging in, but not when sat at the login screen.

Since the other two issues have now been resolved, this seems trivial, since I only spend the amount of time at the login screen to enter my password before the issue corrects itself.

Thank you again for your help.

1 Like

lightDM makes it easy to handle that stuff. you can use the display setup script line in lightdm.conf to issue an xrandr command or run a script with xrandr commands in it. it's very easy


1 Like

Although that page doesn't have specific config for my issue, it has pointed me in the right direction. I didn't know that LightDM was responsible for the login screen, so that has really helped. It's not so much which screen the login window appears, it's that when I try to move my mouse to the other monitor, they have been swapped around. So, when I try to move my mouse from the left monitor to the right, it doesn't work. If I move the mouse to the left (where there is no monitor), it then appears on my right monitor.

Either way I think I'm on the right track now, so thanks again for your help. I will make sure to reply with the fix for this issue when I get there.

you can take care of that with xrandr commands run as a lightdm display setup script. arch has an xrandr wiki also if i didnt mention it before. when lightdm runs xrandr commands will run and designate which monitor is where.. for example hdmi-1 is left of hdmi-2 and so on.

1 Like

Yes, I did come across a command that was meant to fix this issue, but I found that the greeter 'lightdm-gtk-greeter' has its own config file which doesn't take the same command, meaning the command I entered isn't being used. I'll see what else I can do. I can always disable one of the monitors at the login screen which would get around that issue.

a common mistake when editing lightdm.conf is editing the wrong set of lines, there are 2 [Seat:] sections, the first is only examples and the seat section further down is the one you need to edit. the example on the arch wiki should work just fine if it's implemented properly.

first make sure xorg-xrandr is installed, otherwise xrandr commands will not work for obvious reasons.

then get the displays names from xrandr output, mine for example:

>>> xrandr --listmonitors                                                                                                                                                                  
Monitors: 1
 0: +eDP-1-1 1920/344x1080/194+0+0  eDP-1-1

so i would edit lightdm.conf (the lower seat section, uncomment line)

display-setup-script=xrandr --output eDP-1-1 --primary
1 Like

Yep, I was indeed putting my command in the wrong area of the lightdm.conf file. I found an AskUbuntu page HERE which showed me where I was going wrong, as well as how to use arandr to copy the config from my working desktop environment to paste into that config file.

After a reboot I'm glad to say it works perfectly!

Thanks again for all your help!


Forum kindly sponsored by