Filesystem unknown on Linux partition. Can I boot into windows?

I have a refurbished Lenovo t450s with windows 10 installed on it. There are 3 ntfs partitions (windows, restore, and a 100mb system partition) and a 4th partition that I installed Manjaro KDE on (as well as some unpartitioned space) on what I believe is 2 ssds (an internal and an mdot drive is how I think the t450s is set up) set to be one logical drive (either that or it's just one SSD, but all I have is same, not sdb). I don't remember what I formated the Manjaro partition as but I assume ext4 with 4k blocks. However after restarting one day GRUB is giving me a "error: filesystem unknown" in rescue mode. ls'ing all the partitions just returns the same error. Booting into the live CD lsblk gives doesn't show a recognized filesystem on that partition. e2fsck says there may be an error with the super blocks, but checking all the backup super blocks for 4k block size doesn't work either (I haven't checked 1k or 2k yet). The firmware is set to boot into bios/legacy mode first and then try uefi.

I was going to install another copy of Manjaro in the unpartitioned space and the see if I could recover the broken partition later and/or boot into and back up windows and start from scratch, but since it is using MBR, it only allows for 4 partitions.

There isn't really anything important on the computer yet, but in case there was I'd like to know/learn if there is a proper way to fix it other than deleting and reinstalling Manjaro.

Is there a way for me to boot into windows 10 with grub not working and without a windows recovery disk?

I think you'll have more luck fixing it using just that live media you were using. It's not really different than installing it on a separate partition, so I don't really see any reason to do that.

I will check if e2fsck works on 1k or 2k blocks, but it that doesn't work I'm not sure what to do. Everything else I have tried (including testdisk) is giving some varient of filesystem unknown (and so I can't chroot into it and run grub-install), and since I am already at 4 partitions I can't create a new one without deleting an existing partition. I'd like to know the right way to fix it, but I'd also like to get back to using the computer.

It might take you a couple hours to figure out what the "right" way is. I tend to take these kind of issues on a per-issue basis, and respond accordingly. In this case, it seems like a non-trivial issue where the loss by reinstalling would be very small.

Your windows is bios-legacy, so take the manjaro livecd, start it in bios-legacy mode, and at the grub prompt,

grub> insmod ntfs
grub> insmod ntldr
grub> search -f /bootmgr
grub> search -f /bootmgr --set=root
grub> ntldr /bootmgr

That will boot into windows.
Easier and safer.

ps: if "grub> search -f /bootmgr" gives 2 output, one is your recovery partition and the other is your OS partition. select the OS partition by
grub> set root=(hdx, msdosy)
and continue with ntldr command.

ps: if your system grub (not grub rescue) is working (press 'c' to go to prompt), you can use that, but make sure it is in bios-legacy mode.

1 Like

Because the filesystem isn't recognized, I am unable to mount the partition that has grub on it.

The right way is to boot to your Live media and collect information.

sudo fdisk -l
inxi -SMDpuoxxz

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by