Finalizing Manjaro Gnome 18.0 installation - help a Linux newbie pls :)

Hello everyone.

I am a dedicated Windows user who decided to switch to Linux for safety, stability, experimentation and other Linux benefits.
I didnt completely drop usage of Windows because I need it mostly for gaming and some Adobe programs, but for everything else I will be using Manjaro, so I decided to make a dualboot.

I had some complications here and there with the installation:

  1. I reinstalled my Windows 10 to shorten memory usage and clean my SSD (C disk,boot, 128gb). Than I made a separate RAW partition from it (40gb) for my Linux instalation. There were no problems with that in particular.

  2. I downloaded latest Manjaro Gnome 18.0. ISO release and made a bootable USB device using Rufus software. Ive seen a lot of different settings for making a boot USB from other users, depending on the hardware, so I wasted hour or two on making and testing the right thing. My finalised USB boot was in FAT32 system as I recall, and I had to make it in a DD ISO mode, because classic ISO image mode didnt start the Manjaro boot manager on my system.

  3. So finally I boot from USB and I could see Manjaro boot/installation manager where for the first time I simply choose my keyboard and language settings and tried an instant install, but with no success. When Linux was trying to boot there was a repeating line of code "A start job is running for LiveMedia MHWD Script" and didnt go any further.
    So I did some research and realised that in boot manager I need to set drivers to "non-free" cause I use an Nvidia graphic card and in the boot console (or whatever you call it) I had to type "systemd.mask=mhwd-live.service" or instead I wont be able to isntall.

  4. So I reboot my PC after that, tried to start the installation again and wow, it actually worked. Installation was fast and smooth, and Linux told me to reboot to finalize the instalation.

  5. PC rebooted successfuly and opened dualboot windows manager. On the top was my Linux Manjaro, in the middle advanced Linux Manjaro boot options where I could choose my Kernel version (4.9.0.) and on the bootom was Windows 10.

This was for the installation part.

I tried Windows 10 first and it booted superbly, so I rebooted again to try Manjaro.
There was a black screen at first with no loader or whatever, and after a short period my Manjaro user login interface showed up. I was like "Yes! This is it!!", so I typed in my user info, pressed the login button and after that my Manjaro instantly crashes/freezes with some wierd graphical glitch on the to left screen corner.

My question for you guys is what to do now to make it completely usable? Ive seen some advices for trying to type some lines like for starting my installation. But I dont know where to type them to make it work, cause I figured if I type them in my USB boot manager it wouldnt make any difference since Manjaro had already been installed. I also cannot open Terminal on my User login screen because Manjaro would freeze/crash again.

Sorry for the longpost, I figured you guys would need as much info as I can get you. :slight_smile:

Hi, first welcome to Manjaro.

so lets see, I did not run in such an issue, so my knowledge is limited. But I will try to do what I can:

  1. You will find some methods to log into your not working system here:
  1. if you have access to your machine either through tty or via the live-session follow this guide to post informations:
  1. Are you really running kernel version 4.9.0 or are you running 4.19.0?

  2. You might want to try the non-free driver from nvidia here is an manual install guide:

If the nvidia driver does not work, get again access to your system and run sudo nvidia-xconfig

1 Like

I would not suggest running this command, since AFAIK it interferes with the Archlinux/Manjaro/mhwd Xorg setup.

The posted tutorials is what I was going to recommend as well!

It looks like a "usual" nvidia issue, that needs some info to make the right corrections.
I just hope OP is not affected by the doomed Gnome ISO issue

1 Like

Guys, first of all thanks for help! :slight_smile:

My kernel version was 4.19, sorry on that part.

And yea, I managed to install Gnome (had to do some python editing in live mode ). Everything is working great for now except few things:

  1. I have a hybrid laptop, so my deafult graphic card driver is Intel ones. I want to enable my Nvidia gtx1050
  2. So I tried to go into my Manjaro settings manager for Hardware configuration menu. I click on it and the HC starts loading and freezes entire manager, sending me "dont respond app error" if I use ctrl+alt+del. Everything else in settings manager works fine..

use optimus-manager
its in wiki and on forum
i dont have nvidia so its the only help i can provide

I installed optimus, bumblebee and nvidia 390xx driver utils . Trying to figure out what now.

It was intended to only run this command, if the setup does not work anyway, as far as I remember were in the past issues with a missing xorg-config with nvidia. But checking this seems you are right in the optimus case.

Thank you for this information

1 Like

Thanks. Im on it.
Now I have a problem where I want to delete some files, but I cant cause Im not "the right owner".

use sudo rm

These are common signs of a Windows converted :joy:
You need some Linux education, so you don't get into problems.. before it's too late..
Check in Gnome settings for the proper keyboard shortcuts and read about permissions and ownership and why they exist. If you are not the owner then you should not delete those files. If they are on a data partition (not system), you have to look for proper mounting setup.
Give yourself some time reading, if you want to be a Linux user, as it seems you do. :wink:

Edit: check this for kernel parameters, it seems relevant

Im trying your option, but my Hardware Configuration menu doesnt work.. It freezes and keeps loading :confused:

Edit: You know what. I wont be installing Nvidia drivers. I have Windows for gaming so I dont need it. I just wanted my GUI to be as fluid as possible. I guess it is possible with updated Intel HD drivers. Are there any?

P.S. I would still like to have that hardware configuration menu fixed. And a few more things.

  1. When Im trying to restart, theres this thing going on and on..

  2. I realised that my first problem with booting was because I didnt install Manjaro with option "Automatically login into acc". When I had to login bug looked like this. IMG_20181129_110340

I guess disabling Nvidia in Linux should fix it or?

If you mean the kernel parameters, how did you do it?

It seems your video drivers need proper setup. But untill you are able to provide credible info about your hardware and your currentlly installed drivers and configuration we can't just guess..
Can you at least post Xorg log?
It should be at



Sorry for the delay.

So I almost got rid of every problem. After some research and thanks to the info. you guys provided me I changed some boot options in etc/default/grub.
Later updated grub in terminal to keep the changes and rebooted.
Everything is fine with shut down and restart,hardware configuration and system in general are working decently on Intel HD.

Now for the additional changes I had to make. In grub changed old and added:

acpi_osi="!Windows 2015" - Im sure this one works.

nouveau.modeset=0 **,**acpi_osi=Linux - These two were on a lot of forums

Now for the last 2 things I want to do is to test log-in with password, since I had problems with it and to test nvidia info. you gave me.

Thanks for the help. I have learned a lot in the last few days. Linux is fun ^^ :slight_smile:

I did the whole nvidia guide and got this

Is this ok? My setting still says "Intel HD"


It looks like a proper hybrid bumblebee.
Have fun!!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by