Firefox 58 won't open

Hi torvic,
its not need to uninstall "all" Firefox packages. Only the AUR-Package ( firefox-kde-i18n) must be uninstall.

Does anyone know is this "Firefox not opening" problem isolated to KDE? I am using XFCE and have not updated yet [Stable] . thanks

Not directly to KDE, but to firefox-kde which isn't in the repos anymore.

No - it's because of the language packages (which is what is "solved" in this thread).

If you have old language packs (or other extensions) these can prevent Firefox from loading, no matter the DE.

Thanks torvic, if I've been using Firefox on XFCE all along, I should be good to go updating then [at least as far as Firefox goes]?

edit: just saw Jonathan's post, I will look over my language packages, thanks

Yes. Go and update... :stuck_out_tongue:

This is a piddly and easily-fixable issue if and when it does occur, and even if it does happen you can easily switch to Chromium temporarily.

Thanks Jonathan, I just searched package manager for Firefox, it appears no language packages are even installed.

My issue was not resolved by uninstalling the firefox-kde language pack and installing the normal one (nor by reinstalling all firefox packages).

Also, I seem to have two really similar versions of firefox installed.

  1. firefox-58.0.1-0-x86_64.pkg.tar.xz (local)
  2. firefox-58.0-1-x86_64.pkg.tar.xz (local)

I'm going to try restarting my computer...

EDIT: solved by refreshing firefox.

Hi guys, I have solved by uninstalling language pack firefox kde (sudo pacman -R languagepacket) then install local/firefox-i18n-language
Thanks Guys!!!

How is that possible? The newer one should replace the older one - that's the whole point of package updates. Did you do anything "special" to update?

Tanks dude. It worked for me.

1 Like

Woops, I should NOT have said "installed." Those are just the ones listed when I do the downgrade option.

Sorry about being misleading.

1 Like

Thank you for all your suggestions. I finally got it to work.

  1. I too had the old KDE ver 57 language pack, but removing it and installing the new firefox ver 58 one did not fix it.
  2. I tried renaming the "perfs.js" file, but that did not fix it.
  3. Last I tried the safe-mode start and removing the one(1) outdated add-on, Firefox now will launch normally again :wink:

Again, thank you all! Cheers

Thanks to all for the useful info. I had to remove the firefeox-kde-i18n language pack, start Firefox in safe mode, and do a refresh before installing the new Firefox language pack before it would work for me.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by