Firefox 62.0.3 rendering issue

Firefox not rendering Twitter correctly


Confirmed on 2 physical and 1 virtual Manjaro installation with Firefox 62.0.3

Posting as Manjaro Application issue since all my other distros render correctly with Firefox 62.0.3.

Also confirmed by at least one other on Twitter so far:

So far Twitter is the only site I can confirm is affected. Using Chromium works fine. Using previous Firefox versions work fine.

There are no certificate errors, and system time is correct.

\o/ I'm not alone. is also affected.

1 Like

Good to know. Seems to be a thing for sure, but not sure why it's only Manjaro.

Changing security.tls.version.max to 3 instead of 4 fix it (about:config).
Fixing problems by lowering security <3.

This does make it work, but this is not a solution unfortunately.
On all other distros, the setting is also set to 4 (confirmed it) and Twitter/GOG still works fine.

Seems related:

Edit: The problem returned after several minutes, so the solution below does not work reliably.

The following seems to have fixed the problem for me....

Select Preferences from the main (hamburger) menu.

On the Privacy & Security tab, under Cookies and Site Data, click Manage Data....

Type twimg and click Remove All Shown.

Now reload a Twitter page to confirm that the problem has gone away.

Not working

Changing network.http.spdy.enabled.http2 from true to false also work, source:

1 Like

This also works. In either case, this is a workaround. But it does hopefully help figure out what the actual issue is.

Between the two, I might be more comfortable with the first option.

Not seeing the problem here.

Steve, is your entire system up-to-date also?

Yes, I run unstable, I update several times a day (off sick - had my left knee replaced)

It seems working with this:
security.tls.version.max = 3

Have you tried with a new profile, or refreshed FF?

I also had the problem on stable release. Twitter and Tumblr were affected the same. Changing security.tls.version.max did the trick, but here is another interesting message :

curl '' -H 'User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0' -H 'Accept: */*' -H 'Accept-Language: fr,fr-FR;q=0.5' --compressed -H 'Referer:' -H 'DNT: 1' -H 'Connection: keep-alive'
curl: (16) Error in the HTTP2 framing layer

So it's related to HTTP2 implementation, but not directly firefox related it seems.

Worth reading:

Something happening, certainly google and microsoft secret plan to kill firefox :grin::

I had this happen, too. Twitter itself seems to work again, but videos from Twitter, even embedded, now have completely distorted audio. Also I noticed since about half a day ago streams on immediately stop and the video controls disappear. Looking in the inspector, it only loads 1 video segment every time I click on it. What is even happening.

I should add - setting security.tls.version.max to 3 worked for Picarto. GOG was also fixed without any config changes.

"Hi, TLS team lead for VDMS here. We've rolled back the change that creates this issue and we're investigating on our side. Thanks for the info and apologies for the disruption."


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by