Firefox crashing on any invocation of file dialog

Fresh install of Manjaro KDE edition as of this morning. Tried a fresh, clean profile, too. Any invocation of file dialog will immediately crash firefox. For instance, right click > save image as, file > save page as or even file > open (ctrl+o).

I submitted this crash dump:

I can gladly write out a bug report, just not sure who to file it with? Firefox? KDE? Manjaro?

Did you update your system after installation? After the big update of yesterday ─ which included going from Plasma 5.17.5 to Plasma 5.18.3 ─ there was another small update; I think it was xdg-desktop-portal, which is an essential package for browser integration.

Log out of KDE Plasma completely, press Ctrl + Alt + F2 and log in at the character-mode login console with your normal credentials. Then issue the following command: :arrow_lower_left:

sudo pacman -Syu

After the upgrade process, make sure you reboot your system... :arrow_lower_left:

sudo sync && sudo systemctl reboot

Thanks for the reply. I had run updates after the install, including a reboot, but from KDE (pacman CLI in konsole). I just tried a logout and terminal switch (ctrl alt f2), pacman reports nothing to do. Anything else I should do?

Make sure the xdg-desktop-portal-kde is the 5.18.3-1.2 version. Refresh mirrors then update.

Another way is like this, ignore the switching branches mention:

pacman -Q confirms that xdg-desktop-portal-kde is already at 5.18.3-1.2. I forced a reinstall (`pacman -S) in case, followed by a reboot. The issue persists.

Seems that the update broke the firefox save as dialog for someone else: [Stable Update] 2020-03-14 - Kernels, Plasma 5.18.3, KDE Frameworks 5.67, KDE Apps 19.12.3, Firefox, Kodi

Although in their case, nothing happens (instead of a crash).

Run this command:
sudo pacman -S libpipewire02
Log out and back in and let me know if the file dialog works.

error: target not found: libpipewire02

I have the following:

extra/pipewire 0.2.7-2 [installed]

Ok, now i see the issue. The only way to solve it is by doing

I see. I'll try and report back. Is this a current bug in manjaro? Or a workaround for a KDE/Firefox bug?

Thanks a lot for the help so far btw!

error: failed to prepare transaction (could not satisfy dependencies)
:: installing pipewire (0.3.1-1) breaks dependency 'pipewire<0.3' required by xdg-desktop-portal-kde

that means you do not have the pipewire-0.3 installed

I'm not sure I follow. I'm trying to install pipewire=0.3.1, but pacman refuses because xdg-desktop-portal-kde requires pipewire < 0.3

Well, i do not have a stable install at this point to test it out. The only difference i see is that in stable the xdg-desktop-portal-kde is version 5.18.3-1.2 while on testing and unstable is 5.18.3-1.3
That should not create any issue tho ... but ... :man_shrugging:

Bump... still having the issue. Is there anywhere I can report this bug? Is the manjaro gitlab the proper place for bug reports?

I'm living with wget for saving images/pages, but not being able to upload stuff is starting to be a showstopper.

Hi everyone, unfortunately the latest stable update does not fix the issue for me :frowning:

  • The update did install pipewire 0.3.1-1
  • I manually installed libpipewire 0.2.7-1
  • I added export GTK_USE_PORTAL=1 to /etc/profile.d/
  • I rebooted multiple times

I do however have new info to provide. When starting firefox from a terminal, I get the following messages as it is crashing:

(firefox:3725): Gtk-WARNING **: 08:42:03.659: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
Gtk:ERROR:../gtk/gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)
Bail out! Gtk:ERROR:../gtk/gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)
Redirecting call to abort() to mozalloc_abort

ExceptionHandler::GenerateDump cloned child 3966
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.

Any ideas?

Try this:
pacman -Syu shared-mime-info gdk-pixbuf2

I would make sure the system is updated before anything else.
sudo pacman -Syyu


I got some weird errors from that about not being able to rename files. When I tried manually renaming the files, I got other weird errors ("Structure needs cleaning")

So I booted from live usb, ran fsck on the partition and it found and fixed quite a few errors.

Rebooted back into manjaro, manually removed problematic files, reinstalled shared-mime-info gdk-pixbuf2 then:

sudo -i
umask 022
update-mime-database /usr/share/mime

And now it works! It also fixed a weird issue I had where checkboxes were invisible in firefox and thunderbird.

However, I'm now thinking there might be something wrong with my ssd.

Anyways, thanks a bunch @bogdancovaciu :+1:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by