Firefox freeze

My firefox freezes or just quit unexpectedly.
Have tryed other browsers like chrome,opera,brave etc.
But still be the same.
Any suggestions ?

I suggest you include some information.


Plus basics .. like starting firefox in the terminal and seeing any error messages when it quits.

System:
  Kernel: 5.5.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.5-x86_64 
  root=UUID=a36df0e5-a6dd-40b0-aa0f-f3babc88d6a8 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: GA-MA770T-UD3 serial: <filter> 
  BIOS: Award v: F10 date: 03/22/2011 
CPU:
  Topology: Quad Core model: AMD Athlon II X4 645 bits: 64 type: MCP 
  arch: K10 family: 10 (16) model-id: 5 stepping: 3 microcode: 10000C8 
  L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 24922 
  Speed: 1900 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 800 2: 3100 
  3: 3100 4: 800 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA G96C [GeForce 9500 GT] driver: nvidia v: 340.108 
  bus ID: 01:00.0 chip ID: 10de:0640 
  Display: x11 server: X.Org 1.20.8 driver: nvidia 
  resolution: 1280x1024~60Hz 
  OpenGL: renderer: GeForce 9500 GT/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108 
  direct render: Yes 
Audio:
  Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
  Sound Server: ALSA v: k5.5.19-1-MANJARO 
Network:
  Device-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter 
  driver: 8139too v: 0.9.28 port: de00 bus ID: 02:07.0 chip ID: 10ec:8139 
  IF: enp2s7 state: unknown speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 267.50 GiB (28.7%) 
  ID-1: /dev/sda vendor: Toshiba model: HDWD110 size: 931.51 GiB block size: 
  physical: 4096 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm 
  serial: <filter> rev: A8J0 scheme: MBR 
Partition:
  ID-1: / raw size: 931.51 GiB size: 915.89 GiB (98.32%) 
  used: 267.50 GiB (29.2%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 28.5 C mobo: N/A gpu: nvidia temp: 48 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40% 
Info:
  Processes: 195 Uptime: 2h 52m Memory: 3.84 GiB used: 2.79 GiB (72.6%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 clang: 10.0.0 Shell: bash 
  v: 5.0.16 running in: xfce4-terminal inxi: 3.0.37
journalctl
-- Logs begin at Sun 2020-02-02 19:37:39 EET, end at Mon 2020-04-27 20:37:58 EE>
фев 02 19:37:39 zumaha-pc kernel: Linux version 5.4.15-2-MANJARO (builduser@dev>
фев 02 19:37:39 zumaha-pc kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.4-x8>
фев 02 19:37:39 zumaha-pc kernel: KERNEL supported cpus:
фев 02 19:37:39 zumaha-pc kernel:   Intel GenuineIntel
фев 02 19:37:39 zumaha-pc kernel:   AMD AuthenticAMD
фев 02 19:37:39 zumaha-pc kernel:   Hygon HygonGenuine
фев 02 19:37:39 zumaha-pc kernel:   Centaur CentaurHauls
фев 02 19:37:39 zumaha-pc kernel:   zhaoxin   Shanghai  
фев 02 19:37:39 zumaha-pc kernel: x86/fpu: x87 FPU will use FXSAVE
фев 02 19:37:39 zumaha-pc kernel: BIOS-provided physical RAM map:
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x0000000000000000-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x000000000009f800-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x00000000000f0000-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x00000000cfdf0000-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x00000000cfdf3000-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x00000000cfe00000-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x00000000e0000000-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000>
фев 02 19:37:39 zumaha-pc kernel: BIOS-e820: [mem 0x0000000100000000-0x00000001>
фев 02 19:37:39 zumaha-pc kernel: NX (Execute Disable) protection: active
фев 02 19:37:39 zumaha-pc kernel: SMBIOS 2.4 present.
lines 1-23

What is the output of swapon -s ? How much RAM do you have? Also, when was the last time you updated your system?

swapon -s
Filename				Type		Size	Used	Priority
/dev/zram0                             	partition	1007308	1005524	-2
/var/lib/systemd-swap/swapfc/1         	file    	524284	502356	-3
/var/lib/systemd-swap/swapfc/2         	file    	524284	516920	-4
/var/lib/systemd-swap/swapfc/3         	file    	524284	511988	-5
/var/lib/systemd-swap/swapfc/4         	file    	524284	335188	-6
/var/lib/systemd-swap/swapfc/5         	file    	524284	11764	-7
/var/lib/systemd-swap/swapfc/6

I have 4 GB of RAM and have updated my system yestarday.

A very long time ago ..
https://manjaro32.org/repo-compare/

Package stable testing unstable
linux54 5.4.35-1 5.4.35-1 5.4.35-1

...

If you updated yesterday it seems you have neglected your mirrors.

sudo pacman-mirrors -f && sudo pacman -Syyu

Something's odd here, why does his journalctl say 5.4.15-2 but his inxi says 5.5.19? :thinking:

I were on 5.5 kernel,but deleted it.

@cscs :: Starting full system upgrade... there is nothing to do

Which makes it even more apparent you have probably been doing partial upgrades ...
(your 5.5 kernel was on a correct version)

How on earth do you have 5.4.15-2 then ?
So you are supposedly up to date, restarted, and in 5.4 ?.. what does this show?

uname -r

Oh ok. Go ahead and follow @cscs's instructions then.

5.5.19-1-MANJARO ..... :smiley:
I can update to the latest if its needed.

You just stated you deleted kernel 5.5 ...

Yes and back to 5.4

Did you restart your system after removing kernel 5.5? If not, do it. You need to reboot to change kernels completely.

Yep offcourse

Your output shows you still running 5.5 ..
You need to restart to change kernels.
Also .. as an aside .. you shouldnt delete running kernels. You would boot into 5.4 then delete 5.5 ..

I restarted it again.

Alright. Install 5.4.35-1. Do NOT delete 5.5.19-1. Restart again, and this time hold down the shift key as the system boots. When GRUB bootmenu appears, select advanced options, and boot into 5.4. Then delete 5.5.

Does it matter ,if i upgrade it to latest (5.7) ?

It could be the kernel is what is causing your freezes. The LTS kernels are the most stable, so let's try 5.4

Forum kindly sponsored by