Firefox Sync

Hello!

Since either the last stable update or the one before that I am having an issue with Firefox Sync on one of my computers. I noticed newly added bookmarks were not synced and after disconnecting Sync, deleting the existing data on that Firefox and thereafter reconnecting Sync I ended up with no bookmarks at all. So obviously it is not syncing at all, but it does not display any error message either if you manually start syncing by pressing "sync now".

Any ideas?

System:    Host: xxx Kernel: 5.3.8-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.2 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8Z77-V LX v: Rev X.0x serial: <root required> UEFI: American Megatrends v: 2501 
           date: 07/21/2014 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325 charge: 55% (should be ignored) status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-3570 bits: 64 type: MCP arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27291 
           Speed: 1605 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1605 2: 1605 3: 1605 4: 1605 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: Micro-Star MSI driver: nvidia v: 430.40 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK P8Z77-V LX driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 
           Device-2: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-3: Logitech HD Webcam C510 type: USB driver: snd-usb-audio,uvcvideo bus ID: 2-3:3 
           Sound Server: ALSA v: k5.3.8-3-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK P8P67 and other motherboards 
           driver: r8168 v: 8.047.04-NAPI port: d000 bus ID: 03:00.0 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 30:85:a9:9e:0f:5c 
Drives:    Local Storage: total: 853.29 GiB used: 127.10 GiB (14.9%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 830 Series size: 119.24 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 PRO 256GB size: 238.47 GiB 
           ID-3: /dev/sdc vendor: Samsung model: HD501LJ size: 465.76 GiB 
           ID-4: /dev/sdi type: USB vendor: Lexar model: USB Flash Drive size: 29.81 GiB 
Partition: ID-1: / size: 224.77 GiB used: 127.10 GiB (56.5%) fs: ext4 dev: /dev/sdb2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 49 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Info:      Processes: 204 Uptime: 18m Memory: 7.73 GiB used: 1.76 GiB (22.8%) Init: systemd Compilers: gcc: 9.2.0 Shell: bash 
           v: 5.0.11 inxi: 3.0.36 

While I am not using KDE - I assume that Firefox work's the same way no matter which edition.

There has been an issue with Firefox and profile compatibility but I don't know if it is connected to your issue.

Did you try using the Sync now from the sync menu?

This - I think - is default sync behavior - it is like telling sync to remove all sync data.

I am very careful with the sync service - both Chromium and Firefox sometimes removes sync data - most often due to a wrong sequence of action. If I recall - disconnecting sync usually warns that data will be removed.

Sync is b0rk3d. No official statement yet.
Reddit thread at: https://www.reddit.com/r/firefox/comments/dtr1a0/firefox_sync_servers_down/

That sounds off to me - but what do I know - other than sync works for me - has for the last 4 hours.

Yes, when disconnecting you have a choice to either keep local data or delete it. It should be retained on Mozillas side though. Nevertheless it's always a good idea to backup the bookmarks, which I fortunately did.

We'll see if pedros link is the solution. Unfortunately I currently do not have access to my laptop to try things there.

So I will just wait and let you guys know. Thank you so far!

Then it is just for a few users, which explains the lack of official statement.

In the meantime a bug was filed and solved (https://bugzilla.mozilla.org/show_bug.cgi?id=1595298), and actually this solved my problem as well. So everything is working fine again :slight_smile:

Can't remember how it happened, but I lost half my bookmarks with FF sync. And a similar thing happened with Eversync. I now use Vivaldi which thus far seems fine.

But I would prefer to use my pCloud drive.

My ideal solution for all this is a browser which works on my 2 Manjaro laptops & an Android cellphone, all accessing bookmarks and PW's from same set of files on my cloud drive. And all without using Google servers. All three can access pCloud drive which syncs well.

Is this possible? If so, would love to find instructions somewhere because this is a bit above my computer skills 'paygrade.'

(I tried to install degoogled chromium, but two times it hung up during the build process and failed. Pity. Chromium is in many ways the most stable and easiest to use.)

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by