Firefox & Terminal starting up automatically

Hi!
I wasn't sure where to post this so I'll do it here.
I've been using Manjaro for a while now, with XFCE, and since I've installed it that when I start my computer the terminal emulator and firefox open up automatically.
I've checked everywhere possible, I believe, from this page https://wiki.archlinux.org/index.php/autostarting to no avail.
Does any of you know what might be causing this? I tried to remove Firefox and all configuration files, and reinstall, but it keeps doing this.

Thank you,
André

Are you starting with your old session. You may need to enable start with a fresh session option.

Sorry I don't use xfce so I can't walk you through how you change xfce settings.

When you logout/restart you have the option of restoring your session on next login.

Disable that option.

Alternatively to @linux-aarhus 's solution
There's in Xfce Settings - System/Session & Startup - General: Tickbox 'Automatically save session on logout'
https://docs.xfce.org/xfce/xfce4-session/preferences

Prepare a clean session without running apps - tick on - log off - log on again - tick off

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by