First dualboot on macbook air and wifi

Hello people!
So I'm a macuser that got sick of the OS and wants to explore Manjaro.
At first, I tried Manjaro live in VirtualBox at my office's mac mini with ethernet - everything was great and I decided to put it on my main home laptop.

Because of my work software and stuff on macOS, I decided to split my Macbook Air's 128GB SSD on halves. I did the split in macOS, then booted on live-usb made in (Note: I dont have the ethernet cable on mbA, just wifi).

Manjaro live didn't have wifi working, but i decided to install it on the second half of SSD anyway and solve it later. Install went supersmoothly (just when it asked me for the partitions, it also told me that I need EFI partition, so i made 128mb /boot/efi with esp flag - and the rest of the 60GB I set as Root and it installed it and works fine although i just followed instructions and dont really know if 128is ok but thats not the point).

But the Full Manjaro installation still don't have wifi drivers on my Air.

It's manjaro-gnome-17.1.10-stable-x86_64, and when I reboot to macOS parition and check the info, its Broadcom BCM43xx 1.0 wifi. (Note that I also tried install debian before and during the installation, it offered me a list of drivers and i tried all related Broadcom one's and none of them let me continue).

So, what can i do to get wifi working guys? Reminding I dont have ethernet but i can freely download stuff from macos parition and copy that to manajro.

Second less important question: Is there something I can do to not press Option key everytime when i start the mac > then clicking EFI boot, then enter? (So it priorities manajro boot before macos one)?

Thanks a lot :slight_smile:

Try this

You can define the Target Boot from mac os and set to be the boot for manjaro ...

It is more then ok. My EFI partition is 200MB and gparted shows that Manjaro is using 3,3MB... ;D. So 200mb or 128mb - that's even overkill.
As to Mac part, I don't have one so I don't know anything about it.

Could you please post the results of:

inxi -Fxcz0


You could also try installing more recent or older kernels to see if your wifi improves.

so inxi -Fxcz0 gave me Unsupported option: -0
the inxi without parameters returned (image)

the other command is in the other image
(phone photos because again, no network there)


Can't you save them to a text file and transfer to phone?
Use command >> MyInfo.log and get MyInfo.log to your phone.
Try these

inxi -SNxxz
lsmod | grep BCM

Have you tried setting boot order from MacOs ?

Hi, I managed to connect to the Internet via iPhone's bluetooth sharing.
Your command returned this:

Host: core Kernel: 4.14.39-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 7.3.1 Desktop: Gnome 3.28.1 dm: gdm
Distro: Manjaro Linux 17.1.10 Hakoila
Card-1: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter
driver: bcma-pci-bridge v: N/A bus ID: 03:00.0 chip ID: 14e4:43a0

Check this,x#Wi-Fi

More options here

Ive tried the first one, didnt work.
Second one, rebooted, didnt work.
Now, system offered me to install other kernels so im downloading one of the older ones.
about the mac part, i loaded up the Startup Disk app but the macOS is the only options there, seems like it doesnt recognizes it from the macOS system as another bootable thing.

To see what maybe the problem, describe your method and if in terminal, post the output.
About Grub, we may need to use the Force. Luke!! @gohlip

These Macs seem to have nothing but issues with their Broadcom chips. You will need to tether a phone to install the drivers properly. I'm on my cell, so I couldn't read a thing from your pic, but I did catch the bcma-pci-bridge listed as the driver. That means you have conflicting drivers installed because your card was not detected properly during install.

See links:

Sorry that should have been inxi Fxcz0. I'm on my cell and I miss things because of my vision when I do a typo.

you did it again :stuck_out_tongue_winking_eye:
inxi -Fxzc0
[thats the one^]

Oh Jesus my eyes are getting bad. I'm at my girlfriends. She only has a windows machine which I detest using. On my phone I'm half blind.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by