First Install of Manjaro on AMD Ryzen PC with NVidia GFX-Card

Hi,
I have some problems on installing Manjaro from a live USB Device on my (new) PC. It always goes until the line
-- [ OK ] Started TLP system startup/shutdown --
and then it does not go any further.
It is Manjaro Live ISO with Linux 5.4.6-2-MANJARO.
Here is what inxi -Fxxxz says:
inxifxxxz
I assume that there is a problem with the graphics because this motherboard has a separate gfxcard which i cannot disable in BIOS and there is one NVIDIA GFXCard installed which is extra. On the nvidia Gfxcard the monitors are connected.
When i try to start XServer manually with startx then the following error comes in /var/log/Xorg.0.log: Fatal server error: no screens found (EE)
When booting from Live USB Stick i had to make the following settings (driver=nonfree) otherwise i get strange signs on the screen, with this setting on nonfree (i assume there is the nonfree nvidia driver meant) the PC boots till the string mentioned above and then the xserver does not start.
I googled for now 2 hours but there werent any suggestions who could help.
So I ended up here and hope the community can help me.
Thanks in advance!
M.

Please don't use photos - select the text and paste into your topic then select the textand click the </> button in the post toolbar before you submit the topic.

Same goes for comments - no one cares about pictures - it is a tech forum not an image gallery :slight_smile: if you get my drift.

There is several no-install pastebin services.

1 Like

ok, sorry for that. I have problems getting text out of a system which is not installed, so i had to use pictures... -> if the system had worked, i would have been able to post the text.

You can do something like that

sudo pacman -S wgetpaste
inxi -Fxxxza --no-host | wgetpaste
# or
sudo pacman -S pastebinit
inxi -Fxxxza --no-host | pastebinit
# pastebinit maybe inactiv
if the internet connection is working. Post then the URL here.
1 Like

What are the details of your graphics card? Since a driver isn't being loaded inxi isn't telling us what the graphics card is.

Your motherboard is compatible with Ryzen APUs which have integrated graphics, but your 3600X does not have a built in GPU.

Posting a picture of what the boot looks like using the default boot might be useful as well.

The Gfxcard-Chip is a NVIDIA GeForce GTX 1660 SUPER - (ZOTAC Gaming GeForce GTX 1660, 6GB GDDR5, HDMI, 3x DP). When i boot the Manjaro live system without any settings (so free driver) then it looks like this:
withfreedriver
Can you tell me which output you exactly mean by saying: "what the boot looks like"
I mean, is there any command where i can get some log out of the boot actions or something like this?

According to the Specs on this site, my Motherboard has at least an HDMI Output: https://www.asus.com/de/Motherboards/PRIME-X570-P/specifications/
Iam even not quite sure if it also has an integraded graphics processor on the chipset!? Or are they talking about an integrated graphics processor on some type of ryzen CPUs?

Your picture is just what I was asking for.

What does mhwd -l give?

Yeah this is what the HDMI port is for.

Here is the output of

mhwd -l

https://pastebin.com/3mxtYRnN

So it's showing that none of the Nvidia drivers will work with your card, seems odd, but they could be too old to have support for the 1660 super.

I haven't used an Nvidia card in years, and my last one was over 5 years old when I replaced it and used the legacy driver so I never had to do anything with it.

I would imagine installing from the cli would get you a working system since it installs updated packages, but I'm sure someone with more Nvidia experience will be able to help more.

1 Like

Not sure what his issue is, but I can tell you Nvidia drivers support the 1660 super, according to this;
NVIDIA GeForce GTX 1660 SUPER Linux Gaming Performance

BTW, I am upgrading my system, and purchased a 1660 Super (on its way,) so it better work. :grimacing::laughing:

1 Like

Have you tried taking out your Nvidia 1660 super card and seeing if your computer recognizes your internal card and boots? I would start there and deal with one card at a time.

He's booting off the install iso, which seems to have too old of a driver for the 1660 super. Be sure to have the nvidia driver installed and your system updated before you put the new card in and you'll be good to go. He doesn't have an IGP on his ryzen 3600X.

2 Likes

Ok thx in advance for all your answers.
Is there any way to boot into the console, update the driver, then start the X-Server Session (maybe manually) and then last but not least install the system?
pacman -Syu says it has nothing to do, so how do i get a newer nvidia driver onto my live system. Has the arch-live system newer drivers included in their packages?

Another option...can you instead disable your 1660 super gpu in the bios? A lot of motherboards have this option. Then you can boot up using your internal gpu which most likely will set up as your default card, which then you can re-activate the 1660 gpu, and boot up to download the proper Nvidia drivers in Manjaro. That is my thinking anyway, easier and worth a try.

  1. Enter BIOS Setup.
  2. Go to Advanced Menu
  3. Go to Chipset Configuration Menu
  4. Go to Internal Graphics Menu
  5. Set the Internal Graphics Mode to Disable or choose PEG/PCI instead of Auto or IGFX. (IGFX means the onboard graphics).
  6. If you also have a Multi Monitors option set this to disable .

Not sure if you checked this out, but it'll be worth checking to see if you can get anything going.

https://wiki.manjaro.org/Configure_Graphics_Cards

I haven't done an arch install, so can't help with that. :confused:

Hopefully someone with some experience with a 1660 will chime in to what's going on, if the drivers are updated it should be able to load, but they aren't. Maybe doing a force reinstall from the wiki will get it to load.

What about trying the architect iso? Would that not get us around the no driver on the iso issue?
https://wiki.manjaro.org/index.php?title=Installation_with_Manjaro_Architect

Hey there,
architekt could be an option, i will try this later this week. Today i tried to install it with the
Manjaro 19.0 Pre1 iso hoping that there are newer display drivers integrated but it isnt working either.
I will update here if i find any other option or the architekt way works...
Thx till now!

Hi guys,
the newest driver for my nVidia card were not integrated on the live iso and so the only way to get this working would be to install it with architect (live iso always chose nouveau drivers which are currently not working with the 1660 Super). Now im working with archlinux and installed it from scratch.
Thx for help.
M.

it's not the most elegant way of handling it but it should work,

use the latest available iso you can find so your not wasting time updating a bunch of packages on a read-only live environment

Forum kindly sponsored by