[Fix] When recording with Screen Capture in OBS, screen flickers.


I had a problem with this for a while and I didn't find any fix for this problem on Manjaro forum, so I created this post to help people with this problem.
(Also I heard some people because of this problem changed distro to some other.)

Steps to fix the problem:

  1. Open nvidia-settings (NVIDIA X Server Settings)

    • You can open NVIDIA X Server Settings with typing "nvidia-settings" into the terminal and pressing Enter/Return key
      * You can open it with your Application Menu, search "NVIDIA" and it should show application "NVIDIA X Server Settings", click on it
  2. Find option with string "OpenGL Settings" and click it

  3. Uncheck/unclick/disable option "Allow Flipping"

Now when you open OBS and add into the current scene "Screen Capture" it won't flicker anymore with OpenGL rendering.


Forum kindly sponsored by