Flickering when opening windows in KDE

When opening not maximized windows the rest of the screen starts to flicker black in KDEScreenshot_20180712_151946.

I've tried recomendations to Change the compositor to OpenGl 3 and to change the vsync. Also I've tried changing the kernel to 4.17 but no progress. Please help.

Flickering cannot be seen in an image, I suppose..
Do you mean the green blur around the window?

Some system info might help.

inxi -SMGxxxz
neofetch --off

Hahaha yes, I know. It's the black sections in the screenshot.

System:    Host: black-nerd Kernel: 4.17.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.1 
           Desktop: KDE Plasma 5.13.2 tk: Qt 5.11.1 wm: KWin dm: sddm Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:   Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> Chassis: type: 9 
           serial: <filter> 
           Mobo: Dell model: 0101J9 v: A00 serial: <filter> UEFI [Legacy]: Dell v: 01.07.00 date: 04/07/2017 
Graphics:  Card-1: Intel HD Graphics 620 driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           Display: x11 server: X.Org 1.19.6 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.1.3 compat-v: 3.0 
           direct render: Yes 

Please study this tutorial for better using the forum

and repair your posted text output, please.

The second command?

OS: Manjaro Linux x86_64 
Host: Inspiron 15-3567 
Kernel: 4.17.4-1-MANJARO 
Uptime: 1 hour, 45 mins 
Packages: 1491 (pacman) 
Shell: bash 4.4.23 
Resolution: 1366x768 
WM: KWin 
WM Theme: oxygen 
Theme: Breeze Dark [KDE], Adwaita [GTK2], Breath [GTK3] 
Icons: breeze-dark [KDE], Adwaita [GTK2], maia [GTK3] 
Terminal: yakuake 
CPU: Intel i3-7100U (4) @ 2.400GHz 
GPU: Intel HD Graphics 620 
Memory: 1774MiB / 7765MiB

Try with another KWin theme, to see if it still has problem.
Any customization to your gpu modules at Xorg and/or modules-load?

cat /etc/X11/xog.conf.d/*.conf
cat /etc/modules-load.d/*.conf | grep intel
cat /etc/modprobe.d/*.conf | grep intel

No diference.

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "altgr-intl"

Nothing came back.

Thanks for your help btw.

For now I just reinstalled xg86-video-intel. I think it's working, but usually it starts flickering after some time, so i'll wait and let you know.

When I do a re-install I have the same. I always found that once things are installed, I do a reboot and the flickering stops by itself.

here a video of flickering only problem is when simple screen recorder is recording it just go black , doesn't flicker....

can this be fixed does anyone know?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by