fltk library out of date

fldigi fails on Manjaro linux. The root cause seems to be traced back to the fltk library in the community repository. Manjaro is currently pulling in fltk-1.3.5-2 from the upstream Arch repository. However, in Arch there is now fltk-1.3.5-3 available, which fixes the issue preventing fldigi from working.

How can we request for fltk-1.3.5-3 to be pulled into the Manjaro community repository? For myself, I know work around this, but for many Radio Amateurs using fldigi who are not comfortable with package management, it would be much easier for them if Manjaro was using flxt-1.3.5-3.

It is currently 1.3.5-3 in Testing and Unstable branches.
You will get it with next stable update.

And fldigi is an AUR package :wink:

2 Likes

I you want to be closer to arch - switch to testing or unstable - it's a piece of cake

sudo pacman -aS testing --continent && sudo pacman -Syyu

Enjoy


I have been running Manjaro on unstable branch for four years - no major issues ...

I have had major issues - but that was not Manjaro itself - it was Gnome DE - after switch to Openbox window manager - apart from the mandatory issues - python version 3.6 -> 3.7 -> 3.8 and icu lib - nothing - rock solid.

1 Like

Thanks guys, that is all very helpful information. I'll update the wiki on the fldigi website so the ham community knows the situation without coming here again :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by