Fn keys not working - Thinkpad E14

Hi all,

recently I bought a nice lenovo thinkpad E14 (with AMD). Installation of Manjaro MATE went pretty flawless and everything is running pretty smoothly.
However the fn keys are not working as expected:

working:

  • fn + space is controling keyboard backlight
  • fn + Esc is enabling FnLock, although the status LED is not enabled/disabled

not working

  • all fn keys from F1 to F12 have no effect

When trying to edit a shortcut (e.g. volume up) in MATE keyboard shortcuts it is immediately set to "Wake up" when pressing the fn key (it is handled as an usual button).

I would really appreciate when owners of an E14 (@ress) could let me know when they solved the issue or any other general help.

Thanks in advance!

Check in BIOS for a relevant setting (enable/disable). The name may not be clear, but you can read descriptions to get an idea.
On another Lenovo model, this setting toggles the behavior of Fn keys, from "multimedia" to "normal pc-style".

Hey @AgentS,

thanks for this hint. Unfortunately there is no such setting in the BIOS.

IMG_20200715_170858

You have this setting/toggle.
It's this:

F1-F12 as Primary Function

Unfortunately this setting only determines whether FnLock is activated by default or the the F-Keys are working as usual. The issue still persists.

Same laptop with Arch, I took e closer look, FN Key is recoglized as WakeUp and I did not find a way to use multimedia keys. Maybe we have to wait for new drivers....

I created a topic in the lenovo forum as well

https://forums.lenovo.com/t5/Other-Linux-Discussions/Linux-Fn-keys-not-working-Thinkpad-E14-AMD-Gen-2/m-p/5027791

Hello there, I have the exact same problem on my lenovo E15. The Fn-Key is seen as the wakeup-key and the multimedia-Fn-keys become not recognized in any way. The weird novelty in my case: after the installation of Manjaro things worked fine and after some configuration and installation of programs, the settings seem to have messed up. I would be very thankful for any help!

More Comments in the Lenovo thread would be great to motivate lenovo to fix it! Otherwise it wont work at all which would be highly annoying

In this thread i learned, that FN keys will work after waking up from suspend:


I tried it out an it works for me. Any Ideas on why that is? and how it could help?

1 Like

Only the logs can answer that, but it's a huge amount of them.
Maybe try greping a filtered
journal, comparing old and new logs.

I took a deeper look at everything I could think of but nothing stood out. journalctl did not show anything usefull... Any other ideas?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by