Force Manjaro Calamares to use arch-chroot

Gents,
is there a way to force Calamares to use arch-chroot instead of chroot?

appreciated.

arch-chroot isn't in the Manjaro repos, so no?


Moved from #general-discussion to #technical-issues-and-assistance:applications as this is a request for help with an application in the repos, not a discussion item.

1 Like

there is manjaro-chroot

1 Like

i need a way to make calamares to use arch-chroot, maybe edit bootloader main.py somewhere or edit libcalamares if possible or something else !!

Why? What are you trying to do? There may be an easier approach.

im trying to install manjaro on LVM using calamares, it goes fine until it reaches grub-install then whole inst fails. then i tried to resume installation manually, i used arch-chroot /tmp/calamares-root-XXX, and i grub-install went fine.

and you can probably do the same with mhwd-chroot or manjaro-chroot (both of which come with manjaro IIRC)

1 Like

Also consider using Manjaro-Architect either from your current ISO or M-A ISO.

1 Like

What @AgentS said wrote typed, M-A is the way to go.

2019-03-09

On your ISO open a terminal and sudo manjaro-architect, just be aware that on the 18.0.3 ISO there is a problem with LUKS installs, cryptsetup 2.1 defaults to LUKS2 which is not yet supported by GRUB.

3 Likes

thank you all..
i tried MA before, i suffered a lot with very slow internet and ended with a system i spent 4days fixing so many issues. and since im trying to get it done with calamares. it goes fine but fails every time at grup-install, seems root lv wasnt mounted or cant be detected. when it fails, mapper doesnt show vg until i run 'vgchange -ay'.
im just trying to trace calamares scripts if some edits can help.

thank you all guys @sueridgepipe @stephane @AgentS @dglt @jonathon

////////////////
019-03-07 - 10:29:42 [6]: Target cmd: ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=Manjaro", "--force")
2019-03-07 - 10:29:42 [6]: Target output:
Installing for x86_64-efi platform.
grub-install: error: cannot find a device for /boot/grub (is /dev mounted?).
2019-03-07 - 10:29:42 [6]: Python Error:
<class 'subprocess.CalledProcessError'>
Installing for x86_64-efi platform.
grub-install: error: cannot find a device for /boot/grub (is /dev mounted?).
File "/usr/lib/calamares/modules/bootloader/main.py", line 444, in run
prepare_bootloader(fw_type)

File "/usr/lib/calamares/modules/bootloader/main.py", line 411, in prepare_bootloader
install_grub(efi_directory, fw_type)

File "/usr/lib/calamares/modules/bootloader/main.py", line 285, in install_grub
"--force"])

File "", line 5, in

2019-03-07 - 10:29:42 [6]: Skipping non-emergency job "postcfg"
2019-03-07 - 10:29:42 [6]: Skipping non-emergency job "umount"

Then you should create an issue at Manjaro(gitlab)/Calamares(github) issues to provide and get proper feedback.
I am sure @philm would prefer that.

1 Like

if it fails at grub for whatever reason, skip installing grub with calamares and after install is finished chroot into the newly installed manjaro and do a manual grub-install that way?

manjaro-chroot -a
pacman-mirrors -f5 && pacman -Syyu
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
update-grub

OR
https://wiki.manjaro.org/index.php?title=Restore_the_GRUB_Bootloader#Restore_GRUB
OR
use architect to mount efi partition and install grub from architect.

does mkinitcpio -P need to be run first, before installing grub for the first time?

1 Like

i tried to skip grup-install, not defining /boot/efi mountpoint, but also installation fails with err 'os.rmdir("/tmp/calamares-root-_8mwg4pc") OSError: [Errno 90] Directory not empty:' i changed it to shutl.rmtree, msg finished successfully but nothing was written to root lv.

i guess do some reading about installing to LVM, ive never installed to lvm so im not sure of the process

1 Like

here how it went:

  • '#' lines related to grub-install in bootloader main.py
  • inst fails/exits at umount job with err directory not empty os.rmdir(root_mount_point)
  • mount /dev/mapper/jaroVG-root /mnt
  • cd /tmp/calamares-root-4o9hq36z/; tar cpf - . | (cd /mnt; tar xpf -)
  • mount /dev/sda1 /mnt/boot/efi
  • arch-chroot /mnt
  • edit /etc/fstab for empty UUIDs.
  • grup-install + grub-mkconfig

reboot and aeverything is fine (so far).

thank you all.

_________/////////////
└─sda5 8:5 0 23.9G 0 part
├─jaroVG-swap 254:0 0 3.9G 0 lvm [SWAP]
└─jaroVG-root 254:1 0 20G 0 lvm /
sr0 11:0 1 1024M 0 rom
~ >>> df .
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/jaroVG-root 20G 6.5G 13G 35% /
~ >>> uname -a
Linux jaroZ 4.19.27-1-MANJARO #1 SMP PREEMPT Wed Mar 6 22:51:51 UTC 2019 x86_64 GNU/Linux
~ >>>

2 Likes

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by