Former Sometime Ubuntu/Mint User Ready for Manjaro

I assume so? I had to convert the drive to GPT to install Windows 7 before I last installed I think early 2018 or late 2017...

The command
sudo parted -l

Will give you a bunch of information about your disks including that.

1 Like

Thanks for this. Didn't work for me. System booted directly into Windows after running the command successfully, so I am wondering a few things. For example, whether this UEFI system is some sort of a hybrid setup or if secure boot is actually enabled but invisible as mentioned by micsim35. Also, the Linux partition is one simple partition. Is this what should be expected with the "Replace a Partition" type of installation?

Thanks and I will look around for a suitable place to start a thread.

Yes, it should replace a partition with a single ext4 partition mounted as /

Can we see the output of sudo parted -l and inxi -Fxxxz to help you better?

yes it is

I am not sure if this will help, but I found this information that might address your issues. Some aspects might work for windows 7.

[wiki] Windows 10 - Manjaro - Dual-boot - Step by Step:

Sudo parted command failed. Says it's an invalid option. I am connecting through a wifi connection where I live, and I wonder if this could this have anything to do with this failure. Tried to connect using connection sharing via a wire tether with W7 (sharing enabled) but still no connection to the installer. Not going to be able to change this one unfortunately.

This is why I am wondering if the connection could be the cause. The contents of the inxi command output are below.

Thanks.

[manjaro@manjaro ~]$ inxi -Fxxxz 
System:    Host: manjaro Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4  
          tk: Qt 5.12.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux  
Machine:   Type: Desktop System: Hewlett-Packard product: HP Compaq 6200 Pro MT PC v: N/A serial: <filter> Chassis: type: 6  
          serial: <filter>  
          Mobo: Hewlett-Packard model: 1497 serial: <filter> UEFI: Hewlett-Packard v: J01 v02.28 date: 03/24/2015  
CPU:       Topology: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB  
          flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24757  
          Speed: 1597 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1597 2: 1597 3: 1597 4: 1597  
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] RV710 [Radeon HD 4550] vendor: Dell driver: radeon v: kernel  
          bus ID: 01:00.0 chip ID: 1002:9540  
          Display: x11 server: X.Org 1.20.3 driver: ati,radeon unloaded: modesetting alternate: fbdev,vesa  
          compositor: kwin_x11 resolution: 1680x1050~60Hz  
          OpenGL: renderer: AMD RV710 (DRM 2.50.0 / 4.19.13-1-MANJARO LLVM 7.0.0) v: 3.3 Mesa 18.3.1 compat-v: 3.0  
          direct render: Yes  
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel  
          v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20  
          Sound Server: ALSA v: k4.19.13-1-MANJARO  
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k port: f040  
          bus ID: 00:19.0 chip ID: 8086:1502  
          IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>  
Drives:    Local Storage: total: 1.07 TiB used: 116.1 MiB (0.0%)  
          ID-1: /dev/sda vendor: Western Digital model: WD5000AUDX-56WNHY0 size: 465.76 GiB speed: 6.0 Gb/s serial: <filter>  
          rev: 1A01 scheme: GPT  
          ID-2: /dev/sdb vendor: Western Digital model: WD1600AAJS-75M0A0 size: 149.01 GiB speed: 3.0 Gb/s serial: <filter>  
          rev: 3E01 scheme: MBR  
          ID-3: /dev/sdc type: USB vendor: Western Digital model: WD5000AAVS-00ZTB0 size: 465.76 GiB serial: <filter>  
          rev: 1006 scheme: MBR  
          ID-4: /dev/sdd type: USB vendor: Toshiba model: TransMemory size: 14.45 GiB serial: <filter> rev: 1.00 scheme: MBR  
Partition: ID-1: / size: 5.81 GiB used: 116.1 MiB (2.0%) fs: overlay source: ERR-102  
Sensors:   System Temperatures: cpu: 36.0 C mobo: N/A gpu: radeon temp: 54 C  
          Fan Speeds (RPM): N/A  
Info:      Processes: 181 Uptime: 2h 30m Memory: 7.75 GiB used: 776.9 MiB (9.8%) Init: systemd v: 239 Compilers: gcc: 8.2.1  
          Shell: bash v: 4.4.23 running in: konsole inxi: 3.0.28  
[manjaro@manjaro ~]$  

Thankyou very much. I have put in a good 8 hours of research to get where I am. Mostly I don't understand why I am not able to create partitions myself on this system and then continue with the installation. Next option is grayed.

Thankyou. May try this, but I'm not sure. I would like to have some kind of verification from someplace that I need to do this first.

1 Like

Notice in KDE Partition Manager that there isn't a mount point showing. I assume this is normal enough, but I don't see anything indicating that the drive is a root drive and I don't see an option to flag it as such.

That is a lower case 'L'. Any chance you did parted -1 by mistake?

OK, you have a bunch of disks in that machine. Without more information, my best guess is you have more than efi partition and manjaro is placed in the wrong one. Just a guess though.

I would love to see sudo parted -l as well as know where both Windows and Manjaro are installed.

No need to worry about secure boot, you would not be able to boot the live iso if it was secure boot blocking you. The internet connection should also be irrelevant since you are using calamares.

The likely causes for the problem seem to be:

  1. maybe you booted accidentally in legacy mode and Manjaro was not installed in uefi mode
  2. installer was unable to modify the boot order
  3. grub installation failed for some reason.

Whichever it is, it is solvable, and the command suggested by @dalto helps us narrow the cause down.

Lol. There is only one internal backup disk. The rest are USB storage. One is a 500 MB dual RAID drive for backups and I think the 2 TB is there, along with the Toshiba flash drive. Been moving them around while I switch PCs.

Never been into partitioning, and this is my first dual boot. I don't think I have ever created a partition that I ended up using. Created a couple to learn and relearn the process over the years.

sudo parted output below:

[manjaro@manjaro ~]$ sudo parted -l 
Model: ATA WDC WD5000AUDX-5 (scsi) 
Disk /dev/sda: 500GB 
Sector size (logical/physical): 512B/4096B 
Partition Table: gpt 
Disk Flags:  

Number  Start   End    Size   File system  Name  Flags 
1      1049kB  106MB  105MB  fat32              boot, esp 
2      106MB   240MB  134MB                     msftres 
3      240MB   295GB  295GB  ntfs               msftdata 
4      295GB   500GB  205GB  ext4 


Model: ATA WDC WD1600AAJS-7 (scsi) 
Disk /dev/sdb: 160GB 
Sector size (logical/physical): 512B/512B 
Partition Table: msdos 
Disk Flags:  

Number  Start   End    Size   Type      File system  Flags 
1      8225kB  160GB  160GB  extended               lba 
5      8258kB  160GB  160GB  logical   ntfs 


Model: WD My Book (scsi) 
Disk /dev/sdc: 500GB 
Sector size (logical/physical): 512B/512B 
Partition Table: msdos 
Disk Flags:  

Number  Start   End    Size   Type     File system  Flags 
1      32.3kB  500GB  500GB  primary  ntfs 


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0 
has been opened read-only. 
Error: Can't have a partition outside the disk! 
Ignore/Cancel?    


1 Like

Please post output text enclosed in code tags, not images.

```
Text Output
```
2 Likes

Please copy and paste the terminal output here between three ` or use </>
No pictures please.

1 Like

Should I repost the outputs? Thankyou for the information.

Just edit your original posts with the actual text would be best.

grafik

OK. Will do that now. Rerunning the commands.

Turned out to be the problem. I was booting into legacy mode via F10 access to the boot menu. Deleted the partion, booted the DVD from the UEFI DVD option, and went back into the installer. This time I was able to add the partitions as desired and was able then to continue with the installation. The previously greyed next button was now available to click.

Also, no problem getting into Windows via the GRUB boot loader.

Thankyou very much for everyone's assistance with this. I am looking forward to working in Manjaro. Very surprised to see where LibreOffice has come. Didn't expect this much from the program, I guess because I have been using a portable version for quite some time.

Just one question before I go. I mentioned I access the internet via wi-fi. I use a Netgear wireless adapter. Is there a repository for drivers where I can search to find this driver?

Next question will be in a new thread, I promise:blush:

1 Like

depends on the adapter and what chip set it uses. do you know the exact model # ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by