Freezes and glitching

I'm a first time Linux user. Literally just decided to install Manjaro on a spare laptop today to try it out. Windows is all I've ever known so this is all very new and foreign to me.
I'm having an issue where everything will freeze for a few seconds and then the whole thing will start glitching out and/or flickering. The mouse still moves but it can't interact with anything.

I'm guessing this is probably a driver issue of some description, but I'm not quite sure how to go about fixing it.


Hello and welcome to Manjaro!

Could you please provide more information on your hardware and software with

inxi --full --verbosity=7 --filter --no-host

and information on the current boot with

sudo journalctl -b

If you have problems gathering the output because of the glitches you can put the output in a file first like so

sudo journalctl -b > myjournalformanjaro

If it is not doable in the graphical environment you can switch to another TTY (console/terminal) with
ctrl+alt+F2 , then log in and execute the command to make the file.

Please read this post on how to format the output for better readability. (These symbols ``` at the beginning and the end of each output) The output of journalctl may be to long to post so please use a pastebin for that. One example of a pastebin is

  Kernel: 5.6.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Portable System: Dell product: Inspiron 11-3168 v: 2.0.3 
  serial: <filter> Chassis: type: 8 serial: <filter> 
  Mobo: Dell model: 0CPK6D v: A00 serial: <filter> UEFI: Dell v: 2.0.3 
  date: 04/05/2017 
  ID-1: BAT0 charge: 13.9 Wh condition: 29.1/32.0 Wh (91%) volts: 7.5/7.6 
  model: Samsung SD DELL PGYK577 type: Unknown serial: <filter> 
  status: Discharging 
  RAM: total: 3.75 GiB used: 580.7 MiB (15.1%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Topology: Dual Core model: Intel Celeron N3060 bits: 64 type: MCP 
  arch: Airmont rev: 4 L2 cache: 1024 KiB bogomips: 6402 
  Speed: 480 MHz min/max: 480/2480 MHz Core speeds (MHz): 1: 480 2: 480 
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_perfmon bts 
  clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb 
  ept erms est flexpriority fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce 
  md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe 
  pclmulqdq pdcm pebs pge pni popcnt pse pse36 pti rdrand rdtscp rep_good 
  sep smep ss sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
  tsc tsc_adjust tsc_deadline_timer tsc_known_freq tsc_reliable vme vmx vnmi 
  vpid xtopology xtpr 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b1 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (BSW) v: 4.6 Mesa 20.0.6 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:2284 
  Sound Server: ALSA v: k5.6.11-1-MANJARO 
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 
  bus ID: 01:00.0 chip ID: 8086:3165 
  IF: wlp1s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Local Storage: total: 29.12 GiB used: 11.24 GiB (38.6%) 
  ID-1: /dev/mmcblk0 model: HBG4a2 size: 29.12 GiB serial: <filter> rev: 0x8 
  scheme: GPT 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / size: 25.41 GiB used: 11.24 GiB (44.2%) fs: ext4 
  dev: /dev/mmcblk0p2 label: N/A uuid: 65667897-948f-497c-b9e2-a2afe78f1348 
  ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat 
  dev: /dev/mmcblk0p1 label: N/A uuid: 362B-99B5 
  ID-3: /var/lib/snapd/snap/core18/1754 raw size: 54.9 MiB 
  size: <root required> used: <root required> fs: squashfs dev: /dev/loop4 
  label: N/A uuid: N/A 
  ID-4: /var/lib/snapd/snap/gnome-3-28-1804/116 raw size: 160.2 MiB 
  size: <root required> used: <root required> fs: squashfs dev: /dev/loop0 
  label: N/A uuid: N/A 
  ID-5: /var/lib/snapd/snap/gtk-common-themes/1506 raw size: 62.1 MiB 
  size: <root required> used: <root required> fs: squashfs dev: /dev/loop1 
  label: N/A uuid: N/A 
  ID-6: /var/lib/snapd/snap/p3x-onenote/71 raw size: 67.4 MiB 
  size: <root required> used: <root required> fs: squashfs dev: /dev/loop2 
  label: N/A uuid: N/A 
  ID-7: /var/lib/snapd/snap/snapd/7264 raw size: 27.1 MiB 
  size: <root required> used: <root required> fs: squashfs dev: /dev/loop3 
  label: N/A uuid: N/A 
  ID-8: swap-1 size: 2.88 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/mmcblk0p3 label: N/A uuid: 8f5852a4-f1f0-45c8-bce1-ca6344dd1f08 
  Message: No unmounted partitions found. 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 7 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 1-2:2 info: Alcor Micro USB Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 058f:6254 
  Device-1: 1-2.3:4 info: N/A type: HID driver: hid-multitouch,usbhid 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 2386:0403 
  Device-2: 1-2.4:6 info: STMicro Sensor Hub type: HID 
  driver: hid-sensor-hub,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 0483:91d1 serial: <filter> 
  Device-3: 1-3:3 info: Intel type: Bluetooth driver: btusb interfaces: 2 
  rev: 2.0 speed: 12 Mb/s chip ID: 8087:0a2a 
  Device-4: 1-5:5 info: Realtek Integrated Webcam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 0bda:568a 
  serial: <filter> 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 46.0 C mobo: 40.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 174 Uptime: 1m Init: systemd v: 245 Compilers: gcc: 9.3.0 
  Shell: bash v: 5.0.16 running in: xfce4-terminal inxi: 3.0.37

Thank you for formatting the output properly!

I can see that you logged in right after the boot up, but I'm not sure whether you did so in the graphical environment. Did you experience these glitches before copying the journal output? Could you use XFCE for a while before copying the journal? Open some programs till you have seen a few glitches happen.
Then please paste the journal output in the pastebin again, as well as the output of

cat /var/log/Xorg.0.log



Sorry for taking so long to reply, I've been busy this week. :sweat_smile:
This time I logged into the graphical environment and messed around in a few applications while waiting for the glitches to occur. Once they did, I went into terminal.

Your GPU hangs, without known reason, yet...

May 18 16:50:17 marg-inspiron113168 kernel: Asynchronous wait on fence 0000:00:02.0:Xorg[887]:1110c timed out (hint:intel_atomic_commit_ready+0x0/0x50 [i915])
May 18 16:50:22 marg-inspiron113168 kernel: i915 0000:00:02.0: GPU HANG: ecode 8:1:85dffffb, in Xorg [887]
May 18 16:50:22 marg-inspiron113168 kernel: GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
May 18 16:50:22 marg-inspiron113168 kernel: Please file a _new_ bug report at
May 18 16:50:22 marg-inspiron113168 kernel: Please see for details.
May 18 16:50:22 marg-inspiron113168 kernel: drm/i915 developers can then reassign to the right component if it's not a kernel issue.
May 18 16:50:22 marg-inspiron113168 kernel: The GPU crash dump is required to analyze GPU hangs, so please always attach it.
May 18 16:50:22 marg-inspiron113168 kernel: GPU crash dump saved to /sys/class/drm/card0/error
May 18 16:50:23 marg-inspiron113168 kernel: i915 0000:00:02.0: Resetting rcs0 for stopped heartbeat on rcs0
May 18 16:50:23 marg-inspiron113168 kernel: i915 0000:00:02.0: Xorg[887] context reset due to GPU hang

The output of

cat /sys/class/drm/card0/error

after a crash might reveal the problem. You could also try a LTS kernel release, like 4.19, so older than the regression.

This seems to be a problem since kernel 5.3. Here is a big thread on this issue, which is not resolved , yet.

Could you please provide the output of

modinfo -p i915


systool -m i915 -av

An easy fix 'might' be to install the older LTS kernel419, before the regression happened.

Another possible fix is outlined in this post on the Arch Forum.

Which states a solution by putting this into /etc/modprobe.d/i915.conf

options i915 enable_psr=1
options i915 enable_guc=2
options i915 nuclear_pageflip=Y
options i915 enable_dc=2
modeset:Use kernel modesetting [KMS] (0=disable, 1=on, -1=force vga console preference [default]) (int)
enable_dc:Enable power-saving display C-states. (-1=auto [default]; 0=disable; 1=up to DC5; 2=up to DC6; 3=up to DC5 with DC3CO; 4=up to DC6 with DC3CO) (int)
enable_fbc:Enable frame buffer compression for power savings (default: -1 (use per-chip default)) (int)
lvds_channel_mode:Specify LVDS channel mode (0=probe BIOS [default], 1=single-channel, 2=dual-channel) (int)
panel_use_ssc:Use Spread Spectrum Clock with panels [LVDS/eDP] (default: auto from VBT) (int)
vbt_sdvo_panel_type:Override/Ignore selection of SDVO panel mode in the VBT (-2=ignore, -1=auto [default], index in VBT BIOS table) (int)
reset:Attempt GPU resets (0=disabled, 1=full gpu reset, 2=engine reset [default]) (int)
vbt_firmware:Load VBT from specified file under /lib/firmware (charp)
error_capture:Record the GPU state following a hang. This information in /sys/class/drm/card<N>/error is vital for triaging and debugging hangs. (bool)
enable_hangcheck:Periodically check GPU activity for detecting hangs. WARNING: Disabling this can cause system wide hangs. (default: true) (bool)
enable_psr:Enable PSR (0=disabled, 1=enabled) Default: -1 (use per-chip default) (int)
force_probe:Force probe the driver for specified devices. See CONFIG_DRM_I915_FORCE_PROBE for details. (charp)
alpha_support:Deprecated. See i915.force_probe. (bool)
disable_power_well:Disable display power wells when possible (-1=auto [default], 0=power wells always on, 1=power wells disabled when possible) (int)
enable_ips:Enable IPS (default: true) (int)
fastboot:Try to skip unnecessary mode sets at boot time (0=disabled, 1=enabled) Default: -1 (use per-chip default) (int)
prefault_disable:Disable page prefaulting for pread/pwrite/reloc (default:false). For developers only. (bool)
load_detect_test:Force-enable the VGA load detect code for testing (default:false). For developers only. (bool)
force_reset_modeset_test:Force a modeset during gpu reset for testing (default:false). For developers only. (bool)
invert_brightness:Invert backlight brightness (-1 force normal, 0 machine defaults, 1 force inversion), please report PCI device ID, subsystem vendor and subsystem device ID to, if your machine needs it. It will then be included in an upcoming module version. (int)
disable_display:Disable display (default: false) (bool)
mmio_debug:Enable the MMIO debug code for the first N failures (default: off). This may negatively affect performance. (int)
verbose_state_checks:Enable verbose logs (ie. WARN_ON()) in case of unexpected hw state conditions. (bool)
nuclear_pageflip:Force enable atomic functionality on platforms that don't have full support yet. (bool)
edp_vswing:Ignore/Override vswing pre-emph table selection from VBT (0=use value from vbt [default], 1=low power swing(200mV),2=default swing(400mV)) (int)
enable_guc:Enable GuC load for GuC submission and/or HuC load. Required functionality can be selected using bitmask values. (-1=auto, 0=disable [default], 1=GuC submission, 2=HuC load) (int)
guc_log_level:GuC firmware logging level. Requires GuC to be loaded. (-1=auto [default], 0=disable, 1..4=enable with verbosity min..max) (int)
guc_firmware_path:GuC firmware path to use instead of the default one (charp)
huc_firmware_path:HuC firmware path to use instead of the default one (charp)
dmc_firmware_path:DMC firmware path to use instead of the default one (charp)
enable_dp_mst:Enable multi-stream transport (MST) for new DisplayPort sinks. (default: true) (bool)
enable_dpcd_backlight:Enable support for DPCD backlight control(-1=use per-VBT LFP backlight type setting, 0=disabled [default], 1=enabled) (int)
enable_gvt:Enable support for Intel GVT-g graphics virtualization host support(default:false) (bool)
Module = "i915"

    coresize            = "2502656"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "6"
    srcversion          = "421488BB2A0C77E0FBB51A9"
    taint               = ""
    uevent              = <store method only>



Did you try one of the fixes?

I tried the i915.conf fix and that seems to have worked. Thanks for your help. :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by