Freezes and htop shows cores being used up by kernel threads

Dear Manjaro community

I am at a loss...I need your help as I am too new to this.

Summary:
About a week ago I changed from Windows 10 to Manjaro 20.0.3 (Xfce).
Everything worked fine. I had no troubles. No freezes, no crashes, it worked really good.
Until yesterday evening...when I started up this morning I got freezes all over the place.
It seems that some kernel thread is hogging the CPU making the freezes, but I can't remember changing my kernel (even tho I happen to be on 5.6.16 now instead of 5.6.15 all of a sudden).
How can I change that back to check it?

More Explanation:
Until yesterday evening everything ran smoothly and fast (for about a week now). All applications were rather quick to start and use.
Today I booted up and had freezes (of about 3-5 seconds) whenever I started an application, when I clicked the "menue" button of Xfce, when I opened something up, switching applications, etc.
The whole screen froze it seems, funny enough youtube kept the sound playing, only the video seemed to freeze and continued (at the time where those 5 second passed).
I have no changed anything on the hardware (no new or changed hardware, no firmware updates, etc.). I even didn't install new software or updated software yesterday (at least not that I know of!).

Hardware/OS info:
AMD Ryzen 9 3900X on a Asrock Taichi X570 and a Sapphire 5700XT Nitro+
32 GByte DDR4-RAM
No overclocking on GPU, CPU or RAMq
Two NVMe SSDs M.2
One SSD on SATA
Manjaro is on the "primary" NVMe M.2 (1 Tbyte)
Manjaro 20.0.3 Xfce installing medium used, updated the last time two or three days ago (not yesterday, that I know) and I am using kernel: 5.6.16-1-MANJARO #1 SMP PREEMPT Wed Jun 3 14:26:28 UTC 2020 x86_64 GNU/Linux
HOWEVER: as far as I can remember, I was on 5.6.15 (and not on 5.6.16), but I CANNOT remember installing a new kernel

Diagnostics so far:
I tried to use iotop, htop, nvtop and some more, but the freezing didnt allow me to see what happens when it happend (it was normal after such a freeze).
So I tried to ssh into my box from my laptop, hoping I can cause the freeze using my keyboard and mouse while checking all the monitoring tools from ssh...that worked.

  • sensors gave me less than 55 degree celcius on all the sensors I had (CPU, GPU and nvme), so I doubt its an overheating issue

  • When a freeze happens one CPU core spikes to 100% during a freeze (htop red colour - meaning kernel thread) - and it seems its always the process of Xorg that goes berskers with >99%

  • (The exact process is /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 novtswitch)

  • RAM was used to about 3 GByte (a tenth). No spikes there, no swap use

  • iotop was OK as well (no spikes), the processes that showed up with -Pao where all >0.20%, so I gather its not a I/O issue)

Anyone an idea what else I can check or know of such symptoms?
Why did it start out of the blue?
What would be the tool to use to get back to 5.6.15 to check out if there is a regression (sorry, I am new to manjaro)

EDIT 1:
I just checked the manjaro settings manager (and the CLI command) and there is no option to "downgrade" as far as I can see.
Indeed there was 5.6.15 first which was updated some days ago in the repos to 5.6.16. I am not aware if and when this is updated automatically...considering the kernel thread CPU spikes I'd like to get back to 5.6.15 to test out if there is a regression.
However, for the life of me, I cant find a tutorial on google search or forum search concerning "downgrades" of current stable kernels (my google/search fu is bad today, sorry)

Cheers

You would need to downgrade the relevant packages from your package cache at /var/cache/pacman/pkg. However, if you are using any Manjaro extramodules make sure you downgrade them all together.

You can install those packages with:

sudo pacman -U /path/to/package1 /path/to/package2

It would be a lot easier to try kernel 5.7 or 5.4

2 Likes

You can install and run the LTS and recommended kernel 5.4.* and see if that works for you

1 Like

Since you're running a 5700XT and Ryzen like me, I highly suggest to stick the a newer kernel. Kernel 5.7 has a lot more commits for Navi and Ryzen. My computer is a lot more stable on 5.7 than 5.6.

Kernel 5.8 will be a huge update that has even more commits for Navi and Ryzen.

1 Like

Thank you to dalto, realmain and Robin0800

I understand that downgrading from 5.6.16 to 5.6.15 seems to more difficult than actually installing and trying 5.7 or 5.4 altogether.
As far as I understand the concept, I can have all three kernels (5.7, 5.6 and 5.4) and should be able to choose them when booting the system (need to find out how, but I am sure its possible with grub), am I right?
Thanks a lot

1 Like

You are right. You can have multiple kernels installed, and when you boot your system you can choose which one to run. Hold the Esc key to show the grub menu (on UEFI systems, or Shift key on BIOS systems, I think).

Hello all

The joy was short lived...
I installed 5.7.0 last evening (about half an hour after it was suggested in this thread) and after rebooting it used this kernel automatically and I had no problems what'o'ever. I was overjoyed.

Guess what...started up just now to be greeted with freezes again.
I have really no idea why on earth they just came out of nowhere. Well, I try to figure out some more, but if that does not work out...I guess this might be it.

Funny enough, I had the same issues about half a year ago (same hardware, same computer) with Manjaro (19.x.x), however, the freezes where there at the beginning. This is why I switched back to Windows to wait for kernel 5.6.x.

Hi,
I have been running manjaro on this machine Processor System Model ZenBook UX462DA
AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx, 2100 Mhz, 4 Core(s), 8 Logical Processor(s)
without any problems at all. Yesterday and two days ago I logged in, started working and everything froze after about five minutes. No error message at all. Keyboard frozen (no possibility to switch to console!!), Touchpad and screen frozen. Cannot go back to print logs and must now work from Windows to write this. I have tried kernel 5.6-5.8 and normally run on 5.7. WILL ATTEMPT to go back to manjaro, get logs, reinstall and restore (a waste of time!!) Linux will never be stable enough as a workhorse:one developer upgrade in one library and the wholesystem goes crashing down! I am experienced linux,macOS and windows user but I have never seen any freeze like this before. The first that happens is pointer jumps,slows down,windows freeze (cannot be moved or closed), then complete stop of pointer and no response to keyboard so no console available to rescue the system.
MANJARO ARCH SOMETHING BIG HAS GONE WRONG SINCE LAST UPDATE...

Forum kindly sponsored by