Fresh Manjaro install - french accented é key doesn't work !

Hello everyone,

I have just installed a fresh Manjaro linux on my HP laptop, after a little distro-hopping break. This laptop has already run Manjaro fine for months in the past. Everything is rolling - as expected - but there is one fairly annoying bug with my keyboard:

I am using a French layout and I need the accented acute "e" letter, but it doesn't "do" anything whenever I press the key (nothing is typed in the document). The same capital key works (I can type a "2" using shift). All the other keys/letters work fine.

I have switched keyboard layouts, tried other languages... I have plugged in a USB keyboard... In any case, the said key just doesn't work whatever the configuration.
I have googled for a while and I couldn't find a similar case - at least one that was solved.
Here is the ouput of xev when I type "é" (I actually had to copy this from a website):

FocusOut event, serial 40, synthetic NO, window 0x7e00001,
    mode NotifyGrab, detail NotifyAncestor

FocusOut event, serial 40, synthetic NO, window 0x7e00001,
    mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 40, synthetic NO, window 0x7e00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 40, synthetic NO, window 0x0,
    keys:  0   8   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

KeyRelease event, serial 40, synthetic NO, window 0x7e00001,
    root 0x1e0, subw 0x0, time 9787102, (134,57), root:(2058,110),
    state 0x10, keycode 11 (keysym 0xe9, eacute), same_screen YES,
    XLookupString gives 2 bytes: (c3 a9) "é"
    XFilterEvent returns: False

For comparison, I get this when I type "&", located right next to it:

KeyPress event, serial 40, synthetic NO, window 0x7e00001,
    root 0x1e0, subw 0x0, time 9784238, (134,57), root:(2058,110),
    state 0x10, keycode 10 (keysym 0x26, ampersand), same_screen YES,
    XLookupString gives 1 bytes: (26) "&"
    XmbLookupString gives 1 bytes: (26) "&"
    XFilterEvent returns: False

KeyRelease event, serial 40, synthetic NO, window 0x7e00001,
    root 0x1e0, subw 0x0, time 9784334, (134,57), root:(2058,110),
    state 0x10, keycode 10 (keysym 0x26, ampersand), same_screen YES,
    XLookupString gives 1 bytes: (26) "&"
    XFilterEvent returns: False

What I understand is that there is just no KeyPress event triggered. Instead, I get this weird KeymapNotify event. But I don't understand much more than that.

I am runnng Manjaro stable with Plasma 5.18.4 / Xorg 1.20.8 / Kernel 5.6.8-1 (and I also tried 5.6.4_rt3 ... and I have no idea what to do next.


Edit:

I had the same problem in the console. I tried sudo localectl set-keymap --no-convert fr-pc and now I can type accented "é" in the console. However, this still doesn't work in Plasma.

I followed instructions from here, and did sudo xinit /usr/bin/xterm -- :1 from the console. I could type the "é" in the X window that launched. But going back to Plasma... no change.

The Arch wiki hints that:

If you press a key and nothing appears in the terminal, it means that either the key does not have a scancode , the scancode is not mapped to a keycode , or some other process is capturing the keypress.

I'm still stuck.

Did you test the keyboard in the installer before?
Which desktop environment did you installed?
In my case (manjaro i3), I run setxkbmap -model pc105 -layout fr as a startup command and I have all weird french accents needed :wink:

2 Likes

The keyboard works fine in the Windows partition. I did NOT precisely check the "é" during the installation of Manjaro. I did type a few keys wich worked fine.
I'm using Plasma, as I said earlier.
Can I just wipe out my .xinitrc to see what happens or is this considered a kamikaze move?

I am not the most knowledged about linux in this forum...
I would first boot the live session from the installer and see if that works, and make sure that you have the layout that match your keyboard. This is a convenient GUI to test for the keyboard.
Then about wiping .xinitrc, I can't tell you for sure. It is not a system file so shouldn't be too dangerous but does not cost a lot to do a backup at least.
You can also setup timeshift so you can revert many of the bad moves you might think about.

What does this:
2020-05-04_21-27
and this:
2020-05-04_21-28
state in your specific environment?

And can you post the Brand / model of keyboard you actually have, please?

:innocent:

P.S. Do you mind becoming :belgium: instead of :fr: because there is very little difference between these keyboards... :smiling_imp:

Gosh.

Being :belgium: actually solves my problem for the "é" ! However, it messes up other keys. I am using the laptop's keyboard (HP Pavilion 15-ck000nf). The USB keyboard I plug in is a DELL SK-8115...

To reply to your PS: I grew up in Lens (62) and went to Belgium so many times, had a lot of friends there, whom I appreciated very much and loved their open-mindedness. My brother-in-law is from Belgium... I love the mentality. I wouldn't mind so much changing my flag, but even though the fries are excellent, we just make better food on the whole, so...

  1. Good one! :belgium: food is the best food in the world, because it's :fr: food in :de: quantities! :rofl:
  2. Changing to BE keyboard messes indeed with other keys, but at least we know é is working!
    Can you post screenshots of the above using FR?
    (or does switching from :fr::belgium::fr: solve the problem?)

Même si tous les écrans sont en :fr: :pô de blème... :grin:

Switching layouts doesn't solve the problem when I switch back to the French default layout.

Here are the shots:
Screenshot_20200504_232153

I'm only allowed one pic/message, so here is the second screenshot:

Screenshot_20200504_232249

Second screenshot: Don't change anything, but this one:

Screenshot_20200504_232153

Keep the green at all costs, but try all combinations of red and orange...

Log off and on when changing the red one, stay logged on when changing the orange ones...

:first_quarter_moon_with_face: :zzz: :bed:

I can change the Keyboard Model, but when I logout and back in, it is back to 102 keys (Intl.)

Oddly enough, the keystroke works in the SDDM login screen and in the Plasma Lock Screen (when I type it in the password field, it actually ouputs an "é"). :thinking:

I switched to Wayland and I don't get this problem. The culprit seems to be related to Xorg.

1 Like

So Wayland is the solution?

:confused:

Did you read this page?

1 Like

I think I have found the reason why it didn't work, although I wasn't able to track it down to the precise culprit.

After installing Manjaro, I copied quite a few dotfiles and config files from a backup of my previous Fedora install. Although I tried to pay attention to what I copied over, I might have overlooked some file that ended up breaking my keyboard config.

I solved this by starting from scratch and reinstalling Manjaro (which was not too much of a problem since this was a new install anyway), then copied my dotfiles again, this time double-checking everything carefully and it works: "génial"!

So in the end, I have not really managed to track down the culprit file, but I can now type in French. Cocorico.

1 Like

I think that counts as a solution, so I've marked it as such...
The smart easy way would have been to create a new user instead of a full reinstall... Next time! :grin:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by