Freshly installed Manjaro GRUB minimal bash at boot

Hi everybody,
I'm new to manjaro and I tried to install Manjaro 17.1 64bit on my laptop a lenovo ideapad 700.
The live USB works perfectly and I have also used it before on my desktop pc to install manjaro with no problems. In my laptop I want to have dualboot with windows, so I selected the sda8 as ext4 partition to be formatted.
The installation process runs flawlessly and tells me to reboot the system.
The problem arises when the pc restarts, when the grub is there but in minimal bash mode.
Since the laptop has EFI, even before when I had ubuntu and mint installed I had to update the grub from live usb so I tried the guide on the wiki for the EFI version: but to no avail
I installed manjaro on sda8, while the uefi on sda1, the sda3 is the windows partition, I even tried to reinstall it on sda8 but that was useless, since the problem persists.

The partition table is the following

[manjaro@manjaro ~]$ lsblk -f
loop0 squashfs /run/miso/sfs/livefs
loop1 squashfs /run/miso/sfs/mhwdfs
loop2 squashfs /run/miso/sfs/desktopfs
loop3 squashfs /run/miso/sfs/rootfs
├─sda1 vfat SYSTEM_DRV 2C67-4A74
├─sda3 ntfs Windows EA2069F62069CA61
├─sda4 ntfs LENOVO 907CD7EB7CD7C9DC
├─sda5 ntfs WINRE_DRV 986C76066C75E004
├─sda6 ntfs LENOVO_PART 58BE7844BE781CA6
├─sda7 vfat LRS_ESP 0479-E913
├─sda8 ext4 92aaf4b4-6eb5-471d-a2c2-1ee8f7c40e34
└─sda9 swap 92eedf2c-6dcd-49fd-a590-941594242c17
sdb iso9660 MJRO1717 2018-03-27-19-11-24-00
├─sdb1 iso9660 MJRO1717 2018-03-27-19-11-24-00 /run/miso/bootmnt
└─sdb2 vfat MISO_EFI 5C2A-FAE6

Does anyone know a fix to this problem?

Boot up your installed Manjaro using this.
When booted up at terminal,

  1. efibootmgr
    Is manjaro listed at all?

  2. a. If no, do
    sudo grub-install
    b. If yes, make majaro at top of bootorder by
    sudo efibootmgr -o xxxx,yyyy,zzzz....
    where xxxx is manjaro bootentry

  3. Check again
    If 'manjaro' is there and at top of bootorder
    Reboot and let us know if it reboots.

  4. If you still have problems, boot up again to manjaro (same method) and let us know output (with your input command)
    sudo parted -l
    sudo blkid
    findmnt -s
    efibootmgr -v

Thanks for the reply, I managed to enter the system by using the link's instructions.
Following the steps for the UEFI I get the following:

[gf@raikiri ~]$ sudo grub-install
Installing for x86_64-efi platform.
Installation finished. No error reported.
[gf@raikiri ~]$ sudo update-grub
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin
[gf@raikiri ~]$ sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
[gf@raikiri ~]$ efibootmgr
BootCurrent: 0018
Timeout: 2 seconds
BootOrder: 0018,0001,0014,0016,0000,0015,0017,0019,001A,001B
Boot0000* Windows Boot Manager
Boot0001* ubuntu
Boot0010 Setup
Boot0011 Boot Menu
Boot0012 Diagnostic Splash
Boot0013 OilDiagApp
Boot0014* USB FDD:
Boot0015* ATA HDD:
Boot0017* ATAPI CD:
Boot0018* USB HDD:
Boot0019* USB CD:
Boot001A* PCI LAN: EFI Network (IPv4)
Boot001B* PCI LAN: EFI Network (IPv6)

In the list there's no manjaro only ubuntu, so I tried to run again the command 'sudo grub-install', but still the manjaro entry doesn't show up. If it's only a matter of labelling linux, should I put ubuntu as first?

For completeness, the other commands of point 4 show the following:

[gf@raikiri ~]$ sudo parted -l
Model: ATA WDC WD10SPCX-24H (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 274MB 273MB fat32 EFI system partition boot, esp
2 274MB 290MB 16,8MB Microsoft reserved partition msftres
3 290MB 649GB 649GB ntfs Basic data partition msftdata
8 649GB 941GB 292GB ext4
9 941GB 950GB 8374MB linux-swap(v1)
4 950GB 976GB 26,8GB ntfs Basic data partition msftdata
5 976GB 977GB 1049MB ntfs Basic data partition hidden, diag
6 977GB 999GB 21,7GB ntfs Basic data partition diag
7 999GB 1000GB 1049MB fat32 Basic data partition hidden

Model: UFD USB Flash Drive (scsi)
Disk /dev/sdb: 32,1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32,8kB 2049MB 2049MB primary boot
2 2049MB 2054MB 4194kB primary esp

[gf@raikiri ~]$ sudo blkid
/dev/sda1: LABEL="SYSTEM_DRV" UUID="2C67-4A74" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="38138a56-0d5d-419c-86a1-a13070e583ef"
/dev/sda3: LABEL="Windows" UUID="EA2069F62069CA61" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="65e25026-1756-44eb-8b46-6ce2b4ea358f"
/dev/sda4: LABEL="LENOVO" UUID="907CD7EB7CD7C9DC" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="80d59941-2404-49ae-87ce-b1116ab58a7d"
/dev/sda5: LABEL="WINRE_DRV" UUID="986C76066C75E004" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a50c3b3c-6efb-473c-978e-b80f0ffb4cef"
/dev/sda6: LABEL="LENOVO_PART" UUID="58BE7844BE781CA6" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="7d46764d-e6b6-44d8-b6c2-3c1e959fb538"
/dev/sda7: LABEL="LRS_ESP" UUID="0479-E913" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="ded567ac-6ad6-4e92-8e1a-e4434dfa1768"
/dev/sda8: UUID="92aaf4b4-6eb5-471d-a2c2-1ee8f7c40e34" TYPE="ext4" PARTUUID="7d8d5d29-75fd-47e6-90fa-c2cca35dc718"
/dev/sda9: UUID="92eedf2c-6dcd-49fd-a590-941594242c17" TYPE="swap" PARTUUID="3e8490fc-6f1e-4e99-a656-5117dcd04f34"
/dev/sdb1: UUID="2018-03-27-19-11-24-00" LABEL="MJRO1717" TYPE="iso9660"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="5C2A-FAE6" TYPE="vfat"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="bbb5c2fa-cbc2-49fa-ac57-e8ad093ca440"

[gf@raikiri ~]$ findmnt -s
/boot/efi UUID=2C67-4A74 vfat defaults,noatime
/ UUID=92aaf4b4-6eb5-471d-a2c2-1ee8f7c40e34 ext4 defaults,noatime
swap UUID=92eedf2c-6dcd-49fd-a590-941594242c17 swap defaults,noatime

[gf@raikiri ~]$ efibootmgr -v
BootCurrent: 0018
Timeout: 2 seconds
BootOrder: 0018,0001,0014,0016,0000,0015,0017,0019,001A,001B
Boot0000* Windows Boot Manager HD(1,GPT,38138a56-0d5d-419c-86a1-a13070e583ef,0x800,0x82000)/File(\EFI\ubuntu\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* ubuntu HD(1,GPT,38138a56-0d5d-419c-86a1-a13070e583ef,0x800,0x82000)/File(\EFI\ubuntu\shimx64.efi)
Boot0010 Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011 Boot Menu FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0012 Diagnostic Splash FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013 OilDiagApp FvFile(f8397897-e203-4a62-b977-9e7e5d94d91b)
Boot0014* USB FDD: VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0015* ATA HDD: VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a4)
Boot0016* ATA HDD: WDC WD10SPCX-24HWST1 PciRoot(0x0)/Pci(0x17,0x0)/Sata(2,0,0)..bYVD.A...O...
ATAPI CD: VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
Boot0018* USB HDD: VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot0019* USB CD: VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot001A* PCI LAN: EFI Network (IPv4) PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)/MAC(54ee75a395e2,0)/IPv4(,0,0)x.J.+.N.....=8.
PCI LAN: EFI Network (IPv6) PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)/MAC(54ee75a395e2,0)/IPv6([::]:<->[::]:,0,0)x.J.+*.N.....=8.

You did make sure Safe Boot was turned off in the bios right?
I think Ubuntu has a signed boot loader

Right, @Exidious
Manjaro is not listed in efibootmgr after grub-install.
Looks like another case of Lenovo refusing to put it in its uefi firmware.
Like here, here, here, here, here and many more.

If you do not have Ubuntu any more, you can use that to overide it and 'fake' Manjaro as that 'ubuntu' bootentry 0001 as was done on one of these links. as follows.

  1. Boot into Manjaro (as before, follow the link)
  2. At terminal,
    sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/ubuntu/shimx64.efi
    sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/boot/bootx64.efi
    sudo efibootmgr -o 0001,0000

If you still have ubuntu (you said 'had') and want to keep it, follow one of the other links and override the windows boot efi (copy over the windows efi one directory up first).

Good luck.

Can you presently able to boot Windows?
Looks like you can't, Your windows efi looks like it's using ubuntu grubx64.efi ?!
If you still have windows and after making it able to boot manjaro as above.
Do a 'update-grub' to enable windows into its grub menu.

[Errata] should be... (sorry)
sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/ubuntu/shimx64.efi
sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/ubuntu/grubx64.efi

1 Like

Need new post so OP can be aware of bad error above. Sorry.

Should be.....
At terminal,
sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/ubuntu/shimx64.efi
sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/boot/bootx64.efi
sudo efibootmgr -o 0001,0000

I think there's still something wrong in the commands because I get an error

[gf@raikiri boot]$ sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/ubuntu/shimx64.efi
cp: cannot create regular file '/boot/efi/ubuntu/shimx64.efi': No such file or directory

From what I get I should move the file to overwrite the ubuntu's shim64.efi. Then, I would use this command instead, is it correct?
[gf@raikiri boot]$ sudo cp /boot/efi/EFI/Manjaro/grubx64.efi /boot/efi/ubuntu/shimx64.efi

I also add the filelist of the boot directory, if needed
[gf@raikiri boot]$ tree
├── efi
│ ├── BOOT
│ │ └── BOOT.SDI
│ ├── EFI
│ │ ├── Boot
│ │ │ └── bootx64.efi
│ │ ├── EFI
│ │ │ └── manjaro
│ │ │ └── grubx64.efi
│ │ ├── Manjaro
│ │ │ └── grubx64.efi
│ │ ├── Microsoft
│ │ │ ├── Boot
│ │ │ │ ├── BCD
│ │ │ │ ├── BCD.LOG
│ │ │ │ ├── BCD.LOG1
│ │ │ │ ├── BCD.LOG2
│ │ │ │ ├── bg-BG
│ │ │ │ │ ├── bootmgfw.efi.mui
│ │ │ │ │ └── bootmgr.efi.mui
│ │ │ │ ├── bootmgfw.efi
│ │ │ │ ├── bootmgr.efi
│ │ │ │ ├── bootspaces.dll
│ │ │ │ ├── BOOTSTAT.DAT
│ │ │ │ ├── boot.stl
│ │ │ │ ├── .....
│ │ │ └── Recovery
│ │ │ ├── BCD
│ │ │ ├── BCD.LOG
│ │ │ ├── BCD.LOG1
│ │ │ └── BCD.LOG2
│ │ └── ubuntu
│ │ ├── fw
│ │ ├── fwupx64.efi
│ │ ├── grub.cfg
│ │ ├── grubx64.efi
│ │ ├── mmx64.efi
│ │ └── shimx64.efi

OOPS again. Very sorry. I need to be more careful.
sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/ubuntu/shimx64.efi

Should be

sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/EFI/ubuntu/shimx64.efi

One extra 'EFI' is missing.

You can check with 'ls' command on the right path, for example... (you may need sudo)
ls /boot/efi/
ls /boot/efi/EFI/
ls /boot/efi/EFI/manjaro/
ls /boot/efi/EFI/ubuntu/

Your tree is fine if we can see through the branches.

Good luck again.
ps: I used shimx64.efi because it is in your efibootmgr 0001
in the other examples of the link, we have to use only windows efi file because it is the only one there.


Thanks a lot, that did the trick :grin:

1 Like

Wonderful, very glad to hear that.


Addressing you after OP fix the issue.
You said 'safe boot', I think you mean 'secure boot'. In the other cases and I suspect in this one also, secure boot is turned off. The reason why I think Ubuntu works for Lenovo is that it uses 'shim' which is the 'microsoft key' thingy that Lenovo restricts to booting up only microsoft keys.

Hope that explains. But if you have other input, glad to hear from you.
I don't have Lenovo (or HP) and what I know is learned from others like Exidious here.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by