fzf freezes with fish since last update

Hi,

I recently update my system and after that, I notice that fzf keybindings doesn't work anymore in my shell (fish). When I do a Ctrl-R to search in history, it stucks and do nothing. Any input is dropped and I only can do Ctrl-C a lot to quit it.

I notice that fzf is called during the Crtl-R (I see it in the terminal process name).
I also notice that fzf works when I run it directly in the terminal.

So, my questions are :
Did anyone has the same issue ?
Do you know if it's a bug from fish or fzf or a mix-up of both ?

Any advice or input is welcome (a link to the bug if reported, etc ...)

Thanks in advance

PS : I'm not sure it's relevant but I use KDE and I run fish in Konsole (or plugin for KDE apps like Dolphin or Kate). Even Yakuake has the same behaviour.

Hi there,
this is the bug in the fish itself

and also this one

we would I need to wait until the new version of the fish will be released :-/

Thanks a lot, that's what I was looking for :wink:

Now fixed with today update :+1:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by