GA-990XA-UD3 How can i dual boot windows / manjaro UEFI manual setup

GA-990XA-UD3 rev1.1
This is one of those old gigabyte hybrid EFI boards. If you look up it's known to not support UEFI but i always used it in UEFI mode without any issues. All i did was install windows MBR then convert to GPT using EaseUS partition master bootable. It's been running that way ever since.
Under system information it shows up UEFI. It is not BIOS/GPT it is UEFI/GPT.

The problem is, it just isn't possible to boot uefi removable media with this computer. When i install stuff on other pc and then plug the drive in i can boot uefi just fine but on this computer it's impossible to install anything UEFI. I want to dual boot manjaro but the windows installation is in UEFI mode and there is no way to install Manjaro alongside that because i can only boot legacy.

I do not want to go back to MBR either. Because i tried my laptop's dual booting win manjaro setup on it and it works just fine. Btw my laptop does not support legacy boot.

[n@n-desktop ~]$ efibootmgr
BootCurrent: 0000
Timeout: 3 seconds
BootOrder: 0000
Boot0000* OsLoader0000

I installed this UEFI manjaro system on another pc and it boots fine here as well. If i didn't post this people would be telling me that maybe it's not running UEFI after all.

I tried burning installation iso to another hard drive and it boots fine but because the board does not have any UEFI related setting i cannot force it to boot in UEFI mode. I tried making my own manjaro iso, deleted the boot.img and the other hybrid boot img thing but then it complains that i'm trying to run uefi booting legacy.

What i want?

  1. A way to manually set up dual boot.
  2. A way to force manjaro iso to boot UEFI only. Seems more convenient ofc.

It's not really a great deal to me, i don't boot this pc often other than specific tasks but for the feeling of achievement i want to run UEFI dual boot on it if there is a way.
I can always install on my other UEFI board and switch back, that works for windows fine but for manjaro idk how it handles that switch. Though atm, it looks like it's working fine.
Any help is appreciated.

Burn the iso with mbr partitioning (on pendrive),
You will find two options like "Manjaro* [UEFI]" and "Manjaro*"
Boot with the first one

Thanks, how do i burn it that way? I always use rufus. Which application do i need?

It appears this motherboard actually supports booting EFI from dvd.
Got a dvd drive, set dvd boot to EFI only and it booted fine, while i'm typing manjaro is being installed. Efibootmgr command works as expected.
I'll update when it's done.
Edit: Installed fine.

1 Like

Sorry,for replying late,actually I wasn't online,
However gpad to hear the issue solved.

1 Like

However, if you want to use check the label partitioning scheme and set the next dropdown menu to mbr, If it is grayed then don't load the iso, format it with mbr first then burn manjaro iso on the pendrive,
Hope this would be helpful for the next time

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by