Gamepad recognized, but does not work

Hello everyone,

I tried using my Trust GXT 540 Gamepad on Manjaro Linux. It's Layout is identical to an XBox 360 gamepad an it's also recognized by lsusb as such: Microsoft Corp. Xbox360 Controller. I use xboxdrv but have also tried to use xpad, but no input is recognized. This is my xboxdrv configuration file:

 [xboxdrv]
silent = true
device-name = "Microsoft Corp. Xbox360 Controller"
mimic-xpad = true
deadzone = 4000

[xboxdrv-daemon]
dbus = disabled

This is the status of the driver daemon:

● xboxdrv.service - Xbox controller driver daemon
   Loaded: loaded (/usr/lib/systemd/system/xboxdrv.service; disabled; vendor preset: disabled)
   Active: active (running) since Sat 2019-10-19 10:46:19 +01; 24min ago
     Docs: man:xboxdrv(1)
  Process: 12193 ExecStart=/usr/bin/xboxdrv --daemon --detach --pid-file /var/run/xboxdrv.pid -c /etc/default/xboxdrv --detach-kernel-driver --deadzone 4000 --deadzone-trigger 10% (code=exi>
 Main PID: 12194 (xboxdrv)
    Tasks: 2 (limit: 4915)
   Memory: 3.0M
   CGroup: /system.slice/xboxdrv.service
           └─12194 /usr/bin/xboxdrv --daemon --detach --pid-file /var/run/xboxdrv.pid -c /etc/default/xboxdrv --detach-kernel-driver --deadzone 4000 --deadzone-trigger 10%

Okt 19 10:46:19 [MY_PC_NAME] systemd[1]: Starting Xbox controller driver daemon...
Okt 19 10:46:19 [MY_PC_NAME]  systemd[1]: xboxdrv.service: Can't open PID file /run/xboxdrv.pid (yet?) after start: No such file or directory
Okt 19 10:46:19 [MY_PC_NAME]  systemd[1]: Started Xbox controller driver daemon.
lines 1-14/14 (END)

When running jstest, I get the following result:

Driver version is 2.1.0.
Joystick (Microsoft X-Box 360 pad) has 8 axes (X, Y, Z, Rx, Ry, Rz, Hat0X, Hat0Y)
and 11 buttons (BtnA, BtnB, BtnX, BtnY, BtnTL, BtnTR, BtnSelect, BtnStart, BtnMode, BtnThumbL, BtnThumbR).
Testing ... (interrupt to exit)
Axes:  0:     0  1:     0  2:-32767  3:     0  4:     0  5:-32767  6:     0  7:     0 Buttons:  0:off  1:off  2:off  3:off  4:off  5:off  6:off  7:off  8:off  9:off 10:off

Thanks in advance for any advice or solution.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by