Games running slower on my PC with Linux

So I have been on Windows 7 for a while and I understood switching to Linux would make it so I would have to force a handful of the games I play to work. I understand that. However games like TF2 I have to run at very specific setting in order to get them to play at a somewhat constant frame-rate. I want to know how to optimize my PC to better run games that should be working fine like STALKER and HOI 4 here are my specs. I heard Nvidia has always had problems with Linux. Ask more questions if you think it would help me out.
Thanks in advance.

Kernel: x86_64 Linux 5.2.21-1-MANJARO
OS: Manjaro 18.1.2 Juhraya
CPU: Intel Core i7-2700K @ 8x 3.9GHz [40.0°C]
GPU: NV126
RAM: 2718MiB / 7891MiB

Please provide some extra info on your system

Not really. Nvidia drivers are closed source which obviously is not what you want on an open source system, but they work rather well on dedicated single graphics systems since more than a decade.

HOI4 is CPU intensive but light on graphics. In later stages of the game it can get very slow even on high-end system, possibly due to the fact that the engine is single-threaded.

But you must provide more system information as linux-aarhus pointed out above.

Thank you for this info, I am still very new to GNU/Linux

System: Kernel: 5.2.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=1fbd5885-6610-4c73-813d-9f37b5f15d42 rw
quiet apparmor=1 security=apparmor udev.log_priority=3
Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0
Distro: Manjaro Linux
Machine: Type: Desktop Mobo: Gigabyte model: Z68X-UD3H-B3 serial: BIOS: Award v: F10 date: 10/12/2011
CPU: Topology: Quad Core model: Intel Core i7-2700K bits: 64 type: MT MCP arch: Sandy Bridge family: 6
model-id: 2A (42) stepping: 7 microcode: 2F L2 cache: 8192 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 55898
Speed: 1596 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1596 2: 1596 3: 1594 4: 1597 5: 1596
6: 1596 7: 1596 8: 1597
Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Graphics: Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Gigabyte driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:0122
Device-2: NVIDIA GM206 [GeForce GTX 960] vendor: Gigabyte driver: nouveau v: kernel bus ID: 01:00.0
chip ID: 10de:1401
Display: x11 server: X.Org 1.20.5 driver: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa
resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: NV126 v: 4.3 Mesa 19.2.2 direct render: Yes
Audio: Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20
Device-2: NVIDIA GM206 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:0fba
Device-3: Focusrite-Novation type: USB driver: snd-usb-audio bus ID: 1-1.5.2:5 chip ID: 1235:8205
Sound Server: ALSA v: k5.2.21-1-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169
v: kernel port: ee00 bus ID: 07:00.0 chip ID: 10ec:8168
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 931.51 GiB used: 410.26 GiB (44.0%)
ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1ER162 size: 931.51 GiB block size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: CC46 scheme: MBR
Partition: ID-1: / raw size: 931.51 GiB size: 915.89 GiB (98.32%) used: 410.26 GiB (44.8%) fs: ext4
dev: /dev/sda1
Sensors: System Temperatures: cpu: 30.0 C mobo: N/A gpu: nouveau temp: 26 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 705
Info: Processes: 208 Uptime: 5m Memory: 7.71 GiB used: 1.53 GiB (19.9%) Init: systemd v: 242 Compilers:
gcc: 9.2.0 Shell: bash v: 5.0.11 running in: xfce4-terminal inxi: 3.0.36
Also I have heard good things about Bumblebee, However I don't know what provider to choose.

you dont need bumblebee drivers ,
only nvidia drivers
try with version 430xx series ( no free drivers )
go to manjaro setting , select drivers videos ,
and reboot

1 Like

This worked perfectly. Solved my problem thank you

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by