Gaming SLI setup - Multiple Monitors - XORG - troubleshooting

EDIT:I accidently hit post, before I was done writing, that's why I temporaly marked this post for deletion

Hello Community,

This is going to be a long one, as I've been having issues with this for a long, long time and only now post about it because I'm out of ideas.

As the title suggests, I tried to get my setup to work on Manjaro. I'm not the kind of person who gives up quick, I chose manjaro as a linux noob on purpose, because I think one can only learn when things break or don't run out of the box.
So, for my issue(s) I read the archwiki, searched forums and posts even outside arch based systems and tried ALOT of stuff.

Overview: Dump your "inxi -Fxxxza --no-host" here and bookmark it
My setup: I've got 2 Monitors (4k and 1080p) + an AV-Receiver which acts like another Monitor via HDMI, only to process my PCs audio. This AVR can (and does) pass through the 1080p signal to my second monitor no problem, as that's the intended purpose (and the reason why on paper I only have 2 Monitors!)
Further, I've got 2 TeamGreen 980ti's which previously ran in SLI to power my 2 Monitors on my Windows setup before I switched.
(To clarify: I only game on the 4k Monitor, with the second monitor as an assistant for quest help, maps, spreadsheets,...)
If I get this to work OR get answers as to why it's not possible this way on Linux, I consider this post solved.

Let's talk about the instructions and my general understanding:
SLI is having multiple cards working together to calculte the frames.
SLI with multiple Monitors is NOT supported in Linux, EXCEPT for SLI = "MOSAIC"
-> SLI MOSAIC is only for quadro cards (?): If you have an SLI configuration and each GPU is a Quadro FX 5800, Quadro Fermi or newer then you can use SLI Mosaic mode. - arch wiki
Also arch wiki: If you have multiple cards that are SLI capable, it is possible to run more than one monitor attached to separate cards (for example: two cards in SLI with one monitor attached to each). The "MetaModes" option in conjunction with SLI Mosaic mode enables this.

What did I do?
Yes, I've been trying for weeks now, so let me share only the key things I've done.
Basically, I used the same setup from Windows when I switched over:
2 Monitors on one GPU, in the XORG.conf set SLI to MOSAIC (AUTO, ON, AA,... would straight up crash after login)
xorg.conf from my backup:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 430.40

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer XB280HK"
    HorizSync       30.0 - 140.0
    VertRefresh     30.0 - 70.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 980 Ti"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 980 Ti"
    BusID          "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "DP-2: 3840x2160_60 +0+0 {ForceCompositionPipeline=On}, HDMI-0: 1920x1080 +3840+10 {ForceCompositionPipeline=On}"
    Option         "SLI" "MOSAIC"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Eventually I noticed in the Xorg.log, that SLI waas disabled, because my setup was wrong. It sent me over to the XORG documentation, which said the same as arch wiki: put each monitor in a seperate GPU

So that's whaat I did and this is how my config looks now:

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection


Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection


Section "Device"
        Identifier      "Card A"
        Driver          "nvidia"
        BusID           "PCI:1:00:0"
EndSection


Section "Device"
        Identifier      "Card B"
        Driver          "nvidia"
        BusID           "PCI:2:00:0"
EndSection


Section "Monitor"
        Identifier      "Right Monitor"
EndSection


Section "Monitor"
        Identifier      "Left Monitor"
EndSection


Section "Screen"
        Identifier      "Right Screen"
        Device          "Card B"
        Monitor         "Right Monitor"
        DefaultDepth    24
        Option          "SLI" "Mosaic"
        Option          "Stereo" "0"
        Option          "BaseMosaic" "True"
        Option          "metamodes" "GPU-27f23ee2-fdae-0271-e491-038e6975f972.GPU-0.DP-2: nvidia-auto-select +0+0 {ForceCompositionPipeline=On}, GPU-1b9ddc81-1d7f-3c7f-f8b6-22be029ba631.GPU-1.HDMI-0: nvidia-auto-select +3840+10"
        Option          "MultiGPU" "Off"
        SubSection      "Display"
                        Depth           24
        EndSubSection
EndSection


Section "Screen"
        Identifier      "Left Screen"
        Device          "Card A"
        Monitor         "Left Monitor"
        DefaultDepth    24
        Option          "SLI" "Mosaic"
        Option          "Stereo" "0"
        Option          "BaseMosaic" "True"
        Option          "metamodes" "GPU-27f23ee2-fdae-0271-e491-038e6975f972.GPU-0.DP-2: nvidia-auto-select +0+0 {ForceCompositionPipeline=On}, GPU-1b9ddc81-1d7f-3c7f-f8b6-22be029ba631.GPU-1.HDMI-0: nvidia-auto-select +3840+10"
        Option          "MultiGPU" "Off"
        SubSection      "Display"
                        Depth           24
        EndSubSection
EndSection


Section "ServerLayout"
        Identifier      "Default"
        Screen 0        "Left Screen" 0 0
        Option          "Xinerama" "0"
EndSection

INTERESTINGLY most proton games straight up crash now and when I launch Warframe via wine-staging (Yes, I know - GloriousEggroll), my PC makes this loud coil whine sound (hard to tell but sounds like it's coming from the GPUs) which almost sounds like a short circuit - I'm not kidding.
Thinking my GPUs failed, I booted up my old Windows install and fired up valley benchmark ... Everything was nice and quiet (you can hear everything quite well due to the silent watercooling) and SLI was working perfectly. So.. what the ■■■■■

Now, after reading here and there I haven't found clear instructions on how to properly setup SLI and xorg for my use case.
I can now set SLI=AUTO or ON or whatever, but (sudo) nvidia-settings -q all | grep SLIMode doesn't output anything.

I'll leave it at that for now. If anyone has suggestions on what to try or do I'm happy to do it or tell you about the results as I might have already done that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by