GeForce GTX 1650: Bumblebee - probe routine failed

Hi there!

My new Dell XPS15 7590 contains a dual graphics Intel + Nvidia GeForce GTX 1650 setup.

The automatically installed video-hybrid-intel-nvidia-418xx-bumblebee driver package sadly doesn't work for me. I've added my user to the bumblebee to be able to use the optirun tool, but running optirun glxgears doesn't show any gears but instead prints

[ 4739.068317] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card
[ 4739.068411] [ERROR]Aborting because fallback start is disabled.

And gives this output in dmesg:

[Jan10 17:36] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  +0.000404] NVRM: The NVIDIA GPU 0000:01:00.0
              NVRM: (PCI ID: 10de:1f91) installed in this system has
              NVRM: fallen off the bus and is not responding to commands.
[  +0.000009] nvidia: probe of 0000:01:00.0 failed with error -1
[  +0.000011] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  +0.000000] NVRM: None of the NVIDIA devices were initialized.
[  +0.000106] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237

I've tried to replace the driver package with the newer version video-hybrid-intel-nvidia-430xx-bumblebee and adding the nouveau.modeset=0 kernel parameter but that didn't help.

I've found this guide on the arch wiki:
https://wiki.archlinux.org/index.php/Dell_XPS_15_7590#NVIDIA_Optimus

And tried to follow it, but it seems the out of the box bumblebee setup I get from Manjaro doesn't contain a few of the nvidia modules this script wants to use:

./gpucli --on
mv: cannot stat '/etc/modprobe.d/disable-nvidia.conf': No such file or directory
Turning the PCIe controller on to allow card rescan
on
Waiting 1 second
Turning the card on
on
Loading module nvidia
modprobe: ERROR: could not insert 'nvidia': No such device
Loading module nvidia_uvm
modprobe: ERROR: could not insert 'nvidia_uvm': No such device
Loading module nvidia_modeset
modprobe: ERROR: could not insert 'nvidia_modeset': No such device
Loading module nvidia_drm modeset=1
modprobe: ERROR: could not insert 'nvidia_drm': No such device

How to go on? Can I use the GeForce GTX 1650? (on demand, I don't want it on all the time..)

Hi,

Have you tried one of the other options for hibrid laptops?


For instance, did you try Optimus-Switch?

1 Like

Thanks for the link! It required quite a bit of playing around but now I got the optimus-manager setup working. I preferred the Bumblebee setup I had working on my last laptop (without needing to logout and login again to switch GPUs) but this is better than not being able to use the Nvidia at all (or not beeing able to switch between Intel & Nvidia at all).

Thank you!

hmm, well my optimus-manager setup is not really too stable, quite often when I switch from intel (=default) into nvidia mode the desktop won't start and I have to reboot using a tty to get back into KDE.

Is there some other way to make it try again? strg+alt+backspace doesn't do anything for me..

Another issue I ran into: when in nvidia mode and putting the laptop to sleep: after waking up it just told me that the "gpu fell off the bus" and didn't get me back into the desktop-environment and didn't let me switch to a tty with strg+alt+F2.. (so I had to do a hard reboot)

can somebody help me get this nvidia card to work with manjaro?

Since the state I left it in last time didn't work well (only rarly made it into X in nvidia mode)
I tried to fiddle with that stuff again while reading those pages:

But now it doesn't work at all anymore...

$ sudo modprobe nvidia
modprobe: ERROR: Error running install command for nvidia
modprobe: ERROR: could not insert 'nvidia': Operation not permitted

When you change from one option to the other, you must make sure you revert whatever you did previously, otherwise is more likely you will end up with a broken system because of mixing things.

1 Like

thanks for your reply, though to be honest it's not the kind of help I hoped for.

Since I was not that careful that I exactly documented everything I did because some guide or other told me to - with your message I can see 3 options for me:

  1. live with the broken nvidia state I got now and just stick with the intel integrated graphics
  2. start over, do a fresh system installation and very carefully document every little thing I change on the system and hope I then get it to work on my own or that I find somebody (you?) who is then willing to help me make it work
  3. wait / look / ask for more involved help / guide / troubleshooting.

I'm gonna try to document in more detail the what and how of my nvidia gpu not working as I'd like:

bumblebee

with video-hybrid-intel-nvidia-430xx-bumblebee or video-hybrid-intel-nvidia-418xx-bumblebee installed through the tool kcmshell5 msm_mhwd will give this output when used:

$ optirun glxgears
[18733.066404] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[18733.066494] [ERROR]Aborting because fallback start is disabled.

At the same time dmesg shows this:

[Feb 4 23:33] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  +0.000575] NVRM: The NVIDIA GPU 0000:01:00.0
              NVRM: (PCI ID: 10de:1f91) installed in this system has
              NVRM: fallen off the bus and is not responding to commands.
[  +0.000008] nvidia: probe of 0000:01:00.0 failed with error -1
[  +0.000028] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  +0.000001] NVRM: None of the NVIDIA devices were initialized.
[  +0.000437] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237
[  +0.367000] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  +0.000700] NVRM: The NVIDIA GPU 0000:01:00.0
              NVRM: (PCI ID: 10de:1f91) installed in this system has
              NVRM: fallen off the bus and is not responding to commands.
[  +0.000010] nvidia: probe of 0000:01:00.0 failed with error -1
[  +0.000011] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  +0.000001] NVRM: None of the NVIDIA devices were initialized.
[  +0.000394] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237
[  +0.351719] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  +0.000848] NVRM: The NVIDIA GPU 0000:01:00.0
              NVRM: (PCI ID: 10de:1f91) installed in this system has
              NVRM: fallen off the bus and is not responding to commands.
[  +0.000009] nvidia: probe of 0000:01:00.0 failed with error -1
[  +0.000015] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  +0.000000] NVRM: None of the NVIDIA devices were initialized.
[  +0.000134] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237
[  +0.380448] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  +0.001000] NVRM: The NVIDIA GPU 0000:01:00.0
              NVRM: (PCI ID: 10de:1f91) installed in this system has
              NVRM: fallen off the bus and is not responding to commands.
[  +0.000028] nvidia: probe of 0000:01:00.0 failed with error -1
[  +0.000015] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  +0.000000] NVRM: None of the NVIDIA devices were initialized.
[  +0.000539] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237

gpucli

When I instead install video-nvidia-440xx that will make the script gpucli referenced in the arch wiki page for my laptop works to enable the nvidia GPU for CUDA.

nvidia-xrun

the "normal" nvidia-xrun AUR package doesn't seem to work because it tries to use bbswitch which doesn't seem to work on my laptop, but when I instead install nvidia-xrun-git it did work in starting a single application (from tty) with my nvidia gpu. But I was not able to switch back to my normal KDE session using Strg-Alt-F1 while it ran, and after I closed that single application running without a desktop session the system froze up and needed a hardware shutdown.

optimus-manager

When I try to switch to nvidia it logs me out (as designed) but never brings back a desktop. I can switch to a tty and restart the system to get back to an intel desktop.
Is there a way to restart just the window manager without restarting the system from tty? I tried systemctl restart sddm but that just flickered the screen a bit.

I understand, but there are no other options i know about, only those already mentioned and probably tested by you. On some models i noticed is needed more fiddling with kernel boot parameters. For instance:

Maybe can be solved by using:
pcie_port_pm=off rcutree.rcu_idle_gp_delay=2
as kernel boot parameter. Maybe only the second one is needed. But it might not work on all the mentioned options, or maybe for one will have a more negative result ...

In other instances you need to stick with one kernel. Maybe using the 4.19

I honestly don't understand what you are doing.
If optimus-manager and optimus-switch require the restart of the system, as described in their how to, why do you still insist on starting just the WM?

Have you checked this?


But take the time to understand what they are talking about ...

Could you point me to where it says that? optimus-manager the way I understood it should end the X session using the intel GPU and restart just the X session using the nvidia GPU (without rebooting the machine). That sadly doesn't seem to work for me, The nvidia X session doesn't come up.

I now found I can successfully switch between the app started with nvidia-xrun from a tty back to my normal KDE session and from there back to the nvidia tty - but only if I switch to a third terminal-only tty in between. When I switch directly from the nvidia-xrun session to the KDE session it will crash the KDE session.

Sadly I can't find the relevance of the "NVIDIA offloading not powering down GPU" thread to my situation, could you try to elaborate on what you want me to get from there?

I was just looking for a faster way to get back into a WM after it crashed than to reboot the whole system...

I must admit i did read that documentation some time ago, so maybe the reboot part is not required to optimus-manager, or maybe this part is not quite clear

and might mean is to restart the session only, not actually a reboot ... but i can't tell. Sometimes language can be tricky especially in technical jargon.

Now I found a solution that I like and that seems stable for now:

With the driver package video-nvidia-440xx which allows the gpucli script to turn on and off the nvidia GPU for CUDA (and not one of those including bumblebee like video-hybrid-intel-nvidia-430xx-bumblebee) installed, and manually adding the package bumblebee in pamac-manager the included optirun tool works if I manually turn on th nvidia GPU with the gpucli script beforehand.

1 Like

I' not sure if I understood what the solution really is. It looks like some sort of bumblebee but with script? Never heard about it.

Bubmblebee doesn't support Vulkan and has worse performance than other solutions. This is why we shun from Bumblebee these days. If you want to Play games and use Proton, you need to use something else. On bumblebee when you launch Witcher 3 you will see complaint that you do not meet GPU minimum requirement because of that.

Nvidia-xrun is a better solution, although less comfortable and uses a bit more resources, but in my experience it was practically negligible, so I was able to play Witcher 3 with it and was happy with the performance.

Optimus-switch needs a reboot, optimus-manager needs DE/DM session restart (so no reboot needed).

In a way, nvidia-xrun also needs session restart because it creates another, parallel session, that is why it's working.

1 Like

The solution that works for me now is:

  • in the setup tool titled "Hardware Configuration" uninstall all nvidia drivers like video-hybrid-intel-nvidia-*xx-bumblebee and *-primus and instead install only video-nvidia-440xx.

  • That driver allows this script, which I found on the arch wiki page for my laptop, to turn the nvidia GPU on and off.

  • To use the GPU with applications that don't require Vulcan, I found that the optirun tool included in the community package bumblebee (Version 3.2.1-22) works if I first turn on the GPU with the script from the previous point.

  • For applications that require Vulcan I was able to use nvidia-xrun app in a tty, though this crashes the whole system if one tries to switch from that tty directly back to the KDE session. I can switch back and forth between KDE and the nvidia-xrun tty if I go through another, non graphical tty in between the KDE & the nvidia-xrun session.

  • optimus-manager worked for a few times when I first set it up, but now every time I try to switch to into an nvidia session the whole system crashes and I need to hardware reboot (so instead I use bumblebee where possible and nvidia-xrun when Vulcan is required)

1 Like

Yeah, that's a standard bug. I had this issue too when I used nvidia-xrun, although the behavior was not consistent, sometimes it crashes but not all the time.

Here is my topic for nvdia-xrun:

As for optimus-manager, there are many logs to analyze to discover what is the issue: optimus-manager log, systemd log, display manager log, xorg log, kernel log. Usually, somewhere you will find the root of the issue. I posted the findings to optimus-manager developer (on github page) and the result was some fix.

Optimus-manager is the most convenient and flexible solution because you can switch options with few clicks and can use various drivers. For example, I use Intel mode with modesetting drivers which allows me to use multi-monitor setup for me. Manjaro's bumblebee setup was either all non-free or all free, so obviously this was forced me to use all non-free drivers, so it was using Intel closed source drivers and that blocked the output for the additional monitor. Now that I use modesetting (free driver) all works fine. Additionally, modesetting with nouveau in Intel mode also can trigger nvidia on demand but using nouveau drivers, which works great for some older games, especially those with Nvidia bugs (HOMM V). So in the end I can use intel modesetting, nouveau and Nvidia non-free drivers whenever I need them with easy session restart.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by