Getting fresh install up and running by a Manjaro newbie

Sharing the experience of a fresh install of XFCE Manjaro 18.0 by and explaining some hiccups that came up and how they were solved (or disappeared).

  • Creation of boot USB, live boot and installation went without a hitch. Here is the method I prefer: [howto] writing Manjaro ISOs to USB with dd

  • Followed these guidelines for updating using pacman. [wiki] UPDATES and IMPORTANT pacman knowledge ; Applying manjaro update from TTY ; rebooted the system.

  • First problem was the absence of tab-completion in terminal emulator which was fixed with help from the forum. Tab-completion shows installed executables instead of package names after pacman in terminal

  • Second problem was xfce4-display-settings crashing showing a segmentation fault. Similar problems were reported on the forum. Time restrictions forced me to shut down to fix later and this apparently fixed the issue (without it being my intention). Seems that a reboot alone was not sufficient for some of the updates (? :thinking: ).

  • Third problem was the inability to suspend. Here is the thread for what worked for me (so far). Sporadic problems with suspend . NOTE: It involves switching to kernel 4.18. 4.19 might get a fix in near future.
    UPDATE: problem in 4.19 fixed in this stable update.

  • Last and most subtle problem was display not blanking as configured in xfce4-power-manager. Got it working satisfactory for me with this: Xfce power management settings for display has no effect . At least one of the display modes (blank, stand-by or power-off) are triggered requiring a password on resume and suspends after inactivity as configured. Not really a solution and the real problem is still unknown to me, but "if it works it ain't stupid", right? :drooling_face:

  • I also picked up that a special character map was missing which I use often for characters with " or ^ on top. Just installed gucharmap to fix this.

  • That's it. Everything else seems to be in working order. PDF files open up, multiple audio and video formats play without any problems. None of that "install ubuntu-extras" for those familiar with Ubuntu seems to be necessary.

Now it just a matter of tailoring it to suit me as a daily driver :red_car:..

6 Likes

manjaro mounts /tmp in RAM so perhaps your RAM needed clearing, sometimes on modern systems RAM can retain data after a reboot when the power hasn't been cycled as well.

1 Like

Thank you for the clarification @anon71843593 . I had this (wrong) idea that it might be kernel related meaning that all updates excluding that of the kernel could have already taken effect without requiring a reboot, but this was a wild guess of a novice. I am not yet familiar with exactly how the "cogs" of the system operate.

as far as I'm aware manjaro doesn't have the live kernel patching system as of yet so a reboot is still necessary for kernel updates anyhow. if you come across this situation again in the future the power cycling tip is simply to remove voltage from RAM so that any residual data is also purged but you need to leave it about 30 seconds to be sure that power has drained from RAM completely.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by