Getting MS-Office Online to work

The page say try for free for a month then monthly payment or $100 per year over a couple of years that adds up.
Plus where I live its not supported by Ms and it needs very fast internet to work something 90% of the world has not.
This is the Ms future install windows for free then pay monthly to sign in and use it

Returns white page only instead of login page with VPN enable (openvpn). I don't have the same issue through firefox.

I appreciate this effort, I have to use ms-office for work. Thanks!

Thank for your work is great idea :smiley:

1 Like

Is it possible to directly open a file from my local disk using commands like:
word /home/$USER/file.docx

If so, is it possible to associate these Microsoft Office applications as default applications to open MIME types related to these products (.docx, .doc, .ppt, etc.)

I'm using Palemoon as browser. Seems we miss some standard Firefox ships ...

I cannot also start any of the office online apps.. I am running testing Manjaro Kde Pre_1 17.0.6 and I have qupzilla and firefox-developer browsers installed. I also have a 365 Microsoft Office account...but it does not work any of them..start and then close as shut down..


Firefox activates my Ms 365 online account fine though.

I will try and check this in my stable manjaro kde...weird though. Any tips ?

please install webkit2gtk.

1 Like

Thank, but I still get the same error. Word, Excel and Powerpoint work, but OneNote does not with the said error message. Also Outlook doesn't work, but there is no error message or anything, just a white screen when trying to open the program.
If I open the general "Microsoft Office Online" program, I can login and it shows the welcome screen where I can select a program.
Screenshot_20171028_175152

But the result from here is the same. Outlook only displays a white screen and OneNote displays the error message that I can't be signed in right now (although I am signed in).

Thanks @philm , now it is working fine , it opens MS Office online good! Thanks, mate.
Screenshot_20171028_162911

Issues with Outlook launcher is fixed now.

1 Like

Thanks for the great app . I open some pdf files via ms-office writer. After editing some things "download a copy" option not work but it work when I use web browser.

OneNote finally works now. I guess the last few updates did the trick :grin:

This piqued my interest so I tried it out. I like the concept, but I have to log in every time I open it even if I check the remember me box. Kind of defeats the purpose if its slower to get into then using the browser (due to having to log into it every time).

It should work now. Simply update your system mate and give me your feedback.

After clicking Download button happens nothing :confused:
Linux onem-pc 4.9.60-1-MANJARO #1 SMP PREEMPT Thu Nov 2 13:08:20 UTC 2017 x86_64 GNU/Linux

4.9.60-1-MANJARO #1 SMP PREEMPT Thu Nov 2 13:08:20 UTC 2017 x86_64 GNU/Linux

Office 365 Online- Work fine, for me.

Firefox 56.02 and Gnome Versión 3.26.2Captura de pantalla de 2017-11-10 10-27-54Captura de pantalla de 2017-11-10 10-28-24

Check your Download folder, your file should be there.

I already checked. I reinstalled the app but same result.
İnteresting. It saved when I choose save as .odt but not .docx :confused:

.odt and .pdf works. .docx however has some issues with XFCE. Still don't know why.

Are you able to comment on the issue of needing to login every time I run these? Is it just me or is it a known behavior?

I've tried remember password/login and it still opens to login page every time I open one of the "apps".

Forum kindly sponsored by